Please select Into the mobile phone version | Continue to access the computer ver.
Connection to router not working
Uploading and Loding Picture ...(0/1)
o(^-^)o
RumGor
lvl.2

United States
Offline

I'm following the instructions to connect via router, but nothing seems to happen when I press the button on the robot. It doesn't seem like it's even trying to scan the QR code. Connecting directly works fine.
Am I missing something obvious?

7-14 10:50
Use props
Saberfly
lvl.2
United States
Offline

Has the robot asked for the QR code? It will ask when ready.
7-14 11:27
Use props
RumGor
lvl.2

United States
Offline

Saberfly Posted at 7-14 11:27
Has the robot asked for the QR code? It will ask when ready.

It has not asked, but never seems to. Is there something I need to do besides hit the button and wait? And is it just a short-press of the button? If I hold the button long enough it says something like "WiFi Reset." Besides that it seems to just sit there.
7-14 14:35
Use props
Saberfly
lvl.2
United States
Offline

It took 2 times for mine to ask. It was a little slow also but just try waiting and keep trying. Naturally , make sure you didnt type your router password wrong. It's easy to do.
7-14 16:30
Use props
Saberfly
lvl.2
United States
Offline

Is the switch on the robot in the right position? It's not on phone direct mode?
7-14 20:09
Use props
Malibu Aerial
lvl.4
Flight distance : 143898 ft
United States
Offline

RumGor Posted at 7-14 14:35
It has not asked, but never seems to. Is there something I need to do besides hit the button and wait? And is it just a short-press of the button? If I hold the button long enough it says something like "WiFi Reset." Besides that it seems to just sit there.

Launch the RoboMaster app on your phone and click Connect and then select Connect via Router.  After you enter your Router WiFi password, it will generate a QR code and you can scan that using the RoboMaster camera.
If that doesn't work, turn off the RoboMaster and stop & start the RoboMaster app.
7-14 21:41
Use props
RumGor
lvl.2

United States
Offline

Yes, the switch is in the right position. (Always good to check the obvious though!   )

I've been careful with the router pwd, but even if I had it wrong, I would expect it to get to the point of asking for the QR code.

I've restarted everything several times and it still doesn't seem to work.

I'm beginning to wonder if there is something odd in my router setup. I'll dig into that this evening if I can't get it to work otherwise by then.
7-15 09:20
Use props
Saberfly
lvl.2
United States
Offline

You get it working?
7-15 17:24
Use props
RumGor
lvl.2

United States
Offline

Nope. I'm having a couple of other issues too that are making me think either I've got a bad control unit, or the SW on it is borked (I am up to date with firmware).

When connected directly via Wi-Fi, I can control the robot manually, but the follow person feature never finds a person in the frame no matter the lighting conditions, distance etc.

Also, custom programs never execute. Even the most basic tutorial won't run when I hit the run button in the debugger.

I contacted DJI customer support. We'll see what happens.
7-15 18:39
Use props
Saberfly
lvl.2
United States
Offline

Ouch good luck. Customer service is usually less than helpful. I'd just send it back and get a new one.
7-16 06:28
Use props
daev2018
lvl.4
Flight distance : 12263740 ft
  • >>>
United States
Offline

I was getting a message that I was not connected to my router but I was. Worked fine on another Android phone so I figured it was because I'm using iOS13 beta.
7-19 17:43
Use props
RumGor
lvl.2

United States
Offline

The latest firmware update (v00.05.0026 released 7.16.2019) seems to have resolved my issues.

(Note that prior to this, I *was* up-to-date with firmware, so either my previous firmware install went awry, or some change in the new firmware fixed things. In any case, all's well now.)
7-22 08:38
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules