Please select Into the mobile phone version | Continue to access the computer ver.
DJI FPV manual INCORRECT/OSD issues
12
18541 51 2019-8-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
Charmande
lvl.4
Flight distance : 299459 ft
United States
Offline

fansc86b0d47 Posted at 10-25 07:18
You do not need OSD in Betaflight for the DJI FPV unit to get the data from the FC. As long as you properly mount the TX and RX wires to the FC and set the MSP in Ports setup of Betaflight, you'll see the data flowing into the Goggles.

Sorry I thought you were saying the new air unit fixed your issue. You're correct you don't need to have OSD setting on. Betaflight OSD is not fully enabled yet. The white and gray wires are all the matters. Yes, I did have my issue fixed. I had a bad DJI FPV air unit the whole time. Once I got a new one the problem was fixed.
2019-10-26
Use props
pt0x
lvl.1

Netherlands
Offline

Hi all, I have been reading this topic and posts because I didn't had my VBAT in the goggle display. everything else was working like PID's and stuff. Yesterday I updated to v01.00.01.00 firmware and I now have VBAT available. Just wanted to share this. Hope this works  for others that had this issue as well.
2019-11-3
Use props
Charmande
lvl.4
Flight distance : 299459 ft
United States
Offline

pt0x Posted at 11-3 02:11
Hi all, I have been reading this topic and posts because I didn't had my VBAT in the goggle display. everything else was working like PID's and stuff. Yesterday I updated to v01.00.01.00 firmware and I now have VBAT available. Just wanted to share this. Hope this works  for others that had this issue as well.

That's great. Glad to see they're finally pushing software to fix some of these mild issues.
2019-11-14
Use props
Kinjuku
lvl.1

Canada
Offline

Pim Posted at 9-21 03:33
Hello,

I've buy the T-Motor F4 HD and I've the same issue than you.

Hey,

I've got the same FC as you and was having the same issue.

What solved it for me was to go into Betaflight and under the Ports tab turn on UART2 MSP.

Hope your issue gets solved.
2019-12-4
Use props
djiuser_CherFAMeytn0
New
United States
Offline

Same problem here
2020-1-12
Use props
rogvilanggaard
lvl.1

Denmark
Offline

Kinjuku Posted at 2019-12-4 06:14
Hey,

I've got the same FC as you and was having the same issue.

This solved it for me! Thank you!
2020-1-17
Use props
djiuser_Nb2L2mXocMHM
New

United States
Offline

Charmande Posted at 2019-9-7 17:06
I will let ya know what DJI says. Sadly I feel like I may have a defective air unit. I've soldered this up to another flight controller (Tmotor F4 FC - which is recommended by DJI for their FPV system) and still no luck. There seems to be a few people with this issue ... very small but it's happening. It seems everybody else is getting batt voltage and DJI also mentioned adding more OSD functionality later so I'd say it's worth it I just hope to be able to fix this problem. Rest assured though if I do find a solution I will post it here. I am getting a new F7 flight controller that is specifically built for the DJI FPV system in on Tues and I'm curious if that one performs any differently.

Hey there , i had an air unit fail on me it now only has camera function but no receiver function my dji controller does not communicate with the flight controller. I did find that the supplied 3 in 1 harness had two wires wrong and swapped around! I compared it with two other 3 in 1 harness's that came in two different rtf dji set up quads and its verified the harness that came with the dji air unit is wired wrong. It will be the yellow wire and black wire on the end which if im understanding it correctly that would be a short... I will admit im very new to fpv quads however im skilled enough to understand and notice these things. My point for posting this is to hopefully cause some people to keep an eye out for this type of thing.    On a side note, iv noticed that all of these little harness's that have little plastic plugs on each end,  not the ones you have to solder on, if you stretch them out you will notice all the wires line up end to end... The one im having prob with doesnt.
2020-2-16
Use props
Hacky4
lvl.3

Czechia
Offline

Why you all recommend turning on the MSP for the DJI UART? I don't have MSP enabled on the DJI UART and custom betaflight OSD with voltage readings works just fine for me. How come?
2020-2-17
Use props
Hacky4
lvl.3

Czechia
Offline

Hacky4 Posted at 2-17 08:49
Why you all recommend turning on the MSP for the DJI UART? I don't have MSP enabled on the DJI UART and custom betaflight OSD with voltage readings works just fine for me. How come?

My bad, sorry. Of course I have MSP enabled for air unit UART...
2020-2-19
Use props
djiuser_Vs1Sz0xJDNjj
lvl.1
United Kingdom
Offline

Kinjuku Posted at 2019-12-4 06:14
Hey,

I've got the same FC as you and was having the same issue.

> Betaflight and under the Ports tab turn on UART2 MSP

GENIUS! This solved my (same) issue with the T-Motor F55A PRO II + F4 HD STACK not displaying Battery Voltage and/or Flight Time.

Thank you very much Kinjuku.
2020-3-8
Use props
Pukkaras
lvl.1

Russia
Offline

Have the same problem. Sad thing.. Firstly i recieve defective FC matek F405se . S1 and S2 pins was closed by them selves and baro didn't work.
When I solved my problems with matek(they send me new controller via seller from aliexprress), then i realised, when connect all to new FC, that air unit also defective. (FC now is perfect).
I cheked everything ( UART pins , air unit wire , MSP in BF, custom OSD in glasses, try to use different free UART (uart  3 and 4 ) . I wrote to tech support DJI 10minutes ago , and start waithing for the response...
2020-12-17
Use props
finneasaskewhotmail.com
lvl.1

Australia
Offline

Hello my DJI goggles are not displaying my timers any more on all of my drones vista and DJI units , it was there but has just disappeared , it still there in beta flight , and everything else comes up Sats latitude battery etc ?
1-7 15:00
Use props
12
Advanced
You need to log in before you can reply Login | Register now

Credit Rules