Please select Into the mobile phone version | Continue to access the computer ver.
Cannot turn off battery grip
185 0 9-4 14:27
Uploading and Loding Picture ...(0/1)
o(^-^)o
Horn_Bee
lvl.1
Offline

Hi, I received my Ronin-S a couple of days ago. I got it charged, set up the balance, installed the DJI app and connected to the gimbal, and updated the firmware. Everything seems to work fine, but I am not able to turn off the battery grip. The head turns on and off with no problems, but the battery grip does not respond despite following the sequence on the sticker (single press, followed by a press and hold). I have tried different sequence speeds, different hold durations, etc but I have had no change despite repeated attempts. If i leave the battery grip on over night it will turn itself off, but then the only way I can turn it back on is by plugging it into the charger again. Am I missing something?

I also noticed that the green lights will sequentially light up while I charge the battery to indicate the charge level, but remain constantly on (solid) once charged. single pressing the button does not flash the lights to indicate the battery level like I have seen in other videos. The lights will flash while charging and updating firmware, but that's it. Not sure if this has something to do with the issue above?

I have tried long pressing the power button, refreshing the firmware, downgrading the firmware, etc. disconnecting the gimbal head from the battery grip, connecting/disconnecting the gimbal with my PC and connecting/disconnecting the gimbal with the provided charger. I am absolutrely at a loss as to what I need to do next.

Can anyone help me?

I have attached a video below to demonstrate:


9-4 14:27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules