Please select Into the mobile phone version | Continue to access the computer ver.
Connecting GL300F Controller to Phantom 4 Pro issues
625 2 2019-9-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
Alpha_Lobo
lvl.2

Offline

I have a P4P+. That Plus controller works fine. I bought a GL300F controller as I need to use additional apps that the built in screen model doesn't allow.
When I turn on the RC and the GO App, It shows that I am connected to an Inspire 2 even though I do not own an Inspire 2 and no drone is turned on anywhere.
Entering Device (even though it's Inspire 2) and attempting to link RC to Drone via GO App does not work. The Remote screen is also presented for the Inspire 2 (as I see a setting for a master and slave remote). The RC also does not display any message requiring a firmware upgrade.

Tried about 10 different ways to manually link the RC to the drone including what is listed below.
Tried to connect RC to DJI Assistant 2 for Phantom 4 and drone will connect but RC won't.
Followed instructions to change the firmware version of my RC by turning on the RC, Starting the GO App and holding down the hamburger menu button for about 10 seconds. I then see the attached screen that says there is no firmware.

I'm guessing that the firmware is the issue. How can I manually get the firmware on the RC when I cannot upgrade it from the DJI GO App or from the DJI Assistant 2 Windows App?

Have attempted these manual steps plus a few others:
* Turn on both the aircraft and the controller.
* Press C1, C2, and the record button on the controller, then the controller will beep like D-DD.
*Let go all fingers, press the wheel on the right side of the controller and then the first light of the controller will become blue and it will constantly beep DDDD.
* Use a pen to click the linking button on the aircraft and hold for 3-5 seconds, and then take the pen off the aircraft and wait, it will be linked soon.

1.Turn on both of the drone and RC
2.Press C1,C2,recording button and shutter button at the same time.When you hear "D-DD" from the RC, release these buttons and press right dial quickly.Then you will see the RC indicator turns into blue.
3.Find the linking button on the drone and press it.

*********************************
https://youtu.be/zKa8F1rsx-o
*******************************************
Power on the controller and enter the go app,
click the three dots at the top right corner of the screen
then click the icon on the center bar that looks like a radio controller
once you've click that icon you're in the controller submenu, scroll to the bottom and you will see LINK RC or similar
click that and choose ok and it will start a 60 sec countdown and start beeping
go to the drone that you already powered on and want to use the controller with and poke the button in the recessed hole next to the sd card slot with a thick paper clip and you're done

**************************************
https://forum.dji.com/thread-45147-1-1.html

DJI RC No Firmware

DJI RC No Firmware
IMG_0032.PNG
2019-9-10
Use props
fansd21ff97a
lvl.2
Flight distance : 314888 ft
  • >>>
Brazil
Offline

Same issue here... have you solved it?
2019-12-9
Use props
vs82
lvl.2
Flight distance : 176158 ft

Italy
Offline

Same problem for me... there is a way to solve it?
Thank you
1-26 14:01
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules