Please select Into the mobile phone version | Continue to access the computer ver.
Motor not running
883 1 2019-9-11
Uploading and Loding Picture ...(0/1)


Hi I have a Dji P3 pro

After a crach the motors don´t want to run, I have tried to arme the motors manualy  by presing the sticks down and thorward´s each other.
I have tried to auto take off but nothing hapend.
The app shows the followin isuse compass abnormal, I have tried to calibrate it and but get the imige nr, that it didint work becus intensive electromagnetic interference.
overall status is  abnormal  and when I press the button it says  pic nr 2 compass error. contact Dji Support if this continues after restar.   
When I restar it´s the same problem.
One of the LED indicatars is broken  the  front lights are red and the one that works is flashing gren yellow and red.
The drone make´s a beeping sound  B-B- - - B-B

Any one hwo know´s what the problem might  be ?

Use props
DJI Gamora
Super Moderator


Hi, thank you for reaching out. We're sorry to know the incident happen to your DJI Phantom 3 Pro. Please ensure that you have tried calibrating in another location away from possible interference. If the problem persists, I will highly recommend you to send your drone to us for diagnostics and we do have our designated department who will conduct an evaluation to your unit and the corresponding resolution will be provided. The warranty can be applied depending on the outcome of the damage assessment including the warranty period of your unit. You may refer to the link below for you to contact our support team to start up a ticket. Thank you for your kind and understanding. Cheers!
Use props
You need to log in before you can reply Login | Register now

Credit Rules