Please select Into the mobile phone version | Continue to access the computer ver.
Solved my own P4 Firmware update problem from 1.02.06
283 1 10-2 20:23
Uploading and Loding Picture ...(0/1)
o(^-^)o
nebelung
lvl.4
Flight distance : 613612 ft
Offline

Well, this was funny, wrote up all the stuff below and gave it one last try by simply restarting everything...drone, RC AND App! The App restart was key. It updated like a charm after that. But I wrote this up and someone elase may have a similar problem, so I am sharing it here. For me it was...make sure you restart the App after you update the RC.

(original message)
-------------------------------
My P4 STD has been sitting around for a while...been flying other drones...and I am unsuccessfully trying to update its firmware.

Current firmware is 1.02.06
IMG_0576.png

The update downloads fine, but it never starts the install, but gives me the Failed to Update message.

I have tried it using the DJI Go App on an iPad Pro, I have used the DJI Assistant for Phantom 4 and the Assistant 1.2.4 (that someone else has recommended) and I have tried all 3 versions of the firmware that are available (06, 07 and 08). I have used different cables and different USB ports. I have used different batteries and I have tried it with and without an SD card in the drone. I have reformatted the SD card. I have had the RC on (when doing it with the APP) and I had the RC off when using the DJI Assistant. Restarted the drone many times. Probably invented some new curse words.

It's always exactly the same result. Software downloads, but it never starts the actual update.

I need help.    (And a beer)
(not anymore)   (yes, still need that beer)

Thanks.


10-2 20:23
Use props
RedHotPoker
Captain
Flight distance : 165105 ft
Offline

Eh, that’s good news. Thanks for sharing.



RedHotPoker
10-7 23:48
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules