Please select Into the mobile phone version | Continue to access the computer ver.
Receiver won't connect in Betaflight
12Next >
33600 47 2019-10-16
Uploading and Loding Picture ...(0/1)
o(^-^)o
quiptos
lvl.1

Offline

I have (had) two working quads with the DJI FPV setup, HD1 prebuilt from rotor riot and a GepRC MK4 pretty much same setup 5 inch.

I made the MK4 first and had an old FC that had wires all over so I redid the stack with new IS30 and F4 (HD) version with specific included cables to link the controller and flight unit. Both quadcopters worked and flew fine but I wanted the readouts that my HD1 has on the MK4 to show up.

Now that I have the F4 HD in there it just will not see the receiver, I have all the SBUS tabs checked and I know the flight unit works just fine. I have readouts in the goggles already of voltage etc coming from uart 2, everything green lights and binds up to each other like it should and I get all the right sounds. It just refuses to show up in Betaflight at all so I am stuck.

I tried all the tips in here changing between normal HDL etc anything I could find but same deal still doesn't see it. I tried flashing the legacy instead of included with the F4 flash and I am already using 10.6.0 on both before and after the new FC.

I have 10v coming into the unit and seems good minus the not connecting to Betaflight. I have seen quite a few threads about the F4 but not enough to make me think that they are all not working with DJI since they are sold out constantly.

Anyone have any ideas I could try? I know the unit works I can swap between the two builds and I know everything connects and I can see video feed all green lights, it's just the receiver on that specific flight controller for now.

thanks!

Kris
2019-10-16
Use props
quiptos
lvl.1

United States
Offline

Quick update, I tried flashing older versions 4.0.5 no good. Also tried switching to Uart RX3 and ground on the board to bypass the harness since everything else works. Same exact thing, everything connects and talks and I see video with voltage readouts etc but the controller just will not hook up to betaflight. 10v is making it into the unit which is plenty. Any other ideas appreciated. Probably order another Flight controller since I know everything else on the system was up and flying before I had this Tmotor F4 HD. Thanks guys!
2019-10-17
Use props
djiuser_ik4ET2AhKnKo
New

United Kingdom
Offline

quiptos Posted at 10-17 12:18
Quick update, I tried flashing older versions 4.0.5 no good. Also tried switching to Uart RX3 and ground on the board to bypass the harness since everything else works. Same exact thing, everything connects and talks and I see video with voltage readouts etc but the controller just will not hook up to betaflight. 10v is making it into the unit which is plenty. Any other ideas appreciated. Probably order another Flight controller since I know everything else on the system was up and flying before I had this Tmotor F4 HD. Thanks guys!

I'm having the exact same problem someone please help
2019-11-1
Use props
CEF
New

Germany
Offline

I have a Similiar Problem. I ordered an pre-configured and already activated DJI System from GetFPV, which works fine. Now i wanted to use an additional Air Unit with an pretty much identical setup (same Flightcontroller, same wirering, same config in Betaflight). But when everything is bind and powered up, it wont show the version of the air unit when i check devices with the goggle. also i cant switch to DJI HDL. And finally i wont get any input of the Controller in Betaflight. I only see the image of the air unit and the voltage information.
Goggles Menu = Remote Controller -> Servo Setup -> No Changes on Controller input
2019-11-3
Use props
CEF
New

Germany
Offline

I just wanted to add that i use Betaflight version 4.1. after i updated all DJI Devices to Version 01.00.0100 i can see the version on the goggles but the input of the controller still dont work
2019-11-3
Use props
HushThatPanda
lvl.2

United States
Offline

I'm having the same exact issue using  a Mamba F405 mini stack v2 FC. Anyone know  what to  do?
2019-11-9
Use props
fansc7fe036f
lvl.3
Flight distance : 1294593 ft
United States
Offline

I'm having the same issue with the F55a Pro II stack.  Can't set up my receiver or see any movements with the controls in Betaflight.  Not sure how to properly configure.
2019-11-15
Use props
fansbd5d1e8e
lvl.1

Australia
Offline

Same issue with tmotor f7 hd fc, the remote won't configure in betaflight, seems to be a common issue with the tmotor fc.. I got the hd so i wouldnt have any problems but here i am.. Anybody know what's up?
2019-12-30
Use props
KG KG
lvl.1

United States
Offline

Be sure you are set to Fast SBus protocol on both goggles, and in Betaflight. Type "set sbus_baud_fast = ON" in CLI on BF. Select on goggles as well. I had the same problem this fixed it.
2020-1-20
Use props
MRBill28
lvl.1
  • >>>
United States
Offline

fansc7fe036f Posted at 2019-11-15 11:19
I'm having the same issue with the F55a Pro II stack.  Can't set up my receiver or see any movements with the controls in Betaflight.  Not sure how to properly configure.

Having the same problem
2020-1-21
Use props
Elevate72
lvl.1
Flight distance : 231572 ft
Vietnam
Offline

Same issue here, with the SucceX-D Mini F7 2-8S TwinG FC...
2020-1-23
Use props
mc54
Second Officer
Flight distance : 1030 ft

United States
Offline

Just get a kakute F7 HDV and tekko32 35A 4in1 stack.

Avoid any possible voltage problems and wiring mistakes.

Trying to deal with F4 bs and voltage dropouts is not for me.

2020-1-24
Use props
Wavetwister
lvl.1

United States
Offline

Same thing over here. I have the iFlight Megabee with the SucceX-D Mini F7 Stack. All DJI components work perfectly with eachother, and the drone is recognized by Betaflight, but the DJI radio will not communicate with the drone's stack. iFlight and DJI support have been below average.

iFlight suggested the following:
1. Use Betaflight 10.6.0 and flash firmware betaflight_4.1.0_STM32F7X2 to the drone.
2. Use ports UART1 (Serial Rx) and UART 2 (Configuration/MSP).
3. In the CLI input "set sbus_baud_fast = on"
4. Under configuration, change the receiver protocol to SBUS.
5. On the goggles go to Settings > Device > Protocol > SBUS Baud Fast.
6. Update all three DJI componenents to firmware 01.00.02.

Despite making all these changes, my radio will not communicate with the drone's stack.

Kreeze can blow me.
2020-1-24
Use props
KingKimo
lvl.1
United States
Offline

fansc7fe036f Posted at 2019-11-15 11:19
I'm having the same issue with the F55a Pro II stack.  Can't set up my receiver or see any movements with the controls in Betaflight.  Not sure how to properly configure.

I'm in the same boat right now.  And i realize I'm not sure what UART's to configure since it plugs in to the FC
2020-1-28
Use props
RGMGFitness
First Officer
Flight distance : 233757 ft
  • >>>
United States
Offline

Just to confirm this is the T-Motor F4 HD Flight Controller your having issues with?  If so, can you do a "VERSION" command from the BetaFlight CLI and paste below.  Just want to see the first few lines under the VERSION section of the output.  

This is the firmware I'm seeing for this FC:  Firmware: TMOTORF4(BetaFlight)

https://www.getfpv.com/t-motor-f ... YA2V6RoCBeIQAvD_BwE


2020-1-29
Use props
Pimpassbossman
New

United States
Offline

I might be having this problem. I thought my IFlight Bumblebee was RTF but it wouldn't arm, so I tried plugging it into betaflight. for some reason i cannot even connect to it. I just downloaded the newest version and all the drivers, although i am on a mac if that makes a difference. On my goggles I see my controller movements except when I turn on sbus protocol then it seems to turn off my controller response. I'm a little sick because this was a big investment for me and I got the BNF specifically so I wouldn't have to worry about anything... My only hope right now is something Joshua Bardwell said, your remote won't work until you fully charge it once. I turned it on and bound it without charging so I wasn't sure what he was talking about, but hopefully that's it. Soul is really feeling crushed right now.
2020-2-1
Use props
AntDX316
First Officer
Flight distance : 3394731 ft
  • >>>
United States
Offline

c
2020-2-2
Use props
NNN
lvl.1

Germany
Offline

I am pretty sure I have the same problem. My stack is the T-Motor F7 Pro II, also specifically for the dji fpv-system, along with a connector, so you can't really mess up the cables... http://store-en.tmotor.com/goods.php?id=946
My current Ports-configuration in Betaflight is UART1 to Serial Rx and UART3 to Configuration/MSP. I, same as the OP and many otheres here, don't get any input in the Receiver-tab of betaflight. Something to note is that in the goggles, I also don't see the voltage of the FC, to the right of the arrow-icon it just say's "N/A".I can calibrate the controller from the goggles though and get video as well from the air-unit, what seems to be going wrong is the connection between the air-unit and the FC. All dji-components are on the latest firmware.
2020-2-2
Use props
AntDX316
First Officer
Flight distance : 3394731 ft
  • >>>
United States
Offline

NNN Posted at 2-2 06:32
I am pretty sure I have the same problem. My stack is the T-Motor F7 Pro II, also specifically for the dji fpv-system, along with a connector, so you can't really mess up the cables... http://store-en.tmotor.com/goods.php?id=946
My current Ports-configuration in Betaflight is UART1 to Serial Rx and UART3 to Configuration/MSP. I, same as the OP and many otheres here, don't get any input in the Receiver-tab of betaflight. Something to note is that in the goggles, I also don't see the voltage of the FC, to the right of the arrow-icon it just say's "N/A".I can calibrate the controller from the goggles though and get video as well from the air-unit, what seems to be going wrong is the connection between the air-unit and the FC. All dji-components are on the latest firmware.

Signal wire for the receiver is TX for me, not Rx. No MSP on that UART, just Serial enabled but I'm on an F7 SRXL2 Betaflight 4.1.3.

I'd just suggest switching the wire from RX to TX to see if that does anything.

Configuration/MSP is the computers port.  The USB to FC.  It's supposed to be on that and nothing else.

It could take a few saves for Serial to be saved on that UART where the receiver is connected to.

If you are all having problems just get an F722-STD F7 and move on.  I had to resolder all my connections when I smoked my 1st F722.  It doesn't take too long.
2020-2-3
Use props
xcrosser
lvl.1

Canada
Offline

My New titan dc5 bnf with dji radio that wont talk to betaflight….kinda sucken right now. I have watch all the videos and even downloaded  some guys cl dump from youtube . didn't work. Please help me
2020-2-8
Use props
xcrosser
lvl.1

Canada
Offline

did not learn anything today
2020-2-8
Use props
djiuser_yO5Ak4vzHgyo
New

United States
Offline

Yep I wasted my money on it too I got the controller the goggles in the cine whoop everything is updated registered and bound but they controller will not recognize the drone or betaflight will not recognize the controller when I plug it into betaflight it recognizes they drone but cannot see the controller I have a solid green light but consistently blinking on the controller
2020-2-20
Use props
djiuser_yO5Ak4vzHgyo
New

United States
Offline

Yep I wasted my money on it too I got the controller the goggles in the cine whoop everything is updated registered and bound but they controller will not recognize the drone or betaflight will not recognize the controller when I plug it into betaflight it recognizes they drone but cannot see the controller I have a solid green light but consistently blinking on the controller
2020-2-20
Use props
djiuser_yO5Ak4vzHgyo
New

United States
Offline

All the lights are green but the controller keeps beeping which means there's a problem
2020-2-21
Use props
dineli
lvl.2

Switzerland
Offline

Elevate72 Posted at 1-23 22:33
Same issue here, with the SucceX-D Mini F7 2-8S TwinG FC...

Me too, also with the SucceX-D Mini F7 ...
2020-2-21
Use props
djiuser_4SEAUgu3DQ2p
New

United States
Offline

I was using everything stock just to test it all out. I did this before activating all of my gear and everything worked perfectly fine. I activated all of my gear with DJI Assistant 2 and updated all the devices firmware to 1.00.04. After updating the firmware I am getting no response in the receiver tab of Betaflight. Can anyone think of any reason this might be the case? I do not understand why things would go from working to not working just like that. I bound the transmitter and the air unit again just to check, but that did nothing. I just downgraded to 1.00.03 and I still am not seeing any feedback. Any ideas?
2020-3-7
Use props
Alchem1st
New

Estonia
Offline

Hi i have a Holybro Kakute F7 HDV & Tekko32 F3 HDV 40A 4in1 ESC 30x30 Stack and i manage to connect the receiver the first time, but after some time something happened and now i cant connect the Receiver to Betaflight

the goggle and the unit and controller are all connected

please help
2020-4-19
Use props
jahama
lvl.1

United States
Offline

Alchem1st Posted at 4-19 10:08
Hi i have a Holybro Kakute F7 HDV & Tekko32 F3 HDV 40A 4in1 ESC 30x30 Stack and i manage to connect the receiver the first time, but after some time something happened and now i cant connect the Receiver to Betaflight

the goggle and the unit and controller are all connected

I had the same issue when I moved my airmodule over to another FC.  I had to do a " set sbus_baud_fast = ON" in betaflight and then check to make sure that my Airmodule was set to fast in my goggles.  In the Goggles, navigate to device and then change the protocol.  Mine was set to normal for some reason but when I set it to 7ms it was able to talk to the reciever.
2020-4-23
Use props
Ken J
lvl.1
Flight distance : 232815 ft
United States
Offline

quiptos Posted at 2019-10-17 12:18
Quick update, I tried flashing older versions 4.0.5 no good. Also tried switching to Uart RX3 and ground on the board to bypass the harness since everything else works. Same exact thing, everything connects and talks and I see video with voltage readouts etc but the controller just will not hook up to betaflight. 10v is making it into the unit which is plenty. Any other ideas appreciated. Probably order another Flight controller since I know everything else on the system was up and flying before I had this Tmotor F4 HD. Thanks guys!

Same problem here. Linked, not shown in Beta Flight. Tried all port combinations, no joy.
2020-4-24
Use props
djiuser_bG9sXfZIVv3m
lvl.1

United States
Offline

NNN Posted at 2-2 06:32
I am pretty sure I have the same problem. My stack is the T-Motor F7 Pro II, also specifically for the dji fpv-system, along with a connector, so you can't really mess up the cables... http://store-en.tmotor.com/goods.php?id=946
My current Ports-configuration in Betaflight is UART1 to Serial Rx and UART3 to Configuration/MSP. I, same as the OP and many otheres here, don't get any input in the Receiver-tab of betaflight. Something to note is that in the goggles, I also don't see the voltage of the FC, to the right of the arrow-icon it just say's "N/A".I can calibrate the controller from the goggles though and get video as well from the air-unit, what seems to be going wrong is the connection between the air-unit and the FC. All dji-components are on the latest firmware.

@NNN did you ever figure out your issue? I have the exact same problem with the T-Motor F7 HD flight controller.
2020-4-25
Use props
fans7bab1f22
lvl.1
United States
Offline

Anyone make any headway in getting this to work? I am also on a BumblebeeHD. Ordered mine RTF from getfpv. Same issue. Everything linked, no activity from the controller seems to reach the FC.
2020-5-9
Use props
djiuser_kNa7TdvGKR8Z
New

France
Offline

fans7bab1f22 Posted at 5-9 21:33
Anyone make any headway in getting this to work? I am also on a BumblebeeHD. Ordered mine RTF from getfpv. Same issue. Everything linked, no activity from the controller seems to reach the FC.

Guys you actually have to reset your fc in betaflight, andit will normally work. Make sure UART5 serial rx is activated and UART6 configuration is activated plus sbus selected on receiver section.
2020-5-14
Use props
Darshanp109
lvl.1
Flight distance : 288051 ft
United States
Offline

Elevate72 Posted at 1-23 22:33
Same issue here, with the SucceX-D Mini F7 2-8S TwinG FC...

Have you figured out why its not working?
2020-5-15
Use props
jmw
lvl.1
Flight distance : 21493 ft
  • >>>
United States
Offline

fans7bab1f22 Posted at 5-9 21:33
Anyone make any headway in getting this to work? I am also on a BumblebeeHD. Ordered mine RTF from getfpv. Same issue. Everything linked, no activity from the controller seems to reach the FC.

Also got a Bumblebee HD BNF - I finally got mine working today!  I spent three days in forums and on YouTube before I realized he instructions were actually in the iFlight box the entire time...

Before you begin... register and update all three DJI components to firmware 1.00.02

For the Succe-X-A F4 AIO FC for DJI (that's stock on the iFlight):

1. You need to load up the quad in Betaflight.  For those having a hard time on OSX check that you've (a) gotten the USB driver as noted on the Betaflight launch page and RESTART and (b) make sure you've added in the SECOND USB-C plug that came in the box.  The USB-C port you used to register the DJI Air unit isn't the same one!!

2. One you have Betaflight running, map the UART settings as below:



2. Once that is complete, in the Command Line Interface (CLI) of Betaflight, you have to type:

"set subs_baud_fast=on" and SAVE

3. IN THE GOGGLES don't forget to change the settings to "sbus Baud Fast" for the low-latency mode (which you're going to want)
2020-5-23
Use props
djiuser_JZIxS3B0GYaX
New

Norway
Offline

Hey guys I was just struggling with this and figured it out.
on the SucceX-D F7 Twing G Flight Controller.

Update to latest firmware and use the following port configuration (under "use DJI transmitter":


Hope it helps!
2020-5-23
Use props
AG-TO
New

Canada
Offline

iFlight bumblebee HD - exact same problem.

Ok - I just spent 6 hours on this, and the diagram above was the key.  

The top of the diagram shows 6 wires going from the air unit to the FC.  The bumblebee HD had a 4 wire cable going from the air unit to the ESC, and a 6 wire cable in the box.

Swap the cables, and everything starts to work!

(except now my motors don't spin up)

Hope this helps!!
2020-6-19
Use props
franbakersfield
New

United States
Offline

tried msp, tx, baud speed, etc...any other solutions? I have the same issue as ALL the other posts
2020-9-26
Use props
LPFrogr
New
United States
Offline

hello,
i was having the same issue - have a SucceX-D Mini F7 which worked after setting the ports in beta-flight like the diagram from iflight suggested. Configuring goggles/controller and FC to sbus_baud_fast = on. Was flying for a few weeks then i built another drone using the iflight 60a full version of the stack (iFlight Succex-D F7 V2.1 2-6S 30x30 Stack/Combo for DJI (F7 FC / 60A 32bit ESC)). Bound all those pieces together and it worked yay! However when i went back to the mini the remote would not function in the beta-flight configurator. The solution was to turn sbus fast off then set the controller to normal. save and reboot. RE-SET to sbus_baud_fast = ON / save the config reboot then go back into goggles and set the remote to use sbus_baud_fast as well. Now i have both systems working. Woot!!
2020-10-18
Use props
djiuser_ZMYSWznpmHzn
New

United States
Offline

I've tried all these steps and still no luck, also with the SucceX-D Mini F7. I also cannot flash my board(?) Tried using both impulseRC and Zadig and it does not work. When I try to put it in Bootloader mode the LEDS indicate it is in bootloader mode but it cannot be recognized by windows and DFU is never an option. ImpulseRC gives "unexpected number of devices" error and Zadig shows it as unknown. When not in bootloader, I can connect to betflight fine and change settings, but no way to reflash firmware and dji controller gives zero responses in betaflight :/
2020-12-27
Use props
RacerXFPV
lvl.1
United States
Offline

Hi Guys, I have gone through every trick on this excellent post, reflecting lots of work by many frustrated pilots, myself no exception... I am so glad I purchased this on Amazon because Bezos needs another DOA product to resell. LOL NO "SUCCEX" here!
2021-2-3
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules