Please select Into the mobile phone version | Continue to access the computer ver.
New Ronin 1 Battery not working
162 1 2019-10-30
Uploading and Loding Picture ...(0/1)
o(^-^)o
DDubian
lvl.1

United States
Offline

I been using my Ronin 1 since 2016 and the battery it came with has been great ever since.

I recently started using the D Tap at the bottom of the sled to power my camera.

This resulted in me wanting to buy an extra battery for my Ronin 1 which I did 2 months ago from B&H.

I am now in a back and forth war with DJI tech, trying to figure out why my new battery worked great on my first use of it.

And now whenever I ty to connect my app to the Gimbal it says the battery is not a "DJI intelligent battery".

On swapping back to the original the error goes away.

I sent the battery in and they ran tests and sent it back to have the same issue happen again on my end.

They said everything worked fine for them, but now they want me to send my gimbal and the battery all together.

This is not a great solution for professionals who need there gear ready on a daily basis.

I am here to ask if there are any solutions from the community that could help.

I read that cleaning the connectors helps but how does one do that correctly and why wasnt that done on DJI's end when they had my battery?

I seem to question why I never invested in freefly systems because DJI needs better customer service because this is a headache!

Very sad to see a company disregard one of there first units!
2019-10-30
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Hi DDubian, sorry to know the error persists when you got it from the repair center, I managed to get the case number via your Forum account, upon checking the details, both our damage assessment, repair team and testing team all have checked the battery that there is no issue with it, the battery works fine.
Please follow the below suggestion and check again:
1. Ensure the connector of the gimbal and battery is clean, you can wipe it with 95% alcohol and a cotton swab.
2. Are the GCU and IMU firmware up to date?
3. Is the battery inserted completely down? Please make sure 2-pin-sensor contacts battery.
2019-10-30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules