Please select Into the mobile phone version | Continue to access the computer ver.
P4 Multispectral Start Up/Linking
717 2 2019-11-4
Uploading and Loding Picture ...(0/1)
o(^-^)o
zcarpenter4RE
lvl.1

United States
Offline

Hello all, I have a P4 Multispectral that I'm trying to test out. The problem is I'm not finding anything on how to pair the drone, the controller, and one of the flight apps together. I tried to use both DroneDeploy and DJI Ground Station Pro this weekend, but couldn't get it figured out. I also tried to follow instructions in the User Guide and pair the controller with the drone to just fly manually, but it timed out and I couldn't figure out how to accomplish it. I'm very new to drones as a whole, so if anyone has suggestions on what I could be missing, that'd be great!


2019-11-4
Use props
djiuser_2VFRI5Tu5Arp
lvl.1

Chile
Offline

Hello Z, So, the first thing to do after you open the box, is to upgrade the firmware of everything. To upgrade the drone, you must download DJI assistant, and then calibrate the drone. After that, first turn on the controller, connect the ipad with the controller and check the connection. Now you can turn on the drone, and wait until the familiar beepping. If that does not work, you have to put in the GS pro app, the confguration of the controller, and then hit linking. The controller will start to beep, and that's the moment you have to push a small linking button on the drone, its located on the LED in one side of it, between the SD and the micro USB.
2019-12-5
Use props
Ueli
lvl.4
Flight distance : 1696079 ft
  • >>>
Switzerland
Offline

Hi, same problem here. Doesn't link after firmware upgrade.
Opened a ticket at DJI, no answer yet. Seems to be a serious firmware problem.
1-22 08:51
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules