Please select Into the mobile phone version | Continue to access the computer ver.
DJI Fly App Won't Install
5640 31 2019-11-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
JaydenB
lvl.1
Malta
Offline

Today I recieved my Mavic Mini, when I went to install it's app DJI Fly, its giving me an "App Not Installed Error". I have a Xiaomi Redmi S2. Device is updated to lastest firmware (Android 9) If my phone is not supported, I hope DJI will understand that no one is going to buy a new phone just to support the app. Thanks. Screenshot_5.png

2019-11-13
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

Hi JaydenB, we are sorry for the inconvenience. Since the mobile device you are using is not compatible with DJI Fly app, we may suggest that you try another mobile device to ensure the full performance of the app. Hope for your kind understanding. mini cmpt list.png
2019-11-13
Use props
fox mx
lvl.2
Flight distance : 71394 ft
New Zealand
Offline

DJI Thor Posted at 11-13 19:41
Hi JaydenB, we are sorry for the inconvenience. Since the mobile device you are using is not compatible with DJI Fly app, we may suggest that you try another mobile device to ensure the full performance of the app. Hope for your kind understanding.[view_image]

I have same problem ,im not going out buy new phone or (grandma not going to let me use her phone)    ,DJI needs to put large warning lables on the box to state which phone compatible, otherwise people  be tick off or  retuning them. there was no probs with other dji apps
2019-11-15
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

fox mx Posted at 11-15 00:41
I have same problem ,im not going out buy new phone or (grandma not going to let me use her phone)    ,DJI needs to put large warning lables on the box to state which phone compatible, otherwise people  be tick off or  retuning them. there was no probs with other dji apps

I am sorry for the trouble. May I know the specific mobile device you are using?
2019-11-15
Use props
JaydenB
lvl.1
Malta
Offline

DJI Thor Posted at 11-13 19:41
Hi JaydenB, we are sorry for the inconvenience. Since the mobile device you are using is not compatible with DJI Fly app, we may suggest that you try another mobile device to ensure the full performance of the app. Hope for your kind understanding.[view_image]

I tried using my brothers Xiaomi Mi A2 Lite and the app worked. Will you be updating your compatible devices anytime soon?
2019-11-15
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

JaydenB Posted at 11-15 11:32
I tried using my brothers Xiaomi Mi A2 Lite and the app worked. Will you be updating your compatible devices anytime soon?

Hi Jayden, thank you for getting back. We haven't noticed the news about the update of the list. We will forward your mobile device model to the engineers to notice, yet, we are unable to assure that it will be compatible in the future. At this moment, we still suggest using a compatible device. Thank you for your understanding.
2019-11-16
Use props
djiuser_jVAECRcuKaNY
lvl.1

United States
Offline

fox mx Posted at 11-15 00:41
I have same problem ,im not going out buy new phone or (grandma not going to let me use her phone)    ,DJI needs to put large warning lables on the box to state which phone compatible, otherwise people  be tick off or  retuning them. there was no probs with other dji apps

I noticed that not one of the many, many reviewers mentioned this very large compatibility problem.  To me this screams of a lot of effort on DJI's part to keep a major  problem under wraps.
2019-11-18
Use props
Jadee Borinaga
New

Philippines
Offline

Please include the Huawei cheap phones.... I just bought yesterday a Huawei Y6 Pro 2019... And I cannot use it because of an error "app not installed"... And its really frustrating coz I don't have buy a new phone again for the sake of device compabilities
2019-12-29
Use props
djiuser_v6rvvP4wPiF1
lvl.1

Philippines
Offline

This is so frustrating. I bought the mini from Dubai just on the day of my flight going to Philippines. So frustrating to read about this as my phone won't install the app also. Have i known this earlier, i won't definitely buy it. And now  it's going to be my problem where to find a compatible one. I'll be using the drone tomorrow. You're a disappointment!
2019-12-30
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

djiuser_v6rvvP4wPiF1 Posted at 12-30 20:52
This is so frustrating. I bought the mini from Dubai just on the day of my flight going to Philippines. So frustrating to read about this as my phone won't install the app also. Have i known this earlier, i won't definitely buy it. And now  it's going to be my problem where to find a compatible one. I'll be using the drone tomorrow. You're a disappointment!

Hi, the DJI FLY APP was developed based on the 64-bit platform. The minimum request of installation environment as below:
1. Requires Android 6.0 or above. Please note that the Android 10 beta version for Samsung Galaxy models is not currently supported.
2. Available ROM is 2GB and above.
3. Supporting ArmV8 64-bit architectures.(64-bit processor)
Below's the mobile device compatibility list for your reference:
2019-12-30
Use props
djiuser_v6rvvP4wPiF1
lvl.1

Philippines
Offline

DJI Thor Posted at 12-30 23:16
Hi, the DJI FLY APP was developed based on the 64-bit platform. The minimum request of installation environment as below:
1. Requires Android 6.0 or above. Please note that the Android 10 beta version for Samsung Galaxy models is not currently supported.
2. Available ROM is 2GB and above.

I have Samsung S8, model number SM-G950FD. And why it is still not working when in fact it is in your list of compatible devices?
2019-12-31
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

djiuser_v6rvvP4wPiF1 Posted at 12-31 18:30
I have Samsung S8, model number SM-G950FD. And why it is still not working when in fact it is in your list of compatible devices?

Could you please provide a screenshot of the installation issue you encountered? Please also provide the system version of your mobile device for further confirmation. Thank you.
2019-12-31
Use props
djiuser_v6rvvP4wPiF1
lvl.1

Philippines
Offline

2019-12-31
Use props
djiuser_v6rvvP4wPiF1
lvl.1

Philippines
Offline

DJI Thor Posted at 12-31 19:37
Could you please provide a screenshot of the installation issue you encountered? Please also provide the system version of your mobile device for further confirmation. Thank you.

Kindly see attached screenshots below.
2019-12-31
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

djiuser_v6rvvP4wPiF1 Posted at 2019-12-31 20:13
Kindly see attached screenshots below.

Hi there, I haven't been able to find the screenshot, could you please upload again? Besides, please also provide the operation system of your mobile device, thank you.
1-1 02:34
Use props
Cosmin Popa
lvl.1
Flight distance : 653 ft
Cyprus
Offline

Yeah, I've updated the app alright on my samsung s10+, but now it won't start. At all. Rebooted phone, still nothing. Thanks for the latest update, DJI. Really happy customer here
1-1 13:40
Use props
Cosmin Popa
lvl.1
Flight distance : 653 ft
Cyprus
Offline

Cosmin Popa Posted at 1-1 13:40
Yeah, I've updated the app alright on my samsung s10+, but now it won't start. At all. Rebooted phone, still nothing. Thanks for the latest update, DJI. Really happy customer here

So guess what. I've made this forum user just to be able to complain about a very problematic issue: the fact I cannot use the app since I updated it 30 minutes ago. And while I was writing a very detailed 10 lines memo about it in a new thread, the app decided to load.
What do u know. It's the slowest first time running app for mobile, but it eventually loads.
I haven't figured how to delete my last reply, which is why I wrote this one to let you know the app actually works for me. After a 3 mins loading time. gg
1-1 14:01
Use props
Gimborgo
lvl.1
Flight distance : 111378 ft
Italy
Offline

DJI Thor Posted at 2019-11-13 19:41
Hi JaydenB, we are sorry for the inconvenience. Since the mobile device you are using is not compatible with DJI Fly app, we may suggest that you try another mobile device to ensure the full performance of the app. Hope for your kind understanding.[view_image]

Seriously, do you believe this is an appropriate answer?!
2-26 13:14
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

Gimborgo Posted at 2-26 13:14
Seriously, do you believe this is an appropriate answer?!

Hi Gimborgo, may I know the specific issue that you encountered?
2-27 04:40
Use props
djiuser_UcHTXsFGYedo
lvl.1

Philippines
Offline

What the fuck is the problem with you dji i already bought my mavic mini and you guys requiring us to buy a new phone just to be able to ise the deone?!! What the hell.. I cant install it on my oneplus 5t
4-1 13:35
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

djiuser_UcHTXsFGYedo Posted at 4-1 13:35
What the fuck is the problem with you dji i already bought my mavic mini and you guys requiring us to buy a new phone just to be able to ise the deone?!! What the hell.. I cant install it on my oneplus 5t

Hi there, sorry for any inconvenience caued, the DJI FLY APP was developed based on the 64-bit platform. The minimum request of installation environment as belows:
1. Requires Android 6.0 or above.
2. Available ROM is 2GB and above.
3. Supporting ArmV8 64-bit architectures (64-bit processor).
We recommended to use the phone in our compatibility list for better performance, thank you. compatibility list.png
4-1 23:54
Use props
mgmc
lvl.1

United States
Offline

Why doesn't it load on the Samsung Galaxy J7?  It meets all the specifications discussed above.




5-5 06:26
Use props
dpperkins
lvl.1

United States
Offline

mgmc Posted at 5-5 06:26
Why doesn't it load on the Samsung Galaxy J7?  It meets all the specifications discussed above.

[view_image]

I have the same situation with a Samsung Galaxy J3.  The app simply says that it's incompatible, and will not install.  But I cannot see any of the technical specs that would prevent installation.  From what I can tell about the phone, and what I read before I bought the mini, it should be fine.  Any assistance?
5-16 15:07
Use props
djiuser_AMn4GWaIazaU
New

United States
Offline

I'm really mad. Now I have to buy a new phone or pay a restocking fee.. I hate DJI already
6-19 11:59
Use props
djiuser_XPgi0HpZLgqj
New

Canada
Offline

Same phone same problem... 8 months later!

DJI does not have a fair selling practice because the warning about the phones is only on the DJI fly page which you access AFTER having bought the Mavic Mini
6-29 04:25
Use props
djiuser_XPgi0HpZLgqj
New

Canada
Offline

Same phone same problem... 8 months later!

DJI does not have a fair selling practice because the warning about the phones is only on the DJI fly page which you access AFTER having bought the Mavic Mini
6-29 04:27
Use props
Joshua Schuler
New

United States
Offline

Yeah, I have a Samsung Galaxy J7 Crown. The app will not install, even after allowing permission. My phone beats all of the technical specs, so I'm not sure what the problem is.
7-4 15:24
Use props
claudeestephangmail.com
New

Lebanon
Offline

i used to fly my phantom 3 pro with Samsung j6plus! i bought the Mavic mini i cant fly it!? how come?!
8-20 12:47
Use props
[dev]
lvl.1

Poland
Offline

i have Samsung J4+ and J6 and both don't work
its just great to read this right after i received the drone and did not even open the box
fantastic job DJI
8-27 14:07
Use props
jerenimo
lvl.1

Turkey
Offline

DJI Thor Posted at 2019-12-30 23:16
Hi, the DJI FLY APP was developed based on the 64-bit platform. The minimum request of installation environment as below:
1. Requires Android 6.0 or above. Please note that the Android 10 beta version for Samsung Galaxy models is not currently supported.
2. Available ROM is 2GB and above.


You should write this list on the product boxes.
9-23 03:01
Use props
jerenimo
lvl.1

Turkey
Offline

DJI Mindy Posted at 4-1 23:54
Hi there, sorry for any inconvenience caued, the DJI FLY APP was developed based on the 64-bit platform. The minimum request of installation environment as belows:
1. Requires Android 6.0 or above.
2. Available ROM is 2GB and above.

You should write this phone list on the product boxes.
9-23 03:02
Use props
djiuser_qNgfOLX11fYK
lvl.1
Ghana
Offline

Hello there, I was using a Huawei brand and was not supported by the dji app, I just bought a new Samsung A11 and is still not supported. This is not fair I wasted my money. I am returning the drone straight away

Thank you!
10-7 07:35
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules