Please select Into the mobile phone version | Continue to access the computer ver.
DJI Fly App Android compatibility : A comprehensive guide
10454 35 2019-11-15
Uploading and Loding Picture ...(0/1)
o(^-^)o
Faudgie
lvl.2

France
Offline

There seem to be quite a lot of DJI Fly app compatibility issues with many Android users, on phones that are not listed as compatible on DJI's website.So here is a bit of info (from experience), if you find yourself in this situation :


IF :
  • You cannot find the app on Google Play, or
  • You have downloaded the apk from dji.com (https://www.dji.com/fr/downloads/djiapp/dji-fly), but it fails during installation, or
  • You have succesfuly installed the app, but it won't even launch,

Here is what you can check :

  • Go (via a web browser) to https://play.google.com/store/apps/details?id=dji.go.v5,
  • If the previous method doesn't work, go (via a web browser) to play.google.com, search for "DJI", click on "DJI GO 4", then on the app page, click on the App author ("DJI TECHNOLOGIES CO., LTD"), then in the list of app, you can normally find "DJI Fly",
Once on the DJI Fly App page, if it shows "This app is not compatible with your device", of if it still fails during installation or launch, please keep reading.



If you still can't install or launch the app, here are the main issues that you might be facing :
  • Check your android version ! (Settings > About Device > Android Version). If it is under 6.0.0, then you can try upgrading with a System update (if available), otherwise you can try rooting your device and using a custom ROM, but I strongly advise against it.
  • If your Android version is over 6.0.0, I (with other users) found out that the app is ONLY compatible with 64-bit Android on ARM CPUs.


How to check your Android and CPU architecture ?
You can install Benchmarking apps from the play store (I found that AnTuTu Benchmark app gives us exactly the results we need). Once installed, go to "My Device".
  • Under "Basic info", you will have the information about Android and its architecture (ex. "8.0.0 (32-bit)"). This NEEDS to be 64-bit, otherwise DJI Fly app is not compatible with your Android distribution.
  • Under "CPU", you will have the info about the Architecture (ex. "8 x ARM Cortex-A53"). There NEEDS to be written "ARM" somewhere on there, otherwise (again), DJI Fly app is not compatible with your CPU.


Small note : if (like in my case), you have a 32-bit Android,  but your CPU has an ARM architecture, and is capable of 64-bit (under the "Type" info of the "CPU" tab), then it is your phone's manufacturer that decided to only release 32-bit versions of Android, even though your CPU is 64-bit capable. That's probably for performance matters. You can still try to root your device and install a custom ROM, but, again, I strongly advise against it...

Is DJI planning on releasing a 32-bit compatible app in the future?
Excellent question.
The answer is... NO.
DJI Support's answer to the question (by email) :
"With regard to your question, unfortunately, we don't have a plan on releasing a 32-bit compatibility for the DJI Fly app. We suggest to use a supported device for the app. You may refer below [same list as on the website] for the list of supported devices."

What can you do, then?
Well... That's up to you. But here are a few options (that I might follow as well) :
  • Acquire a new phone. (After you checked its compatibility with the app). Yes, that's a shame (in my case, my phone is only 2 years old), but that's basically the simplest solution, and unortunately the one that DJI pushes you to follow.
  • Cancel your Mavic Mini order, and buy an older drone to use with your current phone. Indeed, if your phone is compatible with DJI Go 4 app, then you can basically use ANY other drone that DJI has ever manufactured. All other apps from DJI are 32-bit compatible. And that solution might even be cheaper than buying a new phone.
  • Wait for 3rd-party apps to be released. Indeed, as soon as DJI publicly releases the SDK for the Mavic Mini, other app developers will probably publish new apps (like Litchi, for example) for the Mavic Mini. But DJI might release the SDK in a week, or in a year, or never... You will never know... (DJI, of course, strongly advise against using 3rd-party software.) And even then, the 3rd-party app might not be compatible with more phones than the DJI Fly App currently is.



Anyways, I hope this guide will help some of you out there. I tried to keep it as neutral as possible towards DJI, although I know many people will be upset about DJI's choice towards many Android users.

Fly safe !
2019-11-15
Use props
DJI Stephen
Super Moderator

Offline

Hello and good day Faudgie. Thank you for sharing this guide and your experience with regards to this matter. This will be a very big help to all our DJI co pilots. Thank you for your support.
2019-11-15
Use props
lojzik
lvl.2

Czechia
Offline

tvl to jsou pitomci. Pěkný malý levný dron a oni to zabijou aplikací.
2019-11-15
Use props
djicheaha
Second Officer
Flight distance : 1081453 ft
United States
Offline

Thanks for the guide. I verified that my Samsung Galaxy Note 8: CPU 835, 9 (64-bits). I'll be ready when my MM arrives. Thanks again.
2019-11-15
Use props
mikelaw
lvl.2

United States
Offline

The problem with DJi is that they did not explicitly state on the DJI Mavic Mini store that the DJI Fly app would requite "certain" specific phones . This left many uninformed buyers got stuck.
This is a better reference site for phones compatibility check

https://www.phantomhelp.com/tips/best-tabletsphones-for-dji-go-updated-daily.18?
2019-11-25
Use props
FloridaTom
lvl.1
Flight distance : 10728 ft
United States
Offline

Thank you for this information - certainly will not recommend the mini to anyone with a 32 bit android OS
2019-11-25
Use props
FloridaTom
lvl.1
Flight distance : 10728 ft
United States
Offline

Thank you for this information - certainly will not recommend the mini to anyone with a 32 bit android OS - I purchased a Walmart $100 phone which it seems has a 64bit processor, but a 32 bit Android OS - I purchased DJI just to avoid stupid problems like this! Why take the chance of destroying a $700 phone to fly a $399 drone - sad indeed!
2019-11-25
Use props
djiuser_COA6z1UzrgrV
lvl.1

United Kingdom
Offline

Hi everyone ! Been using Samsung S5 galaxy on my DJI spark and now just bought DJI Mavic mini and will the Samsung S5 galaxy phone work with this drone too ?
2019-12-4
Use props
Firestarter88
lvl.1

Argentina
Offline

djiuser_COA6z1UzrgrV Posted at 12-4 13:32
Hi everyone ! Been using Samsung S5 galaxy on my DJI spark and now just bought DJI Mavic mini and will the Samsung S5 galaxy phone work with this drone too ?

Sadly, I don't think so. It has a Qualcomm MSM8974AC Snapdragon 801which has a 32 bit Architecture.
2019-12-4
Use props
Azgana
lvl.1

Italy
Offline

Hi! I have a Moto G5 Plus smartphone and i cannot install the DJI Fly App. I tried everthing, but there is no way to do it.
I have to buy a new smartphone then... And i opted for the Motorola One series.
Do you know if Motorola One smartphones (Action, Macro, Vision) can run the app?
2019-12-4
Use props
fans9c544e01
lvl.3
Flight distance : 687910 ft
United States
Offline

Great Info…  I read your document. Thank you for your time and effort. What happens if you have the Nvidia Android tablet and the android os is version 6.00. Your document references below 6.00 and above 6.00. What happens if it is android os 6.00?
2019-12-4
Use props
raymacke
lvl.3
Flight distance : 1207385 ft
United States
Offline

Yes, I was very disappointed as I own both a Galaxy S5 which I didn't think would work and a Moto G6 Play which I thought would -  neither will.  I ended up spending almost as much as the Mini cost on referb Ipad Mini 4 just to fly the drone I had already bought.
2019-12-4
Use props
Azgana
lvl.1

Italy
Offline

I wish to understand why there is no compatibility with older device. I have Android 8.1 on my Moto G5 Plus, why i cannot install the app?
2019-12-5
Use props
Azgana
lvl.1

Italy
Offline

Azgana Posted at 12-5 02:19
I wish to understand why there is no compatibility with older device. I have Android 8.1 on my Moto G5 Plus, why i cannot install the app?

I understood that i need a 64 bit OS and CPU, but the old DJI app works on every device, so why not to make compatible even the DJI Fly app with 32 bit systems?
I hope that DJI be aware of this problem, because is really really annoying.
2019-12-6
Use props
Gu5s
lvl.4
Flight distance : 272326 ft
Czechia
Offline

Azgana Posted at 12-6 10:05
I understood that i need a 64 bit OS and CPU, but the old DJI app works on every device, so why not to make compatible even the DJI Fly app with 32 bit systems?
I hope that DJI be aware of this problem, because is really really annoying.

We all wonder why... It is nothing but a stubborn stance the Dji has taken and there is no real justifiable reason (supplied so far), why they have made this resoltion, that they have simply greatly underestimated... I ended up in the mixed bag and just bought a new phone (Xiaomi Note 7 - pretty good for 190$)
2019-12-6
Use props
Mike Dunn
New

United States
Offline

do you know if the Moto Z3 will work on the Mini
2019-12-7
Use props
PeteD314
lvl.1

United States
Offline

Mike Dunn Posted at 12-7 17:34
do you know if the Moto Z3 will work on the Mini

My guess - the Moto Z 3 will probably, but the Moto Z 3 Play does not!

"Z3" has a Qualcomm MSM8998 Snapdragon 835 chipset.
"Z3 Play" has a snapdragon-636 "a Qualcomm® Kryo™ CPU built on ARM Cortex technology".

DJI got me to spend $260 to replace my phone with one that has a native 64bit OS; and now I see it won't work because its not ARM, its Built on ARM.

I'm sick of DJI and the $550 I spent on a known brand drone that should just work.
2019-12-8
Use props
PeteD314
lvl.1

United States
Offline

PeteD314 Posted at 12-8 10:26
My guess - the Moto Z 3 will probably, but the Moto Z 3 Play does not!

"Z3" has a Qualcomm MSM8998 Snapdragon 835 chipset.

Never mind (based on specs); I wouldn't depend on "Z3".
https://www.qualcomm.com/products/snapdragon-835-mobile-platform

Its got a similar architecture "based off..."

Although there was a facebook post from a guy who had success with a "Z3".
https://www.facebook.com/groups/1932007117029390/2672205969676164/?comment_id=2672220323008062&notif_id=1575825621035182&notif_t=group_comment
2019-12-8
Use props
djiuser_FxUyaHZXOcsY
lvl.1
Sierra Leone
Offline

Absolutely shocking to buy the MM and go traveling with it to find out I have a completely unusable drone because DJI and all the 'independent' YouTube reviews failed to mention the extremely small range of compatible phones.
I could have brought my mavic.  Thought I had downgraded to a simpler lighter drone, but I have to upgrade my phone when I get back or sell the MM at a loss.
Terrible attitude to customers.
2019-12-9
Use props
emaneg
lvl.4
Flight distance : 1591 ft
Italy
Offline

Just to provide some personal experience: Xiaomi redmi note 7 (not listed within the compatibles) works fine (so far, at least!)
2019-12-11
Use props
Azgana
lvl.1

Italy
Offline

I bought a new smartphone, a Xiaomi Mi 9 Lite and the DJI Fly app is compatible.
2019-12-13
Use props
djiuser_TjXWDu7wS2Ew
lvl.2
Poland
Offline

emaneg Posted at 12-11 05:40
Just to provide some personal experience: Xiaomi redmi note 7 (not listed within the compatibles) works fine (so far, at least!)

Hi, did you updated you phone to MIUI 11 (Android 10)? How about DJI Fly after update?
2019-12-13
Use props
emaneg
lvl.4
Flight distance : 1591 ft
Italy
Offline

djiuser_TjXWDu7wS2Ew Posted at 12-13 10:52
Hi, did you updated you phone to MIUI 11 (Android 10)? How about DJI Fly after update?

No, I've still android 9 and MIUI 10.3. As I'm using it just for MM, at the moment I do  not need any update. I have to be careful and avoid touching the wrong button!

What about you? Did you update? And then, what about the fly app?
2019-12-14
Use props
Ewa i Piotr
lvl.2
Poland
Offline

emaneg Posted at 12-14 08:53
No, I've still android 9 and MIUI 10.3. As I'm using it just for MM, at the moment I do  not need any update. I have to be careful and avoid touching the wrong button!

What about you? Did you update? And then, what about the fly app?

Hi, I updated to MIUI 11.0.4 (though it is still Android 9) and app is working ok, but... I still wait for delivery of MM. You know, second week of "processing" order. And counting.
2019-12-15
Use props
emaneg
lvl.4
Flight distance : 1591 ft
Italy
Offline

Ewa i Piotr Posted at 12-15 03:30
Hi, I updated to MIUI 11.0.4 (though it is still Android 9) and app is working ok, but... I still wait for delivery of MM. You know, second week of "processing" order. And counting.

well, I had mine off the shelf, but then I discovered the app problem with 32/64 bit android and so, after borrowing someonelse phone just to try, I had to wait long before finding a cheap phone, just for the drone... very disapponting anyway.

For now I will not dare upgrading the GUI and OS of my phone: it works fine with MM and that's it!
2019-12-15
Use props
Bikoman
lvl.2
Flight distance : 21811 ft
United States
Offline

I am using my Samsung S10E without any issues.  Just for fun I thought I would try my $19 Visible R2 (ZTE) that I got when I switched to Visible when they said my unlocked S10E wasn't compatible with their service which it is.  The R2 has 2gb Ram and Qualcomm 425 chipset, running Android 8.1.  Dji Fly does not show up in the phones playstore, but I downloaded the apk from DJI and sideloaded it.  Started it up and signed into my account and it attaches to Mini just fine.  Raining today so flew around inside of house, everything works, no problems.......  For $19, this will be my backup in case something happens to my S10E.
2019-12-15
Use props
djiuser_RZKOx68fX1iO
lvl.2

United States
Offline

Very helpful. To get a reasonably priced 64 bit smartphone, I have to wait two more months until my cellular provider will give me the deal. Thus, the Mavic Mini sits...and sits...and sits. Is there any way to fly this drone without a smart-phone paired to the controller?
2019-12-15
Use props
YouKnowWho
lvl.2
Canada
Offline

Mike Dunn Posted at 12-7 17:34
do you know if the Moto Z3 will work on the Mini

MOTO Z3 is not compatible
2019-12-15
Use props
Berhatz
lvl.2
Flight distance : 113146 ft
Russia
Offline

Hello! And what about Nokia Android phones? For example, Nokia 3.1 Plus. Will it work with DJI Fly App?
2019-12-16
Use props
djiuser_doKwDnYuxNXf
New

United States
Offline

I have a Samsung Tab A that appears to meet the requirement to install the fly app. However, it won't install.
64 bit Arm processor
Android 9

Any ideas?

Thanks
2019-12-22
Use props
Minnesota
lvl.4
United States
Offline

djiuser_doKwDnYuxNXf Posted at 12-22 00:52
I have a Samsung Tab A that appears to meet the requirement to install the fly app. However, it won't install.
64 bit Arm processor
Android 9

There are 32 and 64 bit versions of the Tab A.  2019 versions should be 64 bit.
2019-12-22
Use props
Burak C.
lvl.3
Flight distance : 21814 ft
Turkey
Offline

Hi, I ordered my MM a week ago, waiting to be delivered this week. I checked the Antutu Benchmark it says 64 bits. There is no ARM written in the core section but the app seems to be working just fine with anything connected for now. I think I shouldn't be worried right? Thanks!
2019-12-22
Use props
DowntownRDB
Second Officer
Flight distance : 525 ft
United States
Offline

If you successfully installed the App and it opens without quickly force closing or getting a blank black screen I'd guess your device is compatible.  
2019-12-22
Use props
Sigmo
Second Officer
United States
Offline

My 2019 Tab A 8 doesn't show the Fly App in the Play Store, and if I go to the DJI site and attempt to load it there, it says this app is not compatible with my device.

So clearly, not all 2019 Tab A units are compatible.  I think a lot of us bought Tab A devices recently believing they would make good displays for our Mavic Minis.

It's a good little tablet otherwise.  It's just disappointing to find that it's not supported by DJI.  DJI would make a lot of people happy if the next release of the Fly App has support for a wider range of devices, obviously.

I'm sure, by now, they're feeling the heat from customers and their network of retailers on this issue.  Retailers must be complaining about lots of returns already.  And there will likely be a surge of returns right after Christmas.

Giving people coal in their stockings despite them having been good all year will make DJI the #1 Grinch of the 2019 Christmas season!  Not a good look for any manufacturer.  ;)

Ho Ho Ho.
2019-12-22
Use props
fans28c02dbe
lvl.1
Switzerland
Offline

I found a solution for dji fly for those who do not work on android 10. You need to download the old version of Dji Fly 1.0.2 and have it install but uninstall a new one before.  I hope it works for you too.

Here is the link below from where i downloaded it

https://m.apkpure.com/dji-fly/dji.go.v5/download/2041367-APK
Screenshot_20200109-215649.jpg
Screenshot_20200109-220751_Chrome.jpg
1-9 13:06
Use props
fans28c02dbe
lvl.1
Switzerland
Offline

DO NOT UPDATE THE APP BECAUSE IT WILL CRASH AGAIN until the official solution!!!
1-9 13:45
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules