Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 1 remote wont connect to aircraft or app
367 1 2019-12-12
Uploading and Loding Picture ...(0/1)
o(^-^)o
Absynthe714
lvl.1

United States
Offline

Hey, my name is John and I am new here. I just got a used inspire 1. I have a phantom 4 pro plus but the deal was great on this so I picked it up. It has a z3 camera. So.... I tried to connect to the app when I 1st got it and the app wouldnt connect to the remote, but was still paired to the aircraft. So, I figured that the firmware was too old for it to connect so I upgraded the aircraft 1st..Success to the latest fw, but when I went to use the sd to update the remote.....no joy.I have used several cables,2 iphones, 2 ipad pro's, a note 8 and a s7. none will connect to the remote. there was no connection before I updated the aircraft. I tried resettind the controller c1,c2 etc. I remember reading a post on here from 2017 where someone had a similar problem and rolled back the fw but there is no link to and old firmwares. HDMI was good before this incident as I know the guy who had it. However it was stored for a while and has the sticking travel/flight mode issue. In my attempt to be through and make sure that everything else is functional before taking the tlme to pull it apart and fix that issue, I think I made a mistake with the update. Any links to older firmware or help/solutions would be appreciated. THannks!!!!
2019-12-12
Use props
Mark Guille
Captain
Flight distance : 2031818 ft
Guernsey
Offline

Have a look here

http://www.panorobot.com/dji/inspire_firmwares.htm

Best of luck, keep us posted.

2019-12-15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules