Please select Into the mobile phone version | Continue to access the computer ver.
update DJI go 4!!!
885 11 2019-12-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
DRAGenDROP
Second Officer
Flight distance : 16112582 ft
  • >>>
Netherlands
Offline

When the hell are you goning to update the app on the cristal sky, i can not use the things that i can use when i hook up a ipad.
After a year still no updates.

Thanks DJI for the Sh.t service!

Vincent
2019-12-28
Use props
DJI Natalia
Administrator

Online

Hi Vincent, sorry for the inconvenience. May we know the specific issue that you encountered?
For the update information of the CrystalSky, please refer to the Release Notes on the official web:
https://www.dji.com/crystalsky/info#downloads
2019-12-28
Use props
mAIRs
First Officer
Australia
Offline

You're wasting your time... just look at the stupid answer by that one above... "what issues have you encountered"???!!!! What a stupid insulting throw away question.

Read all of the comments in the CrystalSky section AGAIN Natalia, the hundreds of comments and complaints you arrogant chumps read and ignore.

4444 DJI 44444
2019-12-28
Use props
Keule
Captain
Flight distance : 3733015 ft
  • >>>
Germany
Offline

DJI Natalia Posted at 12-28 22:47
Hi Vincent, sorry for the inconvenience. May we know the specific issue that you encountered?
For the update information of the CrystalSky, please refer to the Release Notes on the official web:
https://www.dji.com/crystalsky/info#downloads

We need GO4 4.3.25 on the Crystalsky.

You should coordinate your internal departments on what they release!
The latest M200 update for example requires:
2019-12-29
Use props
Ruprect
lvl.2
Flight distance : 268510 ft
Australia
Offline

Why can I no longer load third party software on to a device THAT I OWN because I PAID A LOT OF MONEY FOR!!!
DJI You are shooting yourself in the foot. We are the ones that use your drones for our business. We are the ones that go to industry conferences and trade shows and talk to others interested in purchasing your product now AND INTO THE FUTURE. I will be advising everybody to stay away from DJI as you have a very chinese approach to everything you do. Fool me once DJI. The latest Crystal Sky firmware release is nothing but a scam. You need to fix this yesterday.
Disgusted with you YET AGAIN DJI
2019-12-29
Use props
DJI Natalia
Administrator

Online

Keule Posted at 12-29 00:42
We need GO4 4.3.25 on the Crystalsky.

You should coordinate your internal departments on what they release!

Hi Keule, thank you for your reply. We'll forward your request to the related team. Sorry again for the inconvenience caused to you.
2019-12-29
Use props
DJI Natalia
Administrator

Online

mAIRs Posted at 12-28 22:58
You're wasting your time... just look at the stupid answer by that one above... "what issues have you encountered"???!!!! What a stupid insulting throw away question.

Read all of the comments in the CrystalSky section AGAIN Natalia, the hundreds of comments and complaints you arrogant chumps read and ignore.

Hi mAIRs, sorry for the inconvenience. As I replied to Keule, we'll forward your request to the related team.
2019-12-29
Use props
mAIRs
First Officer
Australia
Offline

DJI Natalia Posted at 12-29 19:33
Hi mAIRs, sorry for the inconvenience. As I replied to Keule, we'll forward your request to the related team.

Yeah Yeah yeah whatever lady... I dont think that there's anyone left who believes these kind of copy & paste answers...
We know beyond any doubt that DJI is the worst company in the world when it comes to customer support and the app developers are either m the laziest oost incompetent group ever... absolute rubbish.
2019-12-30
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
Australia
Offline

Time to install Litchi on the CS and maybe when the Mavic Mini SDK comes out, we'll be able to use the CS to fly the Mini as well

https://flylitchi.com/

step by step instructions

https://flylitchi.com/dji-monitors

I've used the mission hub a few times, some good missions on there

https://flylitchi.com/hub

Also liking google maps over mapbox as it's way more detailed

2019-12-30
Use props
mAIRs
First Officer
Australia
Offline

DJI Natalia Posted at 12-29 19:33
Hi mAIRs, sorry for the inconvenience. As I replied to Keule, we'll forward your request to the related team.

Theres only one way for DJI to redeem yourselves... release CS firmware that unlocks all restrictions on the CrystalSky monitor... preferably to install a generic Android OS. This way we would use the generic Android Go4 app and all of these headaches would be gone....

But I know that DJI is NOT listening, doesn't understand english or too lazy, arrogant or stupid to actually do it.

You think that because you're the biggest UAV company right now, but look at the failure of the MavicMini, the loss of customers because of this CrystalSky neglect which is translating into not trusting DJI to purchase the Smart Controller... I look forward to learning the DJI will go bankrupt.. it's coming, and hopefully sooner rather than later.

I don't know why I'm wasting my time responding to you DJI mob... you're hopeless and I've given up on ever seeing any good quality from you, much like any chinese products and there will be a cold day in hell before I get another DJI product... I already steered potential customers AWAY from DJI because of the lack of support.
2019-12-30
Use props
DJI Natalia
Administrator

Online

Keule Posted at 2019-12-29 00:42
We need GO4 4.3.25 on the Crystalsky.

You should coordinate your internal departments on what they release!

Hi Keule, the latest M200 update didn't ask a specific version of the DJI GO4 app, that is to say, the current version of the Crystalsky DJI GO4 APP can also suitable to fly the M200.  So may we confirm the reason that you need the DJI GO4 4.3.25 on the Crystalsky (unable to fly the M200 or any other issues occurred)? Thank you.
1-5 23:50
Use props
mAIRs
First Officer
Australia
Offline

DJI Natalia Posted at 1-5 23:50
Hi Keule, the latest M200 update didn't ask a specific version of the DJI GO4 app, that is to say, the current version of the Crystalsky DJI GO4 APP can also suitable to fly the M200.  So may we confirm the reason that you need the DJI GO4 4.3.25 on the Crystalsky (unable to fly the M200 or any other issues occurred)? Thank you.

What a dog of an answer by a lazy company employee....

To name a couple of features that people who did not get suckered into wasting money on the CS, after wasting money on any DJI equipment, are enjoying are:

there is NO CRITIAL LOW BATTERY setting in the current GO4.3.16, only low battery.

no BAD BATTERY CONNECTION detection,

no setting of time of After how many days the batteries will discharge,

MAP LOADING only shown on flight records instead of the actual location when the GPS is strong,

No HD video option that the CS is capable of as demonstrated in the DJI Pilot 1.6.1, which has HD VIDEO option to preview...

COMPASS INNACCURATE and

auto tracking is jerky when tracking with the M2Z at full zoom...

DJI Stop being LAZY and do you job and give us a complete product that we paid for..



1-6 01:17
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules