Please select Into the mobile phone version | Continue to access the computer ver.
DJI Spark RC Combo connects initially and then immediately discon...
314 3 1-21 16:04
Uploading and Loding Picture ...(0/1)
o(^-^)o
generationnomad
lvl.1

Peru
Offline

hello there,

I have had my DJI Spark RC combo for several months now. About three months ago, I tried to connect to it as I normally would.
It connected initially and then immediately disconnected. The second time I tried it, the RC started beeping like crazy.

Since then I have been battling with this thing. I am travelling for the last couple of months and havent been able to use my Spark drone.
I checked both firmware of Spark drone and Spark RC are up-to-date. I refreshed the firmware on the Spark drone.
I reset the Spark drone to factory settings.
I wrote several emails to DJI support, with no response.

As I am travelling around the world now, I am missing great opportunities to take awesome videos and pics with my drone.
This is very frustrating.

How can I fix this issue?
There are no DJI support centers in all of South America, which is where I am at now.

Can anyone help me?

Thanks!
Tomer



Screenshot 2020-01-21 at 12.12.52.png
IMG_0927.PNG
1-21 16:04
Use props
Wolferl
Captain
Flight distance : 22615 ft
Austria
Offline

Hi Tomer,

Can you do a short video what it looks like when you try to start your Spark and R/C up?

Cheers,
Wolferl
1-22 00:58
Use props
DJI Gamora
Super Moderator

Offline

Hi, thank you for reaching out and we're sorry for the trouble that this has caused. As you've mentioned that the RC is beeping when you turned on, can you please try to calibrate your RC with the drone turned off and try to relink both devices again to see if the problem persists? I will be posting an official tutorial below for the calibration of the Mavic Pro and it is more likely the same with the Spark. Also, If you could provide us a video showing the problem for us to further isolate the issue that would be great. Please keep us posted. Thank you for your understanding and support!

1-22 08:45
Use props
LouisP
First Officer
Flight distance : 41952 ft
United States
Offline

I had the same problem... calibrating the joysticks seems to have fixed it. Or, maybe the problem just went away on it's own.
1-22 11:31
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules