Please select Into the mobile phone version | Continue to access the computer ver.
Sony A6600 (Ronin SC)
2150 22 1-22 07:35
Uploading and Loding Picture ...(0/1)
o(^-^)o
TMRE
lvl.3
United States
Offline

Hello,

I was able to mount the Sony A6600 onto the Ronin SC but noticed that the phone features are non-functional. I'm able to start video recording with the click of the button but unable to take pictures. I am deciding if I should return the gimbal or wait for a future update. Does DJI plan on releasing a firmware update for the Sony A6600?
1-22 07:35
Use props
ormabe
lvl.1

United States
Offline

i got the Sony a6600, I am not sure to get the Ronin Sc yet,  Did that work  with your a6600? did you solve the issue with taking photos? feedback is appreciated
1-25 06:24
Use props
TMRE
lvl.3
United States
Offline

ormabe Posted at 1-25 06:24
i got the Sony a6600, I am not sure to get the Ronin Sc yet,  Did that work  with your a6600? did you solve the issue with taking photos? feedback is appreciated

I'm able to record videos with the button. I'm not able to take photos yet. I'm really hoping this will be fixed in the next firmware.
1-25 12:18
Use props
ormabe
lvl.1

United States
Offline

TMRE Posted at 1-25 12:18
I'm able to record videos with the button. I'm not able to take photos yet. I'm really hoping this will be fixed in the next firmware.

Thanks for let me know! that is bad then. I have been  watching so many review and  video tutorials of different gimbals.  Is it nothing to do with the camera menu, network control with smartphone  TURN OFF?  Then  usb connection to PC REMOTE . I asked somebody who  posts youtube videos.  He told me that he will make a video with the Roni SC and   A6600.  I am not sure if I can copy links here . i do not want get banned! lol
1-25 13:07
Use props
ormabe
lvl.1

United States
Offline

Maybe this will help. Could be the cable? search online for this and let me know if that works.  'DJI Ronin S - New Sony Support & Switched Sport Mode Option - Firmware Info'
1-25 13:42
Use props
ormabe
lvl.1

United States
Offline

it is for A6400, I am very sure it is the cable you are using. This video show how to use two cables different settings. search online , please let me know if that solve your problem. if that works, I can buy the gimbal.  "DJI Ronin SC - Sony A6400 18-105mm Setup, Balance & Active Track Demo"
1-25 13:58
Use props
TMRE
lvl.3
United States
Offline

ormabe Posted at 1-25 13:07
Thanks for let me know! that is bad then. I have been  watching so many review and  video tutorials of different gimbals.  Is it nothing to do with the camera menu, network control with smartphone  TURN OFF?  Then  usb connection to PC REMOTE . I asked somebody who  posts youtube videos.  He told me that he will make a video with the Roni SC and   A6600.  I am not sure if I can copy links here . i do not want get banned! lol

I do have the USB to PC mode selected. The compatibility ends at the Sony A6400. I'm hoping the A6600 will be supported soon.
1-25 14:18
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Sony A6600 is compatible with Ronin-SC and capturing photo is available. May we verify how did you take the picture? Press and hold the Camera Control Button correct?
2-6 01:07
Use props
TMRE
lvl.3
United States
Offline

DJI Mindy Posted at 2-6 01:07
Sony A6600 is compatible with Ronin-SC and capturing photo is available. May we verify how did you take the picture? Press and hold the Camera Control Button correct?

I will verify soon.
2-15 17:13
Use props
TMRE
lvl.3
United States
Offline

DJI Mindy Posted at 2-6 01:07
Sony A6600 is compatible with Ronin-SC and capturing photo is available. May we verify how did you take the picture? Press and hold the Camera Control Button correct?

I tried every button possible, The Ronin SC will record video but not take pictures.
3-24 12:34
Use props
TMRE
lvl.3
United States
Offline

ormabe Posted at 1-25 06:24
i got the Sony a6600, I am not sure to get the Ronin Sc yet,  Did that work  with your a6600? did you solve the issue with taking photos? feedback is appreciated

I'm sorry to say but I wouldn't advise you order the SC for your Sony A6600. Not all features are working.
4-2 06:09
Use props
TMRE
lvl.3
United States
Offline

ormabe Posted at 1-25 13:42
Maybe this will help. Could be the cable? search online for this and let me know if that works.  'DJI Ronin S - New Sony Support & Switched Sport Mode Option - Firmware Info'

I checked the cables multiply times.
4-2 06:15
Use props
TMRE
lvl.3
United States
Offline

DJI Mindy Posted at 2-6 01:07
Sony A6600 is compatible with Ronin-SC and capturing photo is available. May we verify how did you take the picture? Press and hold the Camera Control Button correct?

I would like to take a picture utilizing the gimbal, if I need to hit the camera button then it sort of defeats the purpose of the gimbal?
4-2 06:16
Use props
Advocate
Second Officer
Flight distance : 1076909 ft
  • >>>
United Kingdom
Offline

If you short press the red button on the Ronin-SC it starts recording a video, a long press takes a picture.  On my Sony A6000, which is admittedly a much older camera, I am unable to take a photo whilst the cameras mode dial is set on movie, but am able to both take stills and record movies when the mode dial is set to a picture mode.

Hope this helps.
4-6 12:59
Use props
TMRE
lvl.3
United States
Offline

Advocate Posted at 4-6 12:59
If you short press the red button on the Ronin-SC it starts recording a video, a long press takes a picture.  On my Sony A6000, which is admittedly a much older camera, I am unable to take a photo whilst the cameras mode dial is set on movie, but am able to both take stills and record movies when the mode dial is set to a picture mode.

Hope this helps.

Thank you for the information. I have tried the long press; it focuses and goes straight for video record.
4-11 17:34
Use props
Advocate
Second Officer
Flight distance : 1076909 ft
  • >>>
United Kingdom
Offline

Is that whilst in a picture mode on the mode dial or movie mode?

Are you getting a message on the a6600 screen saying it can’t take a photo?

Not even a long press works whilst the camera (a6000 in my case) is in movie mode.
4-12 14:22
Use props
sbpowers
lvl.1
United States
Offline

an update to this...

I have a Sony A6600 (firmware v1.00 - current version) with the 18/105mm f/4 lens attached to my Ronin SC (firmware v1.1.2.35 - current version).

My issue is that the ability to take photos often disappears. That is, it is present upon powering up the gimbal, then powering up the camera. A long press will trigger the shutter pretty much every time. However, if I then use the button to record video and then stop, sometimes the ability to take photos disappears. I can still record and stop recording videos (short press), but a long press does not take photos. To get this functionality back requires rebooting both the camera and gimbal. I have two MCC Multi cables (purchased a spare) and both perform identically.

Anyone else encounter this glitch?

Thanks.

Steve

4-17 11:12
Use props
Rincewind
lvl.4
  • >>>
Taiwan
Offline

Hi there!
I'm not sure if I'm a little late to the party, but a while ago I had a similar problem with a Sony RX100 VII and Ronin SC. Basically, the camera would take videos, but neither time lapse nor single picture taking would work. What I found out much later, is that if you set the photo shutter button to work as a record button in movie mode, or if you set focus to anything that is not either manual focus, or continuous autofocus, then the ronin SC cannot trigger taking pictures. To be clear, if you want the system to take pictures, then:

1. Make sure that the photo shutter behavior is set to default (i.e. the little red button always starts recording movies, the big black button always takes a picture).
2. Make sure that the focusing mode is either continuous autofocus, or manual focus.
3. At least for time lapses, you have to be in a photo mode for pictures to be taken.

Since my time with the RX100, I have changed the camera to an a6400 (also sony), and can confirm that the same problem persists if the shutter behavior is not set to default.
Hope this helps!
4-20 20:28
Use props
ThatDudeRJ
lvl.1
Flight distance : 13862 ft
United States
Offline

I believe I have the answer for all of you. I have the A6600 with G master 16 to 55 mounted. Many of you explain that the long hold will NOT take photos, and that a short press will record. This happens when you start your camera first and then gimbal. Try this...
- First make sure you are using the Ronin to "SONY" cable. (They are all labled)
- Start gimbal, then realease locks etc.
- THEN start camera.
- It should work now as shown below

You should now be able to:
SHORT PRESS = on/off for record
HALF PRESS = focus (depends on camera focus setting I think)
LONG PRESS = Take photo

If booting your camera the first time did not work try --- booting gimbal first, then camera, and then on off camera again. (so camera boot twice, gimbal remains on)
4-26 10:28
Use props
fansd4b9b7d2
lvl.1
Australia
Offline

TMRE Posted at 4-11 17:34
Thank you for the information. I have tried the long press; it focuses and goes straight for video record.

Did you ever get this working?
I am having the same issue, everything is current firmware, using correct cable and it still will only record and not take stills. I have tried all the suggestions as already and was hoping you or someone else has the solution
7-1 04:46
Use props
TMRE
lvl.3
United States
Offline

fansd4b9b7d2 Posted at 7-1 04:46
Did you ever get this working?
I am having the same issue, everything is current firmware, using correct cable and it still will only record and not take stills. I have tried all the suggestions as already and was hoping you or someone else has the solution

Out of frustration and weeks of trying to figure out a solution. I ended up selling my Ronin on ebay.
7-1 05:20
Use props
fansd4b9b7d2
lvl.1
Australia
Offline

TMRE Posted at 7-1 05:20
Out of frustration and weeks of trying to figure out a solution. I ended up selling my Ronin on ebay.

Thanks for the reply, that’s not what I wanted to hear! Sold my old gimbal because it didn’t support the A6600 at all. I will keep looking, thanks again
7-2 01:38
Use props
fansd4b9b7d2
lvl.1
Australia
Offline

No help to you I know, but anyone else having this issue and reading this post I have had success in getting the A6600 and SC to work properly.
After trying everything I sent the cable back to DJI for testing. The issue lays with the cable. It was repaired/replaced and now works with zero issues.
7-31 02:49
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules