Please select Into the mobile phone version | Continue to access the computer ver.
Vision Plus Controller Not Working
228 2 3-8 22:28
Uploading and Loding Picture ...(0/1)
o(^-^)o
Narrator
lvl.1

Australia
Offline

Hi,

I took my Phantom 2 Vision Plus for a fly yesterday. I got one good flight out of it.

Before the start of my second flight, I got a message on the app saying the controller needs recalibration.
After that message, the Phantom would not respond to control inputs. (Luckily I wasn't up in the air.)


So I took it all home, fired up the RC system assistant, connected the controller, turned it on and got nothing.
No lights showed to say it was connected.
Controls movements got no response.
I changed my USB lead, tried to switch things on in different orders etc. Still nothing.
I also tried it in the Phantom Assistant software. No go.

The RC controller still lights up like it's all working.

Next, I set it all up for flight. The Phantom now responds to controls and there is no message on the phone app.
But still it won't connect to the RC System Assistant, and therefor can't be calibrated.

Any suggestions for what I can do?


3-8 22:28
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

You have Win 10?  See this.  I also had this problem with win 8.1 last year.  Disabling windows driver signature enforecment is what solved it.  

3-9 02:21
Use props
DJI Stephen
Super Moderator

Offline

Hello and good day Narrator. I am sorry for the trouble and thank you for reaching out. For us to be able to assist you further with regards to this issue. Kindly please send an email to support@dji.com for further assistance. Again I am sorry for the trouble and thank you for understanding.
3-9 07:41
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules