Please select Into the mobile phone version | Continue to access the computer ver.
M100 with X5 firmware update and video transmission issue
530 5 2020-3-25
Uploading and Loding Picture ...(0/1)
o(^-^)o
Aerospec
lvl.2

United States
Offline

Hello there,

I've been using the X5 camera with M100 for a couple of years and it worked pretty fine. But when I was trying to fly again yesterday, the video feed was gone, meaning I cannot see what the camera is seeing from my tablet anymore, meanwhile, I can still control the motion of the gimbal and take photos and videos and retrieve them from the SD card just like before.

DJI GO gave me a notice that I need to update the camera firmware, so I downloaded the latest one I can find which is "Firmware Update Package (Zenmuse X5) v.1.3.1.00" and installed it through X5 SD card. It started right but ended failed after about 10 min. I tried to run it again and it failed immediately. BTW, the DJI Assistant 2 is no longer recognizing both of my M100s and I'm not sure why. The update log from SD card is like this:

******************************************************************************
========== 2014.01.01 00:00:06 remo-con disconnect======
Packet: MATRICE100_FC550_FW_V01.03.01.00.bin
Upgrading ...
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:06 remo-con disconnect======
Packet: MATRICE100_FC550_FW_V01.03.01.00.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

========== 2014.01.01 00:00:06 remo-con disconnect======
Packet: MATRICE100_FC550_FW_V01.03.01.00.bin
Result: Failed.
Reboot the aircraft and try to upgrade the firmware again.

******************************************************************************

The version info from DJI GO is now like this:

******************************************************************************
App(Android) 3.1.59
Version 1.3.1.00
Camera 1.8.01.00
RC 1.9.2
Basic fly safe database 01.00.01.09
******************************************************************************
2020-3-25
Use props
Aerospec
lvl.2

United States
Offline

This is what the screen looked like when it first happened.
2020-3-25
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Hi Aerospec, we apologzie for the trouble with the image transmission, could you please enable the hidden file in the SD card and check whether there are detailed logs of the firmare update?
2020-3-29
Use props
Aerospec
lvl.2

United States
Offline

DJI Mindy Posted at 3-29 23:55
Hi Aerospec, we apologzie for the trouble with the image transmission, could you please enable the hidden file in the SD card and check whether there are detailed logs of the firmare update?

Here are the logs from the last few attempts:
*****************************************************************
[00006623]========== remo-con disconnect. boot(15) ============
[00006680]Packet [C:\MATRICE100_FC550_FW_V01.03.01.00.bin] detected, card sn [0x9d1f53b2].
[00006734]Packet upgrade start...

[00006797]Packet checking...
[00006869]Packet vlink 01.03.0100 <-> 01.02.0080.
[00006929]Record vlink 01.03.0100 <-> 01.02.0080 (flow = 0).
[00006993]Done.

[00007060]Version checking[1]...
[00019668][08 00][00] device not detected.
[00019745][03 05][00] v34.1.0.10 -> v34.1.0.10
[00019826][03 06][00] v3.1.5.68 -> v3.1.6.103 need upgrade.
[00019925][12 00][00] v1.12.0.0 -> v1.12.0.0
[00020045][12 01][00] v1.12.0.0 -> v1.12.0.0
[00020146][12 02][00] v1.12.0.0 -> v1.12.0.0
[00020246][12 03][00] v1.12.0.0 -> v1.12.0.0
[00032795][15 00][00] device not detected.
[00032865][19 00][00] v1.0.8.96 -> v1.0.8.96
[00032918][01 00][00] v1.22.5037 -> v1.22.5037
[00032967][01 01][00] v1.9.4499 -> v1.22.5037 need upgrade
[00033026][01 04][00] v0.2.4270 -> v0.2.4270
[00033091][04 00][00] v1.29.0.67 -> v1.29.0.92 need upgrade.
[00033206][05 00][00] v3.0.6.2 -> v3.0.6.2
[00033266][09 00][00] v3.0.0.4 -> v3.0.0.4
[00033365][11 00][00] v3.10.0.0 -> v3.9.0.0
[00033418]Done.

[00036971]Waiting for user confirm...
[00047029]Timeout, start upgrade automatically.

[00047130]Firmware upgrading[1]...
[00047227][01 01] Firmware upgrade start...
[00057513][01 01] Firmware upgrade finished successfully.
[00057672][03 06] Firmware upgrade start...
[00351814][03 06] Firmware upgrade finished successfully.
[00351889][04 00] Firmware upgrade start...
[00403164][04 00] Firmware upgrade finished successfully.
[00403397]Done.

[00403451]Version checking[2]...
[00416002][08 00][00] device not detected.
[00416076][03 05][00] v34.1.0.10 -> v34.1.0.10
[00416156][03 06][05] v3.1.6.103 -> v3.1.6.103
[00416256][12 00][00] v1.12.0.0 -> v1.12.0.0
[00416356][12 01][00] v1.12.0.0 -> v1.12.0.0
[00416456][12 02][00] v1.12.0.0 -> v1.12.0.0
[00416556][12 03][00] v1.12.0.0 -> v1.12.0.0
[00429108][15 00][00] device not detected.
[00429186][19 00][00] v1.0.8.96 -> v1.0.8.96
[00429237][01 00][00] v1.22.5037 -> v1.22.5037
[00429288][01 01][05] v1.22.5037 -> v1.22.5037
[00429376][01 04][00] v0.2.4270 -> v0.2.4270
[00429433][04 00][05] v1.29.0.92 -> v1.29.0.92
[00429516][05 00][00] v3.0.6.2 -> v3.0.6.2
[00429597][09 00][00] v3.0.0.4 -> v3.0.0.4
[00429676][11 00][00] v3.10.0.0 -> v3.9.0.0
[00429727]Packet upgrade failed at version checking.



[00006627]========== remo-con disconnect. boot(15) ============
[00006690]Packet [C:\MATRICE100_FC550_FW_V01.03.01.00.bin] detected, card sn [0x9d1f53b2].
[00006742]Packet upgrade start...

[00006806]Packet checking...
[00006889]Packet vlink 01.03.0100 <-> 01.02.0080.
[00006943]Record vlink 01.03.0100 <-> 01.02.0080 (flow = 0).
[00007006]Done.

[00007074]Version checking[1]...
[00019674][08 00][00] device not detected.
[00019769][03 05][00] v34.1.0.10 -> v34.1.0.10
[00019869][03 06][00] v3.1.6.103 -> v3.1.6.103
[00019969][12 00][00] v1.12.0.0 -> v1.12.0.0
[00020070][12 01][00] v1.12.0.0 -> v1.12.0.0
[00020169][12 02][00] v1.12.0.0 -> v1.12.0.0
[00020269][12 03][00] v1.12.0.0 -> v1.12.0.0
[00032819][15 00][00] device not detected.
[00032884][19 00][00] v1.0.8.96 -> v1.0.8.96
[00032934][01 00][00] v1.22.5037 -> v1.22.5037
[00032987][01 01][00] v1.22.5037 -> v1.22.5037
[00033047][01 04][00] v0.2.4270 -> v0.2.4270
[00033103][04 00][00] v1.29.0.92 -> v1.29.0.92
[00033213][05 00][00] v3.0.6.2 -> v3.0.6.2
[00033284][09 00][00] v3.0.0.4 -> v3.0.0.4
[00033489][11 00][00] v3.10.0.0 -> v3.9.0.0
[00035548]Packet upgrade failed at version checking.



[00006727]========== remo-con disconnect. boot(15) ============
[00006792]Packet [C:\MATRICE100_FC550_FW_V01.03.01.00.bin] detected, card sn [0x9d1f53b2].
[00006848]Packet upgrade start...

[00006922]Packet checking...
[00006987]Packet vlink 01.03.0100 <-> 01.02.0080.
[00007046]Record vlink 01.03.0100 <-> 01.02.0080 (flow = 0).
[00007150]Done.

[00007228]Version checking[1]...
[00019805][08 00][00] device not detected.
[00019905][03 05][00] v34.1.0.10 -> v34.1.0.10
[00020005][03 06][00] v3.1.6.103 -> v3.1.6.103
[00020105][12 00][00] v1.12.0.0 -> v1.12.0.0
[00020225][12 01][00] v1.12.0.0 -> v1.12.0.0
[00020344][12 02][00] v1.12.0.0 -> v1.12.0.0
[00020467][12 03][00] v1.12.0.0 -> v1.12.0.0
[00033019][15 00][00] device not detected.
[00033089][19 00][00] v1.0.8.96 -> v1.0.8.96
[00033142][01 00][00] v1.22.5037 -> v1.22.5037
[00033197][01 01][00] v1.22.5037 -> v1.22.5037
[00033265][01 04][00] v0.2.4270 -> v0.2.4270
[00033327][04 00][00] v1.29.0.92 -> v1.29.0.92
[00033446][05 00][00] v3.0.6.2 -> v3.0.6.2
[00033509][09 00][00] v3.0.0.4 -> v3.0.0.4
[00033624][11 00][00] v3.10.0.0 -> v3.9.0.0
[00035676]Packet upgrade failed at version checking.
*****************************************************************
2020-3-30
Use props
Abdullah_H
lvl.1

Saudi Arabia
Offline

Hello @Aerospec

I am having the exact same issue as you.
2020-11-9
Use props
Aerospec
lvl.2

United States
Offline

Abdullah_H Posted at 2020-11-9 02:16
Hello @Aerospec

I am having the exact same issue as you.

I'm thinking this could be some hardware problem. Maybe a broken cable or board.
1-24 12:10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules