Please select Into the mobile phone version | Continue to access the computer ver.
Intermittent loss of control
871 5 2015-6-15
Uploading and Loding Picture ...(0/1)
o(^-^)o
David Askew
lvl.3

United Kingdom
Offline

The other day I posted on a facebook group that it appeared the like the i1 lost its calibration during flight, i thought it was something to do with either flying over water or a random one-off incident. However the other day it happened again so I'm getting really concerned as it could cause the i1 to fly off very easily if your not on the ball.

I was above water and sand but quite high so i don't think the sensors below are the issue however it only happens in GPS mode even when there are are many as 15 satellites locked in. I took some screenshots so you can see what is going on.

Basically the first thing i notice is the horizon is not level, i let go of all the controls and it doesn't hold its position and flies off in one direction. The compass position is also off showing that the i1 is pointing a different way than it is.

The first screenshot is of it in GPS mode flying at 22/ms when i am not pushing any buttons and the horizon is slightly off. The compass position is also well out as i am by the white building to the left of centre and facing the drone. So if im facing it and its facing me the compass should not be showing it as pointing to the right.

The next image is a more dramatic image of the horizon being out but also the compass position is well out again.

Lastly if i take it out of GPS mode it flies as it should in ATTI mode but as soon as it goes back in to GPS mode it starts to fly off again instantly. When i bring it in lower and closer to me it seems to behave and fly as normal allowing me to land it easily but this wasn't the case the other day.

Yes i did a calibration before setting off and initially the drone was flying as it should but something keeps happens mid flight and it goes haywire. I'm getting scared of flying it now and losing my confidence in it.

I spoke with DJI this morning who confirmed there is an issue. That one operator had had 3 calls already this morning with people having the same issue. These were on the Phantoms but they are getting reports of it on the Inspire as well. A firmware update is due on the Phantoms today or tomorrow but no news yet of one for the Inspire.

Has anyone else experienced this?

1.jpg
2.jpg
2015-6-15
Use props
David Askew
lvl.3

United Kingdom
Offline

The images loaded the wrong way around, so the first image i referenced is the bottom one and the second is the top one.
2015-6-15
Use props
Ph02on
lvl.4
Flight distance : 75673 ft
United Kingdom
Offline

That looks very much like Brean Down to me    What are your sensor mods before take off like David?  Compass should be around 1500, Gyro at 0 and accelerometer at around 1.0.  If your Gyro mod is showing anything other than 0 then the inspire will be trying to compensate for what it sees as movement, even though the aircraft is actually stationary on the ground.  I would suggest a full IMU calibration.  Compass and RC calibration too to see if that improves things.  Repeated calibration before every flight can sometimes lead to issues like this.  When you get a good calibration and your mod values appear sensible, you should consider only calibrating at a new flying location or after a firmware upgrade

Good luck.

Jason
2015-6-15
Use props
freddiebd
lvl.3
Flight distance : 1891184 ft
United Kingdom
Offline

Ph02on Posted at 2015-6-16 02:57
That looks very much like Brean Down to me    What are your sensor mods before take off like David ...

He said he did a compass calibration before take off. Was flying in this location as a one off and cant get the MOD Compass value in the location of flight anymore...
2015-6-15
Use props
Wolfman
Second Officer
Flight distance : 405659 ft
Australia
Offline

Hi David,

you mention DJI have told you that there is an issue.....so what exactly was their response and what is the issue?

Yes, I had a similar event a few months ago. Seems that the craft loses what it thinks is level. The footage of the fly away shows the gimbal rapidly re-setting itself a few times. The last re-set it seems to stop at what it thinks is level but is at about 45 degrees. I was in P-GPS,  looking back on it should have tried switching to ATTI to see if it made any difference but it all happened so quickly.

Will be curious to know the outcome of this David . I have had limited response regarding the cause of my incident despite many requests for information. All I got from DJI was a poorly performing GPS module and a poorly performing accelerometer! I hope they can be more specific with you.
2015-6-15
Use props
David Askew
lvl.3

United Kingdom
Offline

Hi Guys,

Sorry for the late reply ive been busy.

DJI confirmed on the phone this is a bug and that morning the operator that took my call said he had already received 3 calls from other Phantom owners with the same issue. The new phantom uses the sane flight controller so probably something in the firmware to do with that.
2015-6-20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules