Please select Into the mobile phone version | Continue to access the computer ver.
No Bluetooth Permission on iPhone.
634 26 4-13 08:59
Uploading and Loding Picture ...(0/1)
o(^-^)o
Dave_bass5
lvl.4
United Kingdom
Offline

What the hell is going on?
Mimo sees my pocket but tells me it can’t connect to it because of no BT permissions.
This is only using the connector and not the base. This is on my iPhone XS Max. Used to work fine. It's not asked for permission, and as far as I know there is no BT in the pocket, so WTF?
I'm aware 3rd party apps have to ask for permission, but Mimo hasn't allowed to to grant it.
4-13 08:59
Use props
Curt1591
Captain
Thailand
Offline

Go to setting > Bletooth > and look for the pocket / Mimo. See if you can connect.

If no, click the little i with a circle and the "Forget This Device".

Then, shut phone and device off and try to pair again.
4-13 14:14
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Eh? The Pocket doesn’t have Bluetooth, where did you get your info?
4-13 14:19
Use props
Curt1591
Captain
Thailand
Offline

Dave_bass5 Posted at 4-13 14:19
Eh? The Pocket doesn’t have Bluetooth, where did you get your info?

Please forgive me.
What is the "BT" are we referencing ?

https://forum.dji.com/thread-195960-1-1.html
4-13 15:45
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

BT is Bluetooth.
4-13 15:50
Use props
Curt1591
Captain
Thailand
Offline

OK.

Restart your iPhone. Apple devices have a way of mending themselves with a restart.

If that doesn't help, try deleting Mimo and reinstalling it. It may have become corrupted.
4-13 15:57
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Did all that before posting, more than once.
The app needs to have BT permissions granted, even though there is no BT in the device,  but there is no option or window to allow this. This normally happens on install.
Thanks anyway.
4-13 16:00
Use props
Curt1591
Captain
Thailand
Offline

Well, you summed it up - WTF !
4-13 16:03
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Haha, yep.
4-13 16:07
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

Dave_bass5 Posted at 4-13 16:00
Did all that before posting, more than once.
The app needs to have BT permissions granted, even though there is no BT in the device,  but there is no option or window to allow this. This normally happens on install.
Thanks anyway.

Hi Dave, I am sorry to hear that you are experiencing trouble connecting the Osmo Pocket. Please go to system settings, and go to DJI Mimo app and enable to Bluetooth function.
We will optimize this with an update in the future. Thank you for your attention.
4-14 04:30
Use props
Addy Overbeeke
lvl.2
Flight distance : 764869 ft
  • >>>
United States
Offline

I assume you have the WiFi BT adapter?
4-19 14:52
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Addy Overbeeke Posted at 4-19 14:52
I assume you have the WiFi BT adapter?

And I assume you didn’t read my first post ;-)(no is the ovbious answer to both)
4-19 15:56
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

DJI Thor Posted at 4-14 04:30
Hi Dave, I am sorry to hear that you are experiencing trouble connecting the Osmo Pocket. Please go to system settings, and go to DJI Mimo app and enable to Bluetooth function.
We will optimize this with an update in the future. Thank you for your attention.

And that setting is where? Please read my other posts.
4-19 15:58
Use props
blackshady
lvl.2

United States
Offline

Virus attack or maybe iOS cliches?
Maybe you should try updating the iOS again or just restore the iPhone. Just remember to back up before restoring.
Though you can back up the data, there is still a chance that you could lose your data of some third-party app that you forget to back up.
To prevent this, you can use Joyoshare iPhone System Recovery to repair the iOS as a whole and see if that can fix the problem. The repairing process conducted by this program is absolutely secure, and it will not damage your data at all.
4-19 22:59
Use props
DJI Thor
Administrator
Flight distance : 13602 ft
Offline

Dave_bass5 Posted at 4-19 15:58
And that setting is where? Please read my other posts.

Please kindly go to your mobile device's system settings, find the DJI Mimo app and enable Bluetooth for it. See if this helps.
4-20 02:28
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

It’s already on. This is my point. I’ve reinstalled the app 3 times, doing the usual re boots etc. Turned it off and on again. Error still persists in the Mimo app when I connect the pocket.
4-20 04:19
Use props
Curt1591
Captain
Thailand
Offline

Have you tried connecting through the USB-C port, just for giggles?
4-20 15:33
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

No, because that’s not how I want to use it.
4-20 15:39
Use props
Curt1591
Captain
Thailand
Offline

Dave_bass5 Posted at 4-20 15:39
No, because that’s not how I want to use it.

If it works through the USB-C port, I was thinking it might isolate the problem to the phone adaptor or connections through the adaptor, giving a little more info to work with.

4-20 16:20
Use props
Curt1591
Captain
Thailand
Offline

Have you tried cleaning the contacts?
4-20 16:21
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Ok. I’ll give the cable a go in the morning. As far as the adapter goes, I have two and both do this this. I have wiped the contacts on the pocket, as I normally use the wheel (which works fine)/
4-20 16:26
Use props
Curt1591
Captain
Thailand
Offline

Any new insights?
4-22 20:23
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Sorry, forgot to post back. Cable method is working fine.
4-23 02:24
Use props
Curt1591
Captain
Thailand
Offline

Must be some sort of connection problem with the adapter. Would be interesting to get a schematic for which contacts serve which functions. Unfortunately, it will probably require a teardown to fix.
4-23 14:21
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

I think it’s the app and the way it gets installed.
From what I read, 3rd party apps need to request Bluetooth access when they get installed. The app hasn’t asked for it, but is telling me it needs it.
I did notice on one install that the window came up to ask for the permission, but then it got covered by another so I couldn’t click on it, and then it went away with the covering window.
4-23 14:26
Use props
Curt1591
Captain
Thailand
Offline

I'm using my trusty old iPhone 6. It can't run ios13. Never asked for BT. Never had any problems.

What is weird, to me, is that it connects with the wireless, connects with the USB, but asks for BT with the adapter. One might think that, if it is needed for one, it would be needed for all three.
4-23 16:47
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Yes, it’s a strange one. I’m going to try it on a friends phone over the weekend and see if it’s any better. It was working fine until last week, but I must admit I hardly use it so I have no real way of telling at what point it started playing up.
Not the end of the world and I’m sure it will be fixed or I’ll find a way of fixing it.  
I still need to try my Osmo mobile 3 with the app. Now that does need BT so that’s going to be a bigger pain if that doesn’t work.
4-24 01:51
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules