Please select Into the mobile phone version | Continue to access the computer ver.
Why can't the OSDK-ROS sample run with a non-M210 series drone?
214 4 4-21 09:20
Uploading and Loding Picture ...(0/1)
o(^-^)o
dji-doc
Moderator
Hong Kong
Offline

Please turn off ADVANCED_SENSING. Since the non-M210 series drones do not support the ADVANCED_SENSING function, the OSDK-ROS sample cannot be run.
---------------------
Solution: Turn off the ADVANCED_SENSING function in the dji_sdk_node.cpp code.
---------------------
- SDK version: OSDK 3.9.x - Supported products: M100, A3 / A3 Pro, N3, M600 / M600Pro

4-21 09:20
Use props
kjhardrict
lvl.2

United States
Offline

How does one "turn off ADVANCED_SENSING"? I tried commenting out the various blocks of code that had ifdef's involving ADVANCED_SENSING, but it still seems to be enabled when I run the sample code, and it fails.
6-9 08:04
Use props
xiao long
lvl.3

South Africa
Offline

kjhardrict Posted at 6-9 08:04
How does one "turn off ADVANCED_SENSING"? I tried commenting out the various blocks of code that had ifdef's involving ADVANCED_SENSING, but it still seems to be enabled when I run the sample code, and it fails.

May I ask what aircraft model you use, and OSDK version?
6-10 06:01
Use props
kjhardrict
lvl.2

United States
Offline

OSDK 3.8.1 and the Matrice 600 Pro
6-17 14:33
Use props
xiao long
lvl.3

South Africa
Offline

https://forum.dji.com/forum.php? ... D746%26typeid%3D746
You can refer to this link. The problem looks the same and is solved.
6-18 04:16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules