Please select Into the mobile phone version | Continue to access the computer ver.
M2P failed after 2 days. Has anyone any ideas?
147 5 4-25 23:56
Uploading and Loding Picture ...(0/1)
o(^-^)o
Dave064
lvl.1
Flight distance : 397 ft
Australia
Offline

Hi folks,

New Mavic 2 Pro owner. Struggling with this issue after scouring forums for a similar issue and fix. Can't find anything.

My M2P after three small test flights wont boot up, has no LED lights (batt light is on) and won't connect to Controller and won't connect to Assistant 2. It's like it is in an electonic coma.

History:

After 2 days and three 10 minute flights, I turn it on once more.

I get a message to update the database on where I can and can't fly it. I do so. I then notice some minutes later that the video on the app is frozen (using a Huawei P20 Pro which is an approved phone I now learn). Maybe these actions are unrelated. I turn off app and restart and now I have no video at all. It's just black. I restart controller, restart app and restart M2P. M2P starts up and message on controller says I have magnetic anomoly issue. (Never had that before starting drone in same place). I move location. Problem persists. I also notice altitude is -400m and desending even though stationary on floor. Magnetic anomoly messages continue after more reboots and moving around.

I Google forums and recognise an IMU recalibration is recommended. I do so. All appears to go well with LEDs doing their blinking thing.

I then reboot once more and have notice no LEDs come on when the drone is powered on. I also note that there is no sound beeps when the drone is powered on. Battery light is on solid and props jiggle as normal. Controller will not say it is connected on display although binding status LED is green. Controller keeps "connecting...." but never connects. I have tried rebinding - which always works but the M2P is still in a coma. Go 4 app intermittently connects then drops, then connects, then drops for moments only. I connect M2P to PC but the USB connection constantly connects and disconnects. It's not the driver signing issue as I went through that. Assistant connects to controller but not the aircraft so I can reload firmware.

I am running latest firmware released as of today's date. Those updates were first to run on day 1 from power on. Total runtime on aircraft is 18 min for a massive total of 122m travelled !!

Does anyone have any idea what problem I have? Can I resolve this? It seems like the firmware is corrupted somehow or the insides have failed. I am sure the M2P is a wonderful machine but after only 48 hours of having one, I am somewhat frustrated and disappointed.

Dave
4-25 23:56
Use props
Dave064
lvl.1
Flight distance : 397 ft
Australia
Offline



Screen shot of Go 4 app when black screen first occurred. It shows "Main Controller data error" in red. A clue no doubt.
4-26 00:31
Use props
Dave064
lvl.1
Flight distance : 397 ft
Australia
Offline

4-26 00:35
Use props
bluebubble
lvl.2

South Africa
Offline

Hey, never saw this before. Did your drone crashed or hardlanding before? If the problem exist after IMU recalibration and firmware updates, I recommend you to sent your drone to DJI for further diagnosis.
4-26 01:47
Use props
Dave064
lvl.1
Flight distance : 397 ft
Australia
Offline

Thanks. No crashes. It was hardly ever used.

I fully intend to return to DJI Service unless there is another explanation by an experienced technical user. It's new (very new) and I took out the DJI Care Refresh option. I wasn't expecting to claim warranty after 2-3 days !!
4-26 01:57
Use props
Dave064
lvl.1
Flight distance : 397 ft
Australia
Offline

Dave064 Posted at 4-26 01:57
Thanks. No crashes. It was hardly ever used.

I fully intend to return to DJI Service unless there is another explanation by an experienced technical user. It's new (very new) and I took out the DJI Care Refresh option. I wasn't expecting to claim warranty after 2-3 days !!

Hi all,

The unit was replaced under warranty as it was within 7 days of purchase. No idea what the cause of the issue was. Can't complain about that !
4-26 19:30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules