Please select Into the mobile phone version | Continue to access the computer ver.
Poor Video Feed Quality on iPhone 6+
2137 10 2015-6-15
Uploading and Loding Picture ...(0/1)
o(^-^)o
jwhite
lvl.2

United States
Offline

Hey guys. I thought I had this fixed the last few times I've been in the forum asking about it but I seem to be wrong. I'm using the P3 Professional with an iPhone 6+. I have all my firmware updated (per this morning) and my pilot app is up to date. I ran all of my calibration today before the flight, made sure hardware decode was on, turned iPhone into airplane mode, re-linked my RC to my drone, and all the small tunings/calibrations. YET, I'm still having issues with my feed. I can see what's going on but the quality is all pixelated and randomly will flash out or show delayed video. I was hoping it was just a general issue but my boss bought the P3 Pro as well and I took his out right after mine and even hooked in my phone as well and his feed was super clear with no lag or pixelation or delays.
Any idea what this issue might be? It's really frustrating and honestly is keeping me from shooting a lot because I don't trust the drone enough to get close to anything or even fly more than 1000ft away because I'll basically lose my video feed completely and control delay is crazy bad. I'm having this issue of feed pixelation at any distance. I see it even when I turn it on right next to me on the ground. This happens in wide open fields on clear days from tests. It's been happening for 3 weeks now and I was waiting on a firmware update to see if that was the issue, twas not.

Again, everything is up to date firmware wise and app wise, I did the hardware decode, I've relinked my RC to the Drone, and I've done all the calibration processes. Also I'm getting told there is full bars of connection for the phone and RC at the top of my app. Really a tad lost on a fix for this.

Any help appreciated, let me know if you have questions so I can help make more sense of the situation.
2015-6-15
Use props
fiskld
lvl.2

United States
Offline

I hear ya, I'm having the same problem with the 6+. Then I use my iPad and it functions perfectly. I have no idea why it works great on the iPad but not my 6+.
2015-6-15
Use props
Willie Wonka
First Officer

United States
Offline

fiskld Posted at 2015-6-16 05:42
I hear ya, I'm having the same problem with the 6+. Then I use my iPad and it functions perfectly. I ...

what version iPad you are running that shows everything perfect ?
2015-6-15
Use props
jwhite
lvl.2

United States
Offline

Here is how bad it is. I took some screenshots of my screen while it would lock up

Image 1: https://www.dropbox.com/home?preview=File+Jun+15%2C+4+54+42+PM.png
Image 2: https://www.dropbox.com/s/ivfqkmfid4gl7tw/File%20Jun%2015%2C%204%2054%2019%20PM.png?dl=0
2015-6-15
Use props
Willie Wonka
First Officer

United States
Offline

jwhite@schillin Posted at 2015-6-16 05:55
Here is how bad it is. I took some screenshots of my screen while it would lock up

Image 1:  https: ...

try this and let me know :

turn on transmitter then P3
open the pilot app
connect the transmitter to the phone while in pilot app
test and see if tearing still continues in the video feed.
2015-6-15
Use props
ithork
lvl.1

United States
Offline

How warm does your phone get?  I've noticed the issues you describe when my iPhone or iPad gets warm (I'm in Vegas so that happens :/).
2015-6-15
Use props
DJI-Autumn
First Officer

Hong Kong
Offline

You can shutdown other processes before start the Pilot. Overhit can affect the performance of the app.
2015-6-16
Use props
jwhite
lvl.2

United States
Offline

DJI-Autumn Posted at 2015-6-16 18:44
You can shutdown other processes before start the Pilot. Overhit can affect the performance of the a ...

Everything is shut down prior to running app and during. I close apps, then turn off wifi, bluetooth, and put on air plane mode, then start pilot app. Doing this stopped the phone overheating, but didn't stop the lag.
2015-6-16
Use props
jg18970
lvl.2
United States
Offline

I have been having same issue with iPhone 6 since update 1.2.6.  Tearing in pilot app.  After following Willie Wonka's procedure it seems to be stable now.  What is the difference of connecting the iPhone to the transmitter after transmitter and P3 have started up and app is up and running?
2015-6-16
Use props
jg18970
lvl.2
United States
Offline

Spoke to soon, tearing re-appeared but not as bad after a few minutes.  Phone isn't getting hot as others have described.
2015-6-16
Use props
skyeboysteve
lvl.4
Flight distance : 5616722 ft
United States
Offline

Jwhite, interesting that your boss' phantom seems to broadcast video better than yours.  I'm curious though if you did this test in the same settings?  Did you test his phantom in the office while you're testing yours outside in a grassy field?

I've noticed with my phantom, that the processor tends to overheat when the video codec is having to compress lots of FINE detail (like flying low over tall grass, or low over patterns of roof tile) before transmitting to your RC/tablet/phone.  Codecs always struggle with detail and require more processing power--therefore more heat.  Inside an air conditioned office looking at bland walls and desks without fine detail or repeating patterns isn't going to heat up your Phantom's image processor much.

Anyway, just an idea to consider...
2015-6-22
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules