Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 3 4k no downlink video
194 2 6-7 13:12
Uploading and Loding Picture ...(0/1)
o(^-^)o
frankrizzo350
lvl.1
Flight distance : 125 ft

United States
Offline

Hi, I'm having an issue with my P3-4k.  - I have no downlink realtime video on the app.
- The gimbal LED is solid red.

I really dont want to send it in if I can fix it here at home.  I'm tried manually putting the firmware on the SD card, but that didnt help.  

I use the DJI app to format the SD card, but the app says formatting FAILED.

I tried to go back to an older FW, but I dont think its working, App always says latest.

Any other things for me to try?

Regards
6-7 13:12
Use props
JetSam
Captain
Flight distance : 2374311 ft
Spain
Offline

Welcome frankrizzo350  i would try another Sd Card ( Class 10 )


6-8 02:23
Use props
DJI Stephen
Super Moderator

Offline

Hello there frankrizzo350. I am sorry for the trouble this has caused and thank you for reaching out. Have you tried using a different suggested SD card on your DJI Phantom 3 4K and see if the issue will still persist. For reference I will post specifications of suggested SD card for the DJI Phantom 3 4K for reference. Thank you.



6-14 23:51
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules