Please select Into the mobile phone version | Continue to access the computer ver.
Critical Error
240 3 6-22 18:49
Uploading and Loding Picture ...(0/1)
o(^-^)o
Vampichoco
lvl.4
Mexico
Offline

Hello everyone,

Yesterday morning I went hiking to a usual spot that I've visited a couple times and have flown my Spark without any issues. First take off was normal and I managed fly a few meters up and away. Whole flight probably lasted 3 min max. I brought it back and suddenly I got a warning that there was some magnetic interference. I decided to not risk it and went on my way to a less secluded area of the trail.

Second flight was a mess. Everything started up and all indicators were green, but then as it was taking off it started hovering erratically until it hit a plant. It didn't get that high and needless to say instead of hovering up in the same place as it went up like it usually does it moved to the side on its own and crashing. I checked for damages and eveything was intact. I tried again and got it slightly higher to take a sphere panoramic shot. Everything was going smooth until it started behaving erratically again. It started moving side to side a little bit at first, but then it looked like if I let it go any longer it would fly beyind my reach. Out of fear that this time it might lose control and fall down the side of the mountain I caught it and called it day.

When I got home I decided to test in the backyard to see if maybe up in the mountain the strong winds were making behave that way. To my surprise it started doing exactly the same thing as soon as it took off. It was going up and down on its own and then side to side. I tried landing it, but it wasn't responding to the controller and instead it was going down, lightly hitting the ground (had a landing accessory so it didn't hit the ground directly) and then up again. Once again, everything was green and there was no indication of any error. I recalibrated the compass once, tried flying with the same result, calibrated the compass again and no luck. I searched online and saw a few older threads of people with the same experiences. Unfortunately half of the threads ended in nobody knowing what's wrong and the other half with "I gave up, returned the spark and got a mavic".

Decided to try again after I calibrated the IMU and it did okay the first minute. Then it started behaving erratically again except now I am getting all 4 red lights which to my understanding is a critical error. I calibrated the compass, checked that every firmware is up to date on batteries, RC and drone using DJI Assistant and everything seems to be in order. Any help or tips? Spark was working flawlessly 3 months ago when I last used it on the exact same hiking trail.

6-22 18:49
Use props
DJI Stephen
Super Moderator

Offline

Hello there Vampichoco. I am sorry to read and to know what happened to your DJI Spark. Since there was a crash that happened before and this unfortunate event happened I would recommend you to contact our DJI support team at https://www.dji.com/support?site=brandsite&from=nav for further assistance. We have a professional team that will do there best to check the said drone and will give out the best resolution for this issue. If the said drone is still under the warranty period and it is evaluated as a non-pilot error, the warranty service will be provided. Just a friendly reminder that  DJI do not recommend doing a DIY in fixing the said DJI drone to avoid further damaging the said unit. Again I am sorry for the trouble and thank you for your support.
6-24 22:07
Use props
Vampichoco
lvl.4
Mexico
Offline

DJI Stephen Posted at 6-24 22:07
Hello there Vampichoco. I am sorry to read and to know what happened to your DJI Spark. Since there was a crash that happened before and this unfortunate event happened I would recommend you to contact our DJI support team at https://www.dji.com/support?site=brandsite&from=nav for further assistance. We have a professional team that will do there best to check the said drone and will give out the best resolution for this issue. If the said drone is still under the warranty period and it is evaluated as a non-pilot error, the warranty service will be provided. Just a friendly reminder that  DJI do not recommend doing a DIY in fixing the said DJI drone to avoid further damaging the said unit. Again I am sorry for the trouble and thank you for your support.

Hi Stephen,

I did sent an email to DJI support. I also posted on reddit to see if anyone else had encountered a similar issue.

Now I am not exactly sure what or why, but what I did was reset the drone to factory settings and it started flying without any problems. Every now and then it would start behaving erratically again, but then it would stop and fly normal. Not sure what is causing it, but I think it might have been the landing hear I had attached (an official landing gear accessory btw) that may have been messing with the bottom sensors.

I also noticed that it seems to be going into ATTI mode far more often than before which is a minor inconvenience, but nothing major. I've been practicing taking off and landing from my hand just to avoid using the landing gear accessory and so far so good.

Also, since I reset the drone the firmware is not updated, but in the DJI app it says everything is up to date and it flies better than before so not sure what to do about that. Everything else seems fine.

Will upgrade to a Mavic Mini as soon as I can, but for now the drone is working.
7-7 09:04
Use props
DJI Stephen
Super Moderator

Offline

Vampichoco Posted at 7-7 09:04
Hi Stephen,

I did sent an email to DJI support. I also posted on reddit to see if anyone else had encountered a similar issue.

Hi there Vampichoco. Thank you for the reply and for giving us these information. Please keep us posted for us to be able to help you further. Again, thank you and fly safe always.
7-8 00:38
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules