Please select Into the mobile phone version | Continue to access the computer ver.
Failure to register app [ios]
102 7 7-14 17:13
Uploading and Loding Picture ...(0/1)
o(^-^)o
djiuser_d9gtAvUNsatq
lvl.1
Canada
Offline

Whenever I open up my app and the app registration process begins, I’m given this error:
Domain=DJISDKRegistrationErrorDomain Code=-3 "The server may be busy or is not reachable.(code:-3)

I’ve tried opening up the app without a product connection just to activate it, but no luck.

Please advise.
7-14 17:13
Use props
kv886
lvl.4

South Africa
Offline

It looks like your Internet is poor
7-15 03:17
Use props
djiuser_d9gtAvUNsatq
lvl.1
Canada
Offline

kv886 Posted at 7-15 03:17
It looks like your Internet is poor

My internet connection is quite stable, it seems as though every time I install a new build, the issue pops up again. After a few tries the app is able to register. Any ideas?
7-15 09:15
Use props
kv886
lvl.4

South Africa
Offline

Do you use 4G or WIFI?
7-15 23:48
Use props
Susanmusk
lvl.1

India
Offline

You can also check these latest iOS apps for greater benefits.
7-20 22:16
Use props
Susanmusk
lvl.1

India
Offline

Susanmusk Posted at 7-20 22:16
You can also check these latest iOS apps for greater benefits.

I must say you can get the prior response from the iOS emulator team for your project.
7-24 03:01
Use props
Susanmusk
lvl.1

India
Offline

https://appvalley.fr/
7-24 03:02
Use props
DJI_Lisa
Second Officer
United States
Online

djiuser_d9gtAvUNsatq Posted at 7-15 09:15
My internet connection is quite stable, it seems as though every time I install a new build, the issue pops up again. After a few tries the app is able to register. Any ideas?

Since ultimately, this is an internet connection error it sounds like you'll need to do some troubleshooting to figure out what is going on here

Here you can see a list of these errors: https://developer.dji.com/api-re ... isdkgeoerror_inline



And as you can see this message is thrown after an http timeout - so a couple things to check:

  • If, as you say, your internet is stable, then is the problem with the device you're loading your app on? Are you connected via WiFi or you cellular data? Does it happen if you try another device or XCode simulation?
  • Is your code for registration set up in an optimal way?  Can you reproduce the issue on the iOS Sample App? https://github.com/dji-sdk/Mobile-SDK-iOS

If you continue to have this issue please reach out to my team at dev@dji.com so we can help isolate and then fix the problem.

~Lisa, DJI Developer Support
7-24 11:06
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules