Please select Into the mobile phone version | Continue to access the computer ver.
Matrice 300 RTK Waypoint Mission Node ROS OSDK
101 1 8-24 10:53
Uploading and Loding Picture ...(0/1)
o(^-^)o
avashist
lvl.3

United States
Offline

                                         
Hello,

  
I am using a M300 RTK with the Assistant 2 simulator. The M300 RTK is also interfacing with a Jetson TX2, on which the dji_vehicle_node ROS node is running. On another machine on the same network, I am executing the stock ROS mission node (i.e rosrun dji_osdk_ros mission_node). Once the mission node starts up and hotpoint mission is selected, the drone takes off in the simulator, and executes the hotpoint mission successfully. Once the drone is manually landed in the simulator, I re-ran the mission node this time selecting the waypoint mission. I keep getting an error stating that the waypoints could not be uploaded, and thus the mission could not be started. As a sanity check, I repeated this process by running the mission node on the jetson TX2 instead of another computer on the same network and I got the same results. I am running the 4.0 version of the OSDK and latest firmware on the drone itself.

The specific warning can be seen in the text below. Note that I have obfuscated the GPS coordinates manually for this post.

rosrun dji_osdk_ros mission_node
| Available commands:                                            |
| [a] Waypoint Mission                                             |
| Hotpoint Mission                                              |
a
[ INFO] [1598033274.960758176]: Creating Waypoints..

[ INFO] [1598033274.983822393]: Waypoint created at (LLA): xxxxxx     xxxxxx      10.000000

[ INFO] [1598033274.983928023]: Uploading Waypoints..

[ INFO] [1598033274.983985211]: Waypoint created at (LLA): xxxxxx      xxxxxx      10.000000

[ INFO] [1598033274.984042063]: Waypoint created at (LLA): xxxxxx      xxxxxx      11.000000

[ INFO] [1598033274.984106322]: Waypoint created at (LLA): xxxxxx      xxxxxx      12.000000

[ INFO] [1598033274.984162461]: Waypoint created at (LLA): xxxxxx      xxxxxx      13.000000

[ INFO] [1598033274.984206335]: Waypoint created at (LLA): xxxxxx      xxxxxx      14.000000

[ INFO] [1598033274.984254896]: Waypoint created at (LLA): xxxxxx      xxxxxx      15.000000

[ INFO] [1598033274.984304865]: Waypoint created at (LLA): xxxxxx     xxxxxx      10.000000

[ INFO] [1598033274.984353724]: Initializing Waypoint Mission..

[ WARN] [1598033385.768247719]: ack.info: set = 255 id = 255
[ WARN] [1598033385.768407834]: ack.data: 65535
[ WARN] [1598033385.768540060]: Failed sending waypoint upload command

Any help would be appreciated.
                                      
8-24 10:53
Use props
kv886
lvl.4

South Africa
Offline

It seems commands 'a' doesn't support M300. Command a only supports M210 v2
8-25 03:49
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules