Please select Into the mobile phone version | Continue to access the computer ver.
Props/Motors will not spin
1250 8 2014-11-20
Uploading and Loding Picture ...(0/1)
o(^-^)o
dacfile
lvl.1

United States
Offline

         I have a 4 week old P2V+,  been flying daily,  flew it 5 days ago, put it up for cold weather,  went out this afternoon,  all batteries charged, it went thru its startup routine,  green lights blinking, 8 satellites present, all systems go...  push the toggles down and in,  NOTHING.   All the power was still on, green lights  still blinking.   All I got was a very slight camera twitch..   I noticed during the startup routine that the camera did not tilt up to level, which I think it always does... SO  I did the rebind thing, still  NOTHING the same as above.      I will state after all the latest firmware updates that my camera would not tilt by my Tablet control,  and I read here to change the TX from upgrade to basic via the Asst.      That fixed the camera issue and I did fly it twice after that, and there were no issues.       ANY IDEAS????  what to do next  
                                       
2014-11-20
Use props
kenargo
First Officer
  • >>>
United States
Offline

When you connect the Assist software to the Phantom do you see the ticks moving the controls (on the RC page)?  I figure that's a good way to tell if the Phantom is receiving signal.
2014-11-20
Use props
dacfile
lvl.1

United States
Offline

kenargo Posted at 2014-11-21 07:20
When you connect the Assist software to the Phantom do you see the ticks moving the controls (on the ...

I just did a recalibration on the RC...  and it fixed it.   But I do not understand how it could lose calibration just sitting for five days in the same spot it always sit.   For now it works and flies another day...
2014-11-20
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

Cold can cause a tx to drift.
2014-11-20
Use props
brerwolfe
lvl.2
Flight distance : 2481385 ft
United States
Offline

I've been having the same issue with my Phantom 2. I get rapid green lights saying it's good to go, then when I try to activate the motors it flashes red a few times, then goes back to its normal blinking green lights.

Out of my last 9 attempts, I've only gotten it in the air twice. Any help??????
**Edit: I should mention that I live in Orlando and the weather has been excellent. The climate is not to blame.
2014-11-20
Use props
kenargo
First Officer
  • >>>
United States
Offline

brerwolfe@gmail Posted at 2014-11-21 11:09
I've been having the same issue with my Phantom 2. I get rapid green lights saying it's good to go,  ...

Had something like that happen to me today.  I calibrated the compass and the green lights came on and stayed on.  I can't say for certain that the compass calibration did anything but the green lights remained green once I did it.
2014-11-20
Use props
brerwolfe
lvl.2
Flight distance : 2481385 ft
United States
Offline

In case I wasn't clear-- I get the green lights, but then I get red lights when I try to start the motors. The Phantom will not get off the ground.

I've tried changing batteries, I've tried re-calibrating, I've tried power cycling, I've changed locations, I've held it in the air, upside down, tapped on it, and at the moment I'm thinking about pissing on it.

I've run it through the software and everything looks good. I can't figure this out. Any help is endlessly appreciated.
2014-11-20
Use props
Autumn
First Officer

China
Offline

How about re-tuning the controller?
2014-11-20
Use props
dacfile
lvl.1

United States
Offline

Autumn Posted at 2014-11-21 13:34
How about re-tuning the controller?

define the difference between re-tuning the controller and re-calibrating?   I assume controller = TX   Forgot to add, the TX and/or P2V+ never got colder that 71 inside my house.
2014-11-21
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules