Please select Into the mobile phone version | Continue to access the computer ver.
Incompatible Firmware version (Code 30224)
12Next >
6947 49 2020-9-14
Uploading and Loding Picture ...(0/1)
o(^-^)o
SeanGalbraith
Second Officer
Flight distance : 213753 ft
Canada
Offline

I bought a new Mavic Mini (old one was stolen) and am setting it up. It has the most recent firmware installed... but in the preflight check it says "incompatible firmware version. Go to Profile > Settings to update firmware (Code: 30224)" ... the firmware is up to date. What's up?
2020-9-14
Use props
SeanGalbraith
Second Officer
Flight distance : 213753 ft
Canada
Offline

I also note that plugging it into DJI Assistant also shows that it has the most recent firm ware
2020-9-14
Use props
Suren
Captain
Flight distance : 7737779 ft
  • >>>
New Zealand
Online

is it not the battery firmware that needs updating, plug into assistant and do a firmware refresh with each battery
2020-9-14
Use props
SeanGalbraith
Second Officer
Flight distance : 213753 ft
Canada
Offline

Thanks! Doing a refresh with only 1 of the batteries in it seems to have done the trick.
2020-9-14
Use props
Suren
Captain
Flight distance : 7737779 ft
  • >>>
New Zealand
Online

SeanGalbraith Posted at 9-14 12:11
Thanks! Doing a refresh with only 1 of the batteries in it seems to have done the trick.

You are welcome
2020-9-14
Use props
DJI Stephen
Super Moderator

Offline

Hello there SeanGalbraith. I am sorry to read and to know that you are having this issue with your DJI Mavic Mini before and it is great to know to know that you were able to fix the said after following the post of Suren on post #2. Have a safe and a happy flying always.
2020-9-14
Use props
nasnat
lvl.2
Israel
Offline

Having the exact same issue in mini 2, dji assistant is not supporting it yet...
2020-12-1
Use props
djiuser_vIsz7bA20JI5
lvl.1

United States
Offline

nasnat Posted at 12-1 02:53
Having the exact same issue in mini 2, dji assistant is not supporting it yet...

I am having this exact issue. There was a fly safe update which I took and then it completely broke everything, which may not be connected, but that is what happened. I was flying. Then the update came through I landed. completed the update and now I have a paperweight.
2020-12-1
Use props
fans61f2e6ed
lvl.1

United States
Offline

djiuser_vIsz7bA20JI5 Posted at 12-1 10:12
I am having this exact issue. There was a fly safe update which I took and then it completely broke everything, which may not be connected, but that is what happened. I was flying. Then the update came through I landed. completed the update and now I have a paperweight.

Hey, Same exact thing happened to me Just now after the update it landed and that was it, got the error
2020-12-1
Use props
Jeremiah Swedeen
lvl.1

United States
Offline

Has anyone found anything mine just did this as well?
2020-12-1
Use props
Master J
lvl.1

Canada
Offline

I literally just bought this drone a few hours ago. Brought it home. Charged the battery and controller. Downloaded the app. It said there was a fly zone update. I Took the update. Now I go to try my first fly and I can't because of the exact same problem.....I can't believe this. So much excitement to get this thing home from the store to try and now I can't even use it. I'm so frustrated!!!!!!!!!!!!!!!
2020-12-1
Use props
nasnat
lvl.2
Israel
Offline

Master J Posted at 12-1 17:28
I literally just bought this drone a few hours ago. Brought it home. Charged the battery and controller. Downloaded the app. It said there was a fly zone update. I Took the update. Now I go to try my first fly and I can't because of the exact same problem.....I can't believe this. So much excitement to get this thing home from the store to try and now I can't even use it. I'm so frustrated!!!!!!!!!!!!!!!

I'm sending mine (new that never flown) to the official Importer in my country to fix this...
very frustrating!
2020-12-2
Use props
djiuser_RSAbrWQVX2Sc
New
Flight distance : 420781 ft
United States
Offline

Same thing happened to me today. I simply installed a different battery, powered everything back up, flew for a couple minutes, then installed the original one back in. Problem solved.
2020-12-2
Use props
skydwellers_
lvl.1

United States
Offline

nasnat Posted at 12-2 12:06
I'm sending mine (new that never flown) to the official Importer in my country to fix this...
very frustrating!

Were you able to solve this? I'm having the same problem.
2020-12-2
Use props
nasnat
lvl.2
Israel
Offline

skydwellers_ Posted at 12-2 21:23
Were you able to solve this? I'm having the same problem.

No...
waiting for the pick up of the drone
2020-12-3
Use props
bjr981s
First Officer
Flight distance : 125732 ft
  • >>>
Australia
Offline

DJI Stephen Posted at 9-14 21:48
Hello there SeanGalbraith. I am sorry to read and to know that you are having this issue with your DJI Mavic Mini before and it is great to know to know that you were able to fix the said after following the post of Suren on post #2. Have a safe and a happy flying always.

Stephen,

The new version of Assistant 2 does not recognise the Mini 2 correctly on a Mac. It recognises the controller and updates, but the Mini 2 takes you to the wrong page in Assistant.  

I have a thread on this but nobody from DJI has acknowledged.

Cheers


2020-12-3
Use props
djiuser_Ly3v61pfalB4
New

Australia
Offline

Just experienced this on my mini 2 but managed to get it going again. Can't guarantee it'll work for everyone but worth a shot.

I wiped the cache and data of the dji fly app and turned both the controller and drone off then on again. After that the warning was gone. I then tempted fate and reinstalled the database update and things are still working

May be worth a try

2020-12-5
Use props
djiuser_7qSaF1vd7IeP
New

United Kingdom
Offline

djiuser_Ly3v61pfalB4 Posted at 12-5 01:56
Just experienced this on my mini 2 but managed to get it going again. Can't guarantee it'll work for everyone but worth a shot.

I wiped the cache and data of the dji fly app and turned both the controller and drone off then on again. After that the warning was gone. I then tempted fate and reinstalled the database update and things are still working

BRILLIANT, IT WORKED!!!!!!!!!!!!!!!!!!!! THANK YOU, YOU WONDERFUL HUMAN BEING!!!!!!
2020-12-5
Use props
DJI Stephen
Super Moderator

Offline

bjr981s Posted at 12-3 04:13
Stephen,

The new version of Assistant 2 does not recognise the Mini 2 correctly on a Mac. It recognises the controller and updates, but the Mini 2 takes you to the wrong page in Assistant.  

Hello there bjr981s. I am sorry fro the trouble this has caused and thank you for reaching out. The DJI Mini 2 cannot currently use DJI Assistant 2 for firmware updates. DJI Assistant 2 can only be used to export aircraft and remote controller data. Please use the DJI Fly application to update the firmware for your DJI Mini 2. If the error still persists, please provide us with a screenshot of the error message. We would like to help you check it. Thank you.
2020-12-8
Use props
Sokratiskar
lvl.1

Greece
Offline

Happy New Year everybody!!! I just bought a new Mavic Mini 2. It has the most recent firmware installed but in the preflight check it shows "incompatible firmware version. Go to Profile > Settings to update firmware (Code: 30224)" ... the firmware is up to date. I ve done all the actions you have mentioned inside here but nothing.... Any suggestions??

1-1 03:34
Use props
djiuser_vKYVnWcIfcDP
New

Sweden
Offline

I just experienced this fault. Like other users, I had updated the fly safe data and then got the error when attempting to fly.
I simply turned off the mini, pulled the battery, put the same battery back in then restarted the mini. Problem solved.
1-1 07:08
Use props
Sokratiskar
lvl.1

Greece
Offline

djiuser_vKYVnWcIfcDP Posted at 1-1 07:08
I just experienced this fault. Like other users, I had updated the fly safe data and then got the error when attempting to fly.
I simply turned off the mini, pulled the battery, put the same battery back in then restarted the mini. Problem solved.

Did it of course... but nothing happened. Talked with the online support of DJI and just told me to get it back on the store after some actions they made me do (uninstall and install the App etc.).
1-1 13:00
Use props
djiuser_suqV8GZWiaoY
New

United Kingdom
Offline

Hi everyone,

I've just received my Mavic mini today, got everything set up, checked for firmware updates and installed them. Still cannot fly, I get a prompt (incompatible firmware) however there are no updates prompts within the fly app.

How do I check for firmware updates for batteries as I haven't had any prompts and can't find a tab to do so either. Is this something I have to do with a brand new mini?

Any help would be great as I can't wait to get in the sky!
1-5 18:43
Use props
Eclecticfish
lvl.1
Denmark
Offline

Just got a mini 2 today, and i sadly have this exact same issue, have tried the suggestions in this thread but they dont seem to work. :/
1-7 14:25
Use props
djiuser_Hsgg6OEELsDj
lvl.1
Flight distance : 79537 ft
United Kingdom
Offline

Has anyone got a resolution to this issue? I'm starting to think even DJI don't know how to fix this.

I am in the same situation with my newly opened Mini 2. I updated it fresh out of the box and immediately got the incompatible firmware error. Deleting and reinstalling the app doesn't work, updating battery firmware doesn't work, deleting the cache of the app doesn't work, and the DJI Assistant for PCs does not allow the refreshing or updating of firmware for the Mini 2. Other than claiming a replacement through the warranty, I am at a complete loss what to do with this drone which I haven't even flown yet.

Any other potential ideas from experienced DJI users out there?
1-7 14:42
Use props
djiuser_Hsgg6OEELsDj
lvl.1
Flight distance : 79537 ft
United Kingdom
Offline

DJI Stephen Posted at 2020-12-8 22:10
Hello there bjr981s. I am sorry fro the trouble this has caused and thank you for reaching out. The DJI Mini 2 cannot currently use DJI Assistant 2 for firmware updates. DJI Assistant 2 can only be used to export aircraft and remote controller data. Please use the DJI Fly application to update the firmware for your DJI Mini 2. If the error still persists, please provide us with a screenshot of the error message. We would like to help you check it. Thank you.

This error seems to come up for a few users of the Mini 2. Have DJI found out why it is occuring and what can be done about it other than getting a replacement drone?
1-7 14:44
Use props
djiuser_8VzSZqe5QqkI
lvl.1

India
Offline

Same issue, all my firmware is up to date but the error message doesn't go, couldn't fly my brand new mini 2 for the first time, I bought it from US and brought it to India, can't think of sending the unit back!
It's with the fly safe updates it seems, I tried iOS Android, ISSUE REMAINS! DJI please send a resolved update this is so frustrating!!

1-8 04:21
Use props
DJI Susan
Administrator

Offline

djiuser_Hsgg6OEELsDj Posted at 1-7 14:44
This error seems to come up for a few users of the Mini 2. Have DJI found out why it is occuring and what can be done about it other than getting a replacement drone?

Hi, you can provide your DJI account to me, I will a beta firmware to try.
1-9 03:56
Use props
DJI Susan
Administrator

Offline

For there, for Mini 2 users who are getting the incompatible firmware message, we apologize for any inconvenience caused by this issue. It is likely that the issue you described is caused by the Fly Safe database being updated on an earlier version of the DJI Fly app. As the previous app version is incompatible with the current database, the app will prompt an error message.

We recommend that you update the DJI Fly app to the latest version, and provide your DJI Fly account name to us. We will send an optimized firmware version to you to fix this issue. Thank you for your understanding and support.
1-9 03:58
Use props
Manu_valn
lvl.1
France
Offline

DJI Susan Posted at 1-9 03:58
For there, for Mini 2 users who are getting the incompatible firmware message, we apologize for any inconvenience caused by this issue. It is likely that the issue you described is caused by the Fly Safe database being updated on an earlier version of the DJI Fly app. As the previous app version is incompatible with the current database, the app will prompt an error message.

We recommend that you update the DJI Fly app to the latest version, and provide your DJI Fly account name to us. We will send an optimized firmware version to you to fix this issue. Thank you for your understanding and support.

Hello, I am in this situation. I sent you my information by private message.
1-9 20:28
Use props
DJI Susan
Administrator

Offline

Manu_valn Posted at 1-9 20:28
Hello, I am in this situation. I sent you my information by private message.

Received and replied.
1-10 03:08
Use props
Lapa
lvl.1

United Arab Emirates
Offline

DJI Susan Posted at 1-10 03:08
Received and replied.

Hello,
I have sent you pm, but still waiting for your reply!
1-11 00:40
Use props
DJI Susan
Administrator

Offline

Lapa Posted at 1-11 00:40
Hello,
I have sent you pm, but still waiting for your reply!

Hi, sorry for the delay, I had received your PM and forwarded the firmware.
1-11 01:31
Use props
Lapa
lvl.1

United Arab Emirates
Offline

DJI Susan Posted at 1-11 01:31
Hi, sorry for the delay, I had received your PM and forwarded the firmware.

Hi, seems to work now. Thank You!
1-11 02:20
Use props
DJI Susan
Administrator

Offline

Lapa Posted at 1-11 02:20
Hi, seems to work now. Thank You!

Thank you for your feedback, happy flying.
1-11 05:26
Use props
Manu_valn
lvl.1
France
Offline

DJI Susan Posted at 1-11 05:26
Thank you for your feedback, happy flying.

EVERYTHING WORKS FOR ME TOO. THANK YOU
1-11 07:32
Use props
Eclecticfish
lvl.1
Denmark
Offline

Hi I have send you a pm too, hope it helps.
1-12 04:26
Use props
Leon Stone
lvl.1
Flight distance : 577858 ft
United Kingdom
Offline

DJI Susan Posted at 1-9 03:58
For there, for Mini 2 users who are getting the incompatible firmware message, we apologize for any inconvenience caused by this issue. It is likely that the issue you described is caused by the Fly Safe database being updated on an earlier version of the DJI Fly app. As the previous app version is incompatible with the current database, the app will prompt an error message.

We recommend that you update the DJI Fly app to the latest version, and provide your DJI Fly account name to us. We will send an optimized firmware version to you to fix this issue. Thank you for your understanding and support.

Have pm also, hopefully sort mine out too, regards
1-14 01:28
Use props
DJI Susan
Administrator

Offline

Leon Stone Posted at 1-14 01:28
Have pm also, hopefully sort mine out too, regards

Hi there, please PM me your DJI account as well.
1-14 03:56
Use props
DJI Susan
Administrator

Offline

Eclecticfish Posted at 1-12 04:26
Hi I have send you a pm too, hope it helps.

Hi there, beta had already forwarded to your account, please check.
1-14 03:58
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules