Please select Into the mobile phone version | Continue to access the computer ver.
How to Disable DJI Go on an iPad ?
318 4 2020-10-27
Uploading and Loding Picture ...(0/1)
o(^-^)o
Muttley7
lvl.4
United States
Offline

I understand that if DJI Go is not disabled in the settings menu, it is likely to conflict with Litchi, but on my new iPad, I haven't thus far spotted the exact settings option that allows one to disable DJI Go, so as to use Litchi.
I have a bunch of saved Litchi flight plan missions that I created on the Litchi Mission Hub with my desktop computer, after which I downloaded a couple into the Litchi app on my iPad, BUT, whenever I try to start the drone motors after powering everything up, I get that ominous error message saying the IMU is being calibrated.  

Having at one point tried to wait for the IMU calibration process to complete, and realizing that the process can take many hours beyond the capacity of the Phantom 3S battery, I have come to regard that IMU message as an order to shut down, pack it up, and try to get airborne some other day.   This IMU message is more prevalent with Litchi, but also, if I dare start up Litchi on any given day, the IMU calibration message also inhbits motor startup even with DJI Go, for the rest of that day.

Suspecting that the IMU calibration message might be arising from some hidden conflict arising from my not being able to properly disable DJI Go whenever I attempt to use Litchi, I thought I'd better ask here in this forum, to see if anyone can outline the steps I will need to take to disable DJI Go on an iPad, without having to uninstall it completely.  Thanks in advance for any help that can be offered.  

2020-10-27
Use props
Muttley7
lvl.4
Canada
Offline

All's well that end's well, and I learned from the DJI website how to calibrate the IMU indoors, in just 5 minutes.  For anyone who suddenly encounters the IMU calibrate error message, set the drone on a table top indoors, and tap the following  sequence.  Camera, Setup, Sensor Setting, Check IMU, Calibrate IMU, OK, then wait five minutes, and Bob's yer uncle, done !   The drone flies smooth as silk once again, and I just flew my very first Litchi auto-flight with 100% success.  In summary, when all else fails, read the instructions ha ha
2020-10-27
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft

Offline

Hello Muttley7, thank you for reaching us out and I appreciate your inquiry. You can disable the DJI Go app only if you uninstall it. DJI applications are optimized to use with the DJI Aircrafts. Though, you can try to follow this settings to see if the DJI Go app will no longer interrupt your flight while using a third party application.
1. Go to Settings of your iPad.
2. Find the DJI Go app.
3. Turn off or toggle not allowed all access such as location, photo etc.
4. Ensure that the DJI Go app is always closed and not running in the background. You can double click the home button of your iPad to see the applications that is still running in background.

After doing those steps please try. If the issue persist you will need to uninstall the DJI Go app if you insist to use the third party application.

On the other hand, in regards to the IMU Calibration. It requires to be in a flat level surface to conduct the calibration and follow the instructions provided else, it will fail or stuck and won't move the progress bar to continue the calibration process. Thank you.
2020-10-27
Use props
Muttley7
lvl.4
Canada
Offline

Thank you so much for this informative response, DJI Paladin.  I managed to muddle through the IMU calibration following the instructions in a video on the subject in the DJI website, and I was pleasantly surprised  to see the whole process run its course to completion in just 5 minutes.

Also, I am grateful for the explanation you have provided describing how to simply toggle off the permission dialog box inside DJI Go, in order to ensure that DJI Go doesn't conflict with Litchi.  Before I read your very helpful response here, I actually did manage to fly a fully autonomous Litchi mission  which went very well, even without my having disabled that DJI Go feature, so at least for my drone, it does appear that DJI Go does not in any way interfere with Litchi, even when all DJI permissions are left active.  Once again I thank you kindly for this insightful advice that helps eliminate guesswork for this novice in all things DJI.
2020-10-27
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft

Offline

Muttley7 Posted at 10-27 20:34
Thank you so much for this informative response, DJI Paladin.  I managed to muddle through the IMU calibration following the instructions in a video on the subject in the DJI website, and I was pleasantly surprised  to see the whole process run its course to completion in just 5 minutes.

Also, I am grateful for the explanation you have provided describing how to simply toggle off the permission dialog box inside DJI Go, in order to ensure that DJI Go doesn't conflict with Litchi.  Before I read your very helpful response here, I actually did manage to fly a fully autonomous Litchi mission  which went very well, even without my having disabled that DJI Go feature, so at least for my drone, it does appear that DJI Go does not in any way interfere with Litchi, even when all DJI permissions are left active.  Once again I thank you kindly for this insightful advice that helps eliminate guesswork for this novice in all things DJI.

Hi Muttley7, I'm glad that your concern has been resolved. IF you have any concern, questions or inquiry please do not hesitate to post here in DJI Forum. Enjoy flying your drone. Fly safe! Thank you for your support.
2020-10-30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules