Please select Into the mobile phone version | Continue to access the computer ver.
Ronin SC2 Record Button not working for Canon Eos R6
3203 17 2020-11-3
Uploading and Loding Picture ...(0/1)
o(^-^)o
djiuser_BWl8p701nfB9
lvl.2
Flight distance : 20732 ft
Germany
Offline

Hey, has anyone else the problem that the record button does nothing for the EOS R6? According to DJI the camera ist compatible but for me it does nothing. Yes I put the usb c cable in the rss connection. Yes I tried all of the shooting modes.
2020-11-3
Use props
fans43734448
lvl.1
United States
Offline

have the same setup and it worked fine for me
2020-11-3
Use props
djiuser_BWl8p701nfB9
lvl.2
Flight distance : 20732 ft
Germany
Offline

fans43734448 Posted at 11-3 17:07
have the same setup and it worked fine for me

Oh that sounds cool, how did you get it?
1)  Did you put the camera in a special mode (M, video, etc), (af/mf)?
2)Did you adapt any Settings of the gimbal or did you just put the cable in?
3) Did you use the USB c to USB c?
2020-11-4
Use props
Reno Luo
New

Singapore
Offline

djiuser_BWl8p701nfB9 Posted at 11-4 10:57
Oh that sounds cool, how did you get it?
1)  Did you put the camera in a special mode (M, video, etc), (af/mf)?
2)Did you adapt any Settings of the gimbal or did you just put the cable in?

I have the same problem, even worse, whenever I hit the record button, the Canon R6 will crash down like a PC and will not respond to anything I do. Have to take out the battery to turn it off and restart...  it’s quite weird. Still figuring out what wrong
2020-11-14
Use props
RocDoc
lvl.1

United Arab Emirates
Offline

I have same problem, nikon z6ii, ronin sc2, both fresh out of the box.
Plug in usb-c cable to rss and to camera.
Set disp lever to movie, set mode to P, turn on camera.
Red button on gimbal does not auto focus, does not start or stop video. It does take a snapshot if pressed and held.
The movie monitor rec icon has a line through it.
No explanation in nikon online manual, just 'cannot record movie'.
If I unplug cable from camera, I can record from camera movie button, reconnect cable and 'no record' icon appears.
Just about fed up enough to send the gimbal back !
2020-11-20
Use props
djiuser_W7P3X8XUmg53
lvl.1
Germany
Offline

RocDoc Posted at 11-20 08:46
I have same problem, nikon z6ii, ronin sc2, both fresh out of the box.
Plug in usb-c cable to rss and to camera.
Set disp lever to movie, set mode to P, turn on camera.

RRS 2s is not compatible with Z6 II. I hope the new firmware will come soon.
2020-11-21
Use props
RocDoc
lvl.1

United Arab Emirates
Offline

New firmware from DJI.
I have updated the firmware on my gimbal. I turned off the gimbal and the smartphone Ronin application.
I am using a Samsung S7 Android phone on the phone mount. I also am using a Samsung Note20 for remote.
When I restarted the first time, the smartphone application hung while connecting to my gimbal. I turned gimbal and smartphone application off again.
I restarted the mobile phone. I turned on the gimbal first, and waited for the menu to show. Then I turned on the smartphone and started the ronin application.
The application connected to the gimbal in less than 5 seconds.
The gimbal now works in every respect. Camera movement, start record, stop record, snapshot. All gimbal menu options that I have tried work correctly.
I now have to connect raveneye and focus motor (for zoom) and test those.
I am pleased with the firmware update, which has fixed the problems I had with the RSC2 gimbal.
2020-11-26
Use props
djiuser_EwyCBYtOOsji
New

Poland
Offline

djiuser_BWl8p701nfB9 Posted at 11-4 10:57
Oh that sounds cool, how did you get it?
1)  Did you put the camera in a special mode (M, video, etc), (af/mf)?
2)Did you adapt any Settings of the gimbal or did you just put the cable in?
Did You solve the problem? Just trying to connect same set, rsc2 with r6 and the cable is not working. When I was in dji shop with my camera to test rsc2 everything work fine. Maybe it is issue with new canon firmware?
2020-12-25
Use props
djiuser_BWl8p701nfB9
lvl.2
Flight distance : 20732 ft
Germany
Offline

djiuser_EwyCBYtOOsji Posted at 12-25 05:59
Did You solve the problem? Just trying to connect same set, rsc2 with r6 and the cable is not working. When I was in dji shop with my camera to test rsc2 everything work fine. Maybe it is issue with new canon firmware?

Unfortunately I had to sent back the gimbal.
2020-12-25
Use props
DjHush
lvl.1
United States
Offline

Ok i got a fix for you guys with the Canon R5/R6. First these cameras do not have a physical switch to choose between camera and video. That being said, you have to press the mode button> then the info button at the bottom of your LCD screen. At this point you will see your video options. Select your option, then come out of there... and go to your menu in the camera section (red) page 6. you will now have access to "enable " remote control. Once that is all done power down your camera and gimbal, mount and connect your camera USB-C cable, at this point power on the gimbal first...then the camera. at this point the record button should be functional. Hope this helps you guys, get out and get creative. Cheers and happy holidays.
2020-12-29
Use props
djiuser_UI4XRsAjpUjb
lvl.3
Flight distance : 745768 ft
  • >>>
United States
Offline

I've been having the same issues for quite some time..been losing my mind.

Does this fix really help?  I will give it a shot.
5-3 05:24
Use props
djiuser_UI4XRsAjpUjb
lvl.3
Flight distance : 745768 ft
  • >>>
United States
Offline

Still no good.  It's bananas that dji and a popular camera eos r6 can't take video and stills??  I can only take video, if in video mode on the camera.   Am I doing something wrong?
5-3 05:40
Use props
djiuser_ps6HtWdHCD3f
New

Canada
Offline

Reno Luo Posted at 2020-11-14 09:31
I have the same problem, even worse, whenever I hit the record button, the Canon R6 will crash down like a PC and will not respond to anything I do. Have to take out the battery to turn it off and restart...  it’s quite weird. Still figuring out what wrong

I got same problem with my r6 . When i hitt record button it crashed and need to take battery out. Did you found whats going on,? Plz let me know.
6-30 17:45
Use props
HarroNZ
lvl.1
New Zealand
Offline

Did anyone get a fix for this? The record button on the ronin won’t work, it can focus, can take a photo if camera in photo camera mode and video mode, but it won’t start to record a video in video or any mode. If in ronin app force mobile starts and stops video fine.

7-21 18:40
Use props
djiuser_DjElMyxoFroD
lvl.2
Iran
Offline

Hi! I have same issue with my RSC 2 and Canon 90D , when I start recording everything is fine , but when I stop recording screen goes off and can't play or see anything !!!! If I turn off canon and RSC 2 sometimes Camera change automaticly to Photo mode !!!
Is there a solution for this
8-12 22:01
Use props
djiuser_DjElMyxoFroD
lvl.2
Germany
Offline

Reno Luo Posted at 2020-11-14 09:31
I have the same problem, even worse, whenever I hit the record button, the Canon R6 will crash down like a PC and will not respond to anything I do. Have to take out the battery to turn it off and restart...  it’s quite weird. Still figuring out what wrong

I have same issue with my 90D , and noone wants to answer
8-14 08:41
Use props
TimNATC
lvl.1
United States
Offline

It worked fine for me.
8-14 10:01
Use props
djiuser_DjElMyxoFroD
lvl.2
Iran
Offline

TimNATC Posted at 8-14 10:01
It worked fine for me.

What is your config ! I can't fix my problem
8-14 22:25
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules