Please select Into the mobile phone version | Continue to access the computer ver.
Brand New Phantom 2 Wobbling In Air
2469 21 2014-11-22
Uploading and Loding Picture ...(0/1)
o(^-^)o
sasvet02
lvl.1

United States
Offline

This is my second Phantom 2. The first one was my 'guinea pig'. Learned alot, but clearly not enough.

Out of the box, this phantom is wobbling side to side. I put it through an advanced IMU calibration. The issue is still present.

Attached are the screenshots from the Phantom 2 assistant. Any ideas?
IMU Calibrations.png
Specs.png
2014-11-22
Use props
ghostmaster
lvl.3

Portugal
Offline

everything seems normal, but not the gains... they arent the stock ones.

Try this ones:
120 120 120 200
220 220
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

ghostmaster Posted at 2014-11-23 06:24
everything seems normal, but not the gains... they arent the stock ones.

Try this ones:

Thanks ghostmaster, I just put in those gain settings you mentioned. Are those the stocks ones? I haven't touched them since opening the box. It's dark here now, so will test it out tomorrow morning.

I also noticed one of the motors twitches on start-up. Here's a video:



Once powering up the props, that same prop/motor seems to be spinning slightly slower than the rest. It also stops before the rest. Video below.



Can that be the reason for the wobble?
2014-11-22
Use props
away-point
lvl.4

United States
Offline

In case you hadn't noticed, mousing over the yellow "?" in the IMU Calibration window shows useful info.

Off the top of my head, 1500 is too high for the compass.  Have you tried compass calibration in the field?  
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

away-point Posted at 2014-11-23 07:10
In case you hadn't noticed, mousing over the yellow "?" in the IMU Calibration window shows useful i ...

Are you referring to the compass 'dance' calibration? (turning it 360 degrees until green LED lights)

That does not fix the issue. How does one calibrate the compass in the assistant? (not by computer at the moment)
2014-11-22
Use props
insitb
lvl.4

Singapore
Offline

OP, can you confirm that your props are completely free spinning? With the motors off, there's no resistance at all when you push the props around using your finger? Oddly, that's what it looks like on your video.
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

With the props on (motors off), there is the magnetic click with each spin of the prop, when doing it very slowly. The motor that is slightly slower than the rest, moves more 'freely', but still has that magnetic click when spinning slowly.

When just flicking the props, they spin freely.
2014-11-22
Use props
insitb
lvl.4

Singapore
Offline

But when you flick the props, they still spin against the drag of the magnets, correct?
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

Correct. All seem to spin without any issues.
2014-11-22
Use props
kenargo
First Officer
  • >>>
United States
Offline

away-point Posted at 2014-11-23 07:10
In case you hadn't noticed, mousing over the yellow "?" in the IMU Calibration window shows useful i ...

For Mod the values should be between 750 and 2250 (according to the hover over).  X, Y and Z should be -500 - +500.
2014-11-22
Use props
kenargo
First Officer
  • >>>
United States
Offline

ghostmaster Posted at 2014-11-23 06:24
everything seems normal, but not the gains... they arent the stock ones.

Try this ones:

The gain values in my unit (just received yesterday are the same as your unit);

125 125 120 140
260 260
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

kenargo Posted at 2014-11-23 10:34
The gain values in my unit (just received yesterday are the same as your unit);

125 125 120 140

And all works well with your drone?
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

kenargo Posted at 2014-11-23 10:33
For Mod the values should be between 750 and 2250 (according to the hover over).  X, Y and Z shoul ...

So then looks like my numbers are fine...
2014-11-22
Use props
kenargo
First Officer
  • >>>
United States
Offline

sasvet02@gmail. Posted at 2014-11-23 10:36
And all works well with your drone?

Yes, I've had it out flying a few times and it's flies nice and stable.  
2014-11-22
Use props
sasvet02
lvl.1

United States
Offline

kenargo Posted at 2014-11-23 10:42
Yes, I've had it out flying a few times and it's flies nice and stable.

Never ending stories with these things. Looks like there are still faulty drones/gimbals floating around out there.

Hope someone else might chime in. I'll be talking to my dealer (B&H) tomorrow, let's see what they say. They usually say to just swap it for a new one, but to be honest I'm more interested in knowing how to fix it. Based off all these issues you see people writing about,  these tools can get out of whack after a while. Knowing how to trouble shoot the issues, will come in very handy.
2014-11-22
Use props
chris
lvl.4

Indonesia
Offline

did imu advanced calibration.. worked..
2014-11-22
Use props
ghostmaster
lvl.3

Portugal
Offline

Strange DJI changed the gains, the stock was the ones i shared....
2014-11-22
Use props
Daninho
Second Officer

Germany
Offline

ghostmaster Posted at 2014-11-23 15:04
Strange DJI changed the gains, the stock was the ones i shared....

The gains were changed alot since the first release of the P2. Many new FW updates brought new gains if you clicked at the "default" Button after installing the new FW. Your gains were the first from december 2013. Mod 1500 is normal.

To the OP: In your video database are alot of videos showing problems including one with a motor failure, did you repaired all those problems? Your Gimbal was faulty, your motor and so on. You also added FPV i saw, maybe this causes balance problems or some other issues.
2014-11-22
Use props
ghostmaster
lvl.3

Portugal
Offline

Daninho Posted at 2014-11-23 15:50
The gains were changed alot since the first release of the P2. Many new FW updates brought new gain ...

Im not sure if the default gains are really meant to be used with the phantom 2...
2014-11-23
Use props
Daninho
Second Officer

Germany
Offline

ghostmaster Posted at 2014-11-23 21:03
Im not sure if the default gains are really meant to be used with the phantom 2...

Well, since they come with a Phantom only flight controller i would guess so, the FW of it is different to a normal Naza V2. Another point is i think someone said that his new Phantom came with the higher gains so i guess those are the latest default gains
2014-11-23
Use props
sasvet02
lvl.1

United States
Offline

Daninho Posted at 2014-11-23 15:50
The gains were changed alot since the first release of the P2. Many new FW updates brought new gain ...

The previous videos were during my first phantom. I did fix all those issues, and then sent it in to be replaced for a new one. This new drone is the one I'm working with.

I did install an FPV setup and it was flying all wobbly. I thought maybe it was due to it losing its center of balance from all the devices (although it's a basic set-up everyone uses with no issues). So I took everything off it, and started flying with just the drone, and the issue is still there. So clearly it's a drone issue.

I have a feeling it has something to do with the slower motor, because none of the advanced IMU calibrations are doing anything.
2014-11-23
Use props
sasvet02
lvl.1

United States
Offline

Update:

I put in the numbers 'ghostmaster' recommended. Did an advanced IMU calibration on a cold drone (first thing in the morning). I also put on  a new set of props (9443). Today is a gorgeous day, virtually no wind, and the drone is flying flawlessly.

Yesterday, there was wind, but nothing that I would expect to make the drone wobble side to side (winds were roughly 8-10 mph).

I will now attached the gimbal, see if it still flies without issue, followed by the FPV set-up.

Hard to tell what made it fly correctly today, hopefully it'll stay like this. Will keep you guys posted.
2014-11-23
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules