Please select Into the mobile phone version | Continue to access the computer ver.
Tello Power and Charging Issues
984 5 2020-12-22
Uploading and Loding Picture ...(0/1)
o(^-^)o
robotrick
lvl.1

Austria
Offline

Hi Guys,

the main problem is, I can't turn on the Tello (6 month old, 2 flight hours). If i press the power button, but the LED stays off. When I try to charge the battery via the drone, the led turns green, blinks red quickly a few times and then the blue light flashes three times for a second and once for 3 seconds and this keeps going forever. After 4 hours charging nothing has changed. Then I updated the firmware, but nothing... Does anyone have an idea whats going on?

Thanks in advance.



2020-12-22
Use props
RYZE
Super Moderator

South Africa
Offline

Dear customer,
The normal status of indicator during charging via drone should be blue and blinks once per second regularly and periodically, when the charging is finished, the indicator turns into solid blue. According to your description, the charging is abnormal,  please try with another adaptor of 5V1A-5V2A or Micro USB wire.
If the problem still persists, Please contact us via support@ryzerobotics.com.
2020-12-23
Use props
djiuser_xoakOfyZdy8n
New

Italy
Offline

I have the standard firmware problem (turn Tello on, get one shot of green light, then some flashing red lights and then drone is dead), so I try the reset procedure to update firmware keeping pressed the power-on button...green led stays on for some seconds then turns off, I release the power button and the led keeps blinking red...now I can connect to the drone's wifi to update firmware...but it always tells me I got less than 50% battery (even with brand new battery fully charged with external charger) -.-

Anybody knows a way to fix this please?
2-1 15:23
Use props
RYZE
Super Moderator

China
Offline

djiuser_xoakOfyZdy8n Posted at 2-1 15:23
I have the standard firmware problem (turn Tello on, get one shot of green light, then some flashing red lights and then drone is dead), so I try the reset procedure to update firmware keeping pressed the power-on button...green led stays on for some seconds then turns off, I release the power button and the led keeps blinking red...now I can connect to the drone's wifi to update firmware...but it always tells me I got less than 50% battery (even with brand new battery fully charged with external charger) -.-

Anybody knows a way to fix this please?

Dear customer,
We are sorry for the inconvenience brought to you, please contact us via support@ryzerobotics.com for a furthur troubleshooting.
Hope my reply could help you!
2-1 21:56
Use props
El Argentino
New

Argentina
Offline

hi there, i had the same problem and i came up with the solution. The real problem is the app, to update the firmware you need to install the tello app v1.1.1 (you can find it online) and a charge battery.
Without the battery press and hold the power buttom and conect the charger, keep holdin the power buttom and insert the battery, when the green led turn off release the power buttom. It will turn a pulsing red light, connect the tello to your device and procede to install the firmware from the app.
this work for me and i hope works for you.
sorry about my inglish i´m from argentina
3-3 10:08
Use props
Anonymous_guy
lvl.2

United States
Offline

One reason could be since you didn't use the batteries for a long time, they lost their juice.  I recommend buying a new battery.
4-12 05:04
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules