Please select Into the mobile phone version | Continue to access the computer ver.
How to properly disconnect from Tello?
760 2 2020-12-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
twissmueller
lvl.4
Flight distance : 3504 ft
Germany
Offline

I am writing an application in Swift for iPhone to control my Tello drone. I can connect to it and send payloads like "command", "takeoff" and so on.

But I am having trouble understanding how to properly disconnect from the Tello when I close my application. Here is the process:

When turning on the Tello and after it has booted up, the status LED is blinking yellow.

Then I establish a UDP-connection with Apples Network Framework which I have explained on my blog.

After the UDP-connection has been established I am sending the "command"-payload to the Tello and the yellow blinking LED is turning constantly green.

When I close my app though, I want the Tello to return to a blinking yellow state, but I have not found a way on how to do that. In my case the LED stays green and then turns red because nothing is being send to the Tello any more. After a while the UDP-connection fails and I cannot reestablish a proper connection when starting my application. I have to turn the Tello off and then on agian which I do not want.

I want to be able to properly disconnect from the Tello so I can then connect again if necessary without having to restart my Tello.

It is possible though, because that is how the official Tello application is actually behaving. When it is closed, the Tello LED turns from constant green to blinking yellow. When the Tello app is started again, the LED turns constant green again.

Any hints are highly appreciated. Thank you!


2020-12-29
Use props
Vola Telo
lvl.1

Germany
Offline

AFAIK the default yellow blinking behavior is just for the binary protocol. Once you switch into SDK mode you no longer have that
2-18 12:15
Use props
twissmueller
lvl.4
Flight distance : 3504 ft
Germany
Offline

Vola Telo Posted at 2-18 12:15
AFAIK the default yellow blinking behavior is just for the binary protocol. Once you switch into SDK mode you no longer have that

Exactly, the question is how to get back to the yellow blinking / binary protocol? It must be possible, because this is the behaviour when using the official Tello app.
2-23 22:20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules