Please select Into the mobile phone version | Continue to access the computer ver.
Can't bind RC because of old drone firmware
257 5 3-1 08:45
Uploading and Loding Picture ...(0/1)
o(^-^)o
djiuser_tWEB2vy8YfX5
lvl.1
Flight distance : 39012 ft
Poland
Offline

Hi,

I've been trying to bind my RC to DJI Account for a few days now, and I can't figure out what am I doing wrong.

After launching my DJI MINI 2, there's a prompt on DJI Fly App screen saying that I can activate flyaway optin in my dji care.
When i try to hit "next" button in aircraft binding window, DJI Fly APP tells me that I have to update my drone.

But after hitting update dron button, it tells that my drone is up to date...

My mobile device is Samsung Galaxy S21 (also checked on Galaxy S10 - same problem).

Thanks in advance!
Cheers
0.png
1.png
3-1 08:45
Use props
newcreation
lvl.1
Flight distance : 993379 ft
Germany
Offline

Same here - iOS 14 and different iPhones - Support is not responding at all ...
3-11 12:55
Use props
RedEyz
lvl.1
Flight distance : 1355 ft
Canada
Offline

mine will not bind for the life of me. i've been on the phone with support (that was expensive) and still didn't resolve the issue.

it says my aircraft firmware needs to be updated when i try and bind, then when i go to update the firmware it says the firmware is up to date. i'm at a loss and very frustrated.

should i return it for a new unit and start again?
10-9 06:05
Use props
MiniManiac
First Officer
Flight distance : 1047503 ft
United Kingdom
Offline

Sucks that doesnt it, however I have a fix for it
10-9 09:07
Use props
MiniManiac
First Officer
Flight distance : 1047503 ft
United Kingdom
Offline

newcreation Posted at 3-11 12:55
Same here - iOS 14 and different iPhones - Support is not responding at all ...

see my post above
10-9 09:07
Use props
MiniManiac
First Officer
Flight distance : 1047503 ft
United Kingdom
Offline

RedEyz Posted at 10-9 06:05
mine will not bind for the life of me. i've been on the phone with support (that was expensive) and still didn't resolve the issue.

it says my aircraft firmware needs to be updated when i try and bind, then when i go to update the firmware it says the firmware is up to date. i'm at a loss and very frustrated.

see my post
10-9 09:08
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules