Please select Into the mobile phone version | Continue to access the computer ver.
V2 Googles wont link to air unit
3066 5 2021-3-5
Uploading and Loding Picture ...(0/1)
o(^-^)o
Bkay1
lvl.4
Flight distance : 3670112 ft
  • >>>
Canada
Offline

good day

i purchase the dji fpv drone combo and i cannotr get the googles  to bind to my airunits and cadex vista.  it works perfctly with the new drone but will not connect to air uniot and vista

is there a fix in place?
2021-3-5
Use props
Bkay1
lvl.4
Flight distance : 3670112 ft
  • >>>
Canada
Offline

i called support and the said they the v2 googles will not work with old airunits,  didnt seem right to so i used chat and agent t was able to help me link all three airunits and my cadex vista
2021-3-5
Use props
Buzzyone
Captain
Flight distance : 4399455 ft
  • >>>
United Kingdom
Offline

Make sure the firmware is updated on the air units and link the goggles first, don't forget you have to go into the goggles 'About' scroll all the way to the bottom and select 'DJI FPV System' restart the goggles and then follow the linking procedure.
2021-3-5
Use props
DJI Susan
Administrator

Offline

Hi there, we are sorry for the late reply. You can connect DJI FPV Goggles V2 to the air unit, please enter the Settings> About to switch DJI FPV mode to DJI Digital FPV System mode.
Happy to hear that you had got help from the chat support. Would you mind sending me a PM of your phone number that was used for calling our support? We will investigate the support issue for service improvement purposes.
2021-3-8
Use props
djiuser_y17NsYtrPnAq
lvl.1
United States
Offline

I see that you can change the vtx mw settings in dji digital fpv system but not in dji fpv system mode? So the actual fpv drone is set at a certain power for the vtx and you cannot change it, is that right? Or am I missing something? I have searched all over the web for the answer to this. Any help is appreciated. Thanks
2021-7-9
Use props
Blu_Kerry
lvl.2
Flight distance : 6516 ft
United States
Offline

Buzzyone Posted at 2021-3-5 11:38
Make sure the firmware is updated on the air units and link the goggles first, don't forget you have to go into the goggles 'About' scroll all the way to the bottom and select 'DJI FPV System' restart the goggles and then follow the linking procedure.

YOU ARE MY HERO!!!!  I have been sitting here trying to figure it out for a week.  I had no idea I needed to make that switch in the goggles.  Thank you!!!
5-16 05:16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules