Please select Into the mobile phone version | Continue to access the computer ver.
Aircraft Encoder Error problem
159 3 3-13 14:41
Uploading and Loding Picture ...(0/1)
o(^-^)o
Gordon G
lvl.3
Flight distance : 1502119 ft
Australia
Offline

Today I tried to photograph an area across the road for a 2nd Litchi test, but  shortly after Litchi has acquired the video I get the "Warning Aircraft Encoder Error"  message as seen in some other threads with various model drones. The video live stream is  still present.

My Mavic 2 Pro is only 4 months old and has been flying perfectly well,  now with about 30 hours flying time. I used Litchi for the first time a  couple of days ago for an initial test using DJIFlightPlanner then  Litchi to cover my front paddock, which worked perfectly well including  the return to home finish. The drone has never been crashed.

I then tried to connect with DJI GO4, but it wont connect, ie I never  see the GO FLY message. I can connect to video only though.  I'm using a  Samsung Android OS phone. FW updates have always been done, the most  recent only a few days ago. There were no error messages when I last  used it. I've reformatted the 128GB micro SD and internal storage, with no improvement.

If there was any proper fix without having to send my drone away, as I  need it for a job in a couple of days, that would be really helpful!
3-13 14:41
Use props
Gordon G
lvl.3
Flight distance : 1502119 ft
Australia
Offline

UPDATE
Today I re-installed ie "refresh" the latest firmware with DJI Assistant, and also did a screen calibration, as I figured "encoder error" could apply to any number of different encoders that may be in the Pro 2.
It is pouring rain today, so no outside testing, but I did start run Litchi, which did not display the error, and also  DJI Go 4, which appeared to connect, and then display "Go Fly".

Perhaps this has solved the problem, but I will test with flights outside when it stops raining tomorrow or Tuesday.
3-13 20:54
Use props
Gordon G
lvl.3
Flight distance : 1502119 ft
Australia
Offline

OK, well what I thought was a successful fix did not last long!

Last night I refreshed the controller's current firmware too.

After yesterday's initial apparent fix described above, today- enabling connection in GO4 and no error displayed in Litchi, I tried to connect and go for a flight in GO4 today. However, it would not connect, just gave me unhelpful instructions on how to do it, but again, it will connect to the 2Pro's video output.

Litchi again displayed the error, but at least I can fly it using Litchi- a few test circles close by, and it will follow a course from DJIFlightPlanner.

Does anyone know what "Aircraft Encoder Error" actually means? a tech from DJI perhaps?

Is it safe to fly, or does it refer to something vital that might cause loss of control or a crash? The suggested turn off then on again still makes no difference.

Stories of taking a month to get one fixed are a real concern, as I am currently quoting for a big time critical job in a couple of weeks, and need to know the best course of action.

TIA
3-14 21:06
Use props
Gordon G
lvl.3
Flight distance : 1502119 ft
Australia
Offline

Yesterday, after 2 weeks of failure, it has suddenly started working properly! Who knows why, but it doesn't seem to be related to any deletion and re-installs of DJIGO4 on my phone or tablet. It was just another random "lets see if this works today" attempt.
After it started working again a new FW update came through, but that was after it started working, so can't be related.
3-26 19:45
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules