Please select Into the mobile phone version | Continue to access the computer ver.
Stuttering 4K video,...problem of the Cam?...or me?
1681 20 2015-7-17
Uploading and Loding Picture ...(0/1)
o(^-^)o
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

Hello Guys i need your help,

I got a new project for a theatre and they asked me to film some high resolution videos in 4K used for mapping and splited on 6 screens. Well, the journey was a pleasure but after editing and post treatement i had a bad surprise while we made some tests on the screens.

STUTTERING VIDEOS...........

Until now i always observed some minor stuttering on my computer screen (ok,...the picture is not as good as i hope but i can live with it and i d'ont talk about the RAM, Graphic interface, GPU, CPU and so on (Macbook Pro retina 16GB Ram, Intel i7,  from 2013)).

BUT if you put it on a big screen the result is not usable!!! By the way, yes, we used professional hardware/software for the projection...

The question now is:

- Does the camera has some dropframes when you film in 4K?
- If it is a problem with the current compression of the native video file?
- Does the internal camera hardware slows down when too hot?
- Is my SD Card is good enough? ( San Disk extreme PLUS, class 10, 32GB )
- Filmed in 23.97 fps is the problem?

You will find an example here: http://youtu.be/sB9rq2tw3s0

Just feel free to give me some advice what is wrong with my footage :-)

In the beginning of this Year Tahoe_Ed shared a link for a download from a short video of the Lake Tahoe in 4K and it was fluid and beautifull, but i never had the same results with my I1. User problem?

Thanks for your help

Patou

PS: Sorry for my english








2015-7-17
Use props
EdgyMedia
Second Officer

Japan
Offline

The video came up as private. If you make it unlisted, we should be able to take a look.
2015-7-17
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

The way you'll know is to edit your video down to an easily playable size, like 1280x720 using an H.264 CODEC.

If the video plays smoothly then you have a performance issue with high res playback and nothing to do with the camera.

Also, you should have your high res videos in an easy to use production format like ProRes, not the highly compressed files that come out of the Inspire as they are almost impossible to play.

Finally, it's very important to know the difference between dropped frames and stuttered playback, which could be caused by too low a frame rate or too high a shutter speed.

So about a dozen things you need to consider to figure out what's happening here.

Let us know and we can be of more assistance.
2015-7-17
Use props
daniel.frederik
lvl.3
Flight distance : 10656 ft
New Zealand
Offline

You might try a faster card, I've just bought the next fastest card after yours, it's the SanDisk Extreme Pro and the Inspire One works well with it.

Good Luck!
2015-7-18
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

EdgyMedia Posted at 2015-7-18 09:05
The video came up as private. If you make it unlisted, we should be able to take a look.

Thanks EdgyMedia for the advice... you can take a look now :-)
2015-7-18
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

jimhare Posted at 2015-7-18 10:54
The way you'll know is to edit your video down to an easily playable size, like 1280x720 using an H. ...

Hello Jim,
thanks for your answer. I gonna try it this way and get back with some news later.

Patou
2015-7-18
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

daniel.frederik Posted at 2015-7-18 18:53
You might try a faster card, I've just bought the next fastest card after yours, it's the SanDisk Ex ...

Hey Daniel,

Now i have some doubts...i made a little research and it seems that the SD Card has a lower performance than expected:

Performance/speed: Up to 80MB/s read and up to 50MB/s write speed

But in the specs of the I1 it's written that you can have a Max Bitrate Of Video Storage about 60 Mbps

So i guess that it's worth to try with another SD Card.

Thank you

Patou
2015-7-18
Use props
mtnmaddman
Second Officer

United States
Offline

jimhare Posted at 2015-7-18 10:54
The way you'll know is to edit your video down to an easily playable size, like 1280x720 using an H. ...

Hey Jim which one are you in your avatar and who's doing the posting?    I like your little buddy maybe you should send him up stateside here for a little visit.
2015-7-18
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

mtnmaddman Posted at 2015-7-19 05:46
Hey Jim which one are you in your avatar and who's doing the posting?    I like your little bu ...

I'm the monkey.  The human just takes me around and is useful for ordering pizza, not much else!
2015-7-18
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

patou72 Posted at 2015-7-19 02:09
Hey Daniel,

Now i have some doubts...i made a little research and it seems that the SD Card has a ...

You answered your own question here:


Inspire  60Mb/s          60Megabits
SD: up to 50 MB/s     50MegaBYTES

1MB = 8Mb so the SD can do up to 400MegaBits per second but only needs to keep up with 60.  

You're all good.
2015-7-18
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

jimhare Posted at 2015-7-19 08:34
You answered your own question here:

oups... Should know it but didn't see it

2015-7-19
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

jimhare Posted at 2015-7-18 10:54
The way you'll know is to edit your video down to an easily playable size, like 1280x720 using an H. ...

Hello Jim,

Back again... like suggested i tried with the same videofile but compressed to FullHd.

Here the link: http://youtu.be/t8Ma1oGOiG4

I can't observe a better look (more fluid)... so i really don't know if it's the normal "rendering" of the cam.
Like i said before, on the computer screen it's quite ok, but if you play it on a bigger screen it's just unusable for me.

Like a lot of other users i just ordered the Renaat ND filters and hope it helps a little bit to keep a motion blur with lower shutter speed...
But anyway i got this impression that there are some Dropframes while recording or some lag in the treatment from the recorded informations by the Hardware. Sure i can be wrong but for now i can't find a solution...

Thanks for your help Jim.

Patou
2015-7-19
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

patou72 Posted at 2015-7-19 16:32
oups... Should know it but didn't see it

Heh, all good!   
2015-7-19
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

patou72 Posted at 2015-7-19 17:10
Hello Jim,

Back again... like suggested i tried with the same videofile but compressed to FullHd. ...

Hi Patou,

Yeah, there is something strange going on in there.

Can you tell me how you edited it?   Are you 100% sure you edited at the native frame rate of the file?   For example shot 23.97 and edited at 23.97?     It kind of looks like bad standards conversion, like you edited at 25FPS or something?

I would start there as it doesn't really look like dropped frames to me.

Any chance of uploading the original camera file?  I can have a look at it and tell you for sure.   At the moment there are still too many variables.

Cheers,

Jim
2015-7-19
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

jimhare Posted at 2015-7-19 17:37
Hi Patou,

Yeah, there is something strange going on in there.

Hey Jim,

Thanks a lot for the time you take...next time you come to Switzerland you are very welcome!

Here is the link of my Dropbox : https://www.dropbox.com/s/k4e94xkswrdkjwm/DJI_0222.mov?dl=0

So if you can take a look to the original file, that would be great...

Normally i use Final cut pro X and when i create a new project the settings are "automatic" depending and according to the first file imported in the project.

Thanks for your point of view of the problem

Patou
2015-7-19
Use props
trowland32304
lvl.2
United States
Offline

patou72 Posted at 2015-7-19 21:24
Hey Jim,

Thanks a lot for the time you take...next time you come to Switzerland you are very welc ...

There has been some discussion of this at the rcforums site with lots of what I consider speculation.  At first I had problems with what I will call stuttering and tried lots of things including fast cards with poor results.  I then went to the dji site and downloaded the dji transcoding tool, not to be confused with the dji cleaner for stills.  I have a big fast desktop with lots of power and it took a lot more time than I expected to run my raw video from the Inspire through the transcoding tool, but once it was finished the video played with no stuttering using several video players.
2015-7-19
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

trowland32304 Posted at 2015-7-20 07:35
There has been some discussion of this at the rcforums site with lots of what I consider speculati ...

Hello Trowland,

Never tested this option until now but I will give it a trial. Hope that works also for me:-)

Thank you

Patou
2015-7-20
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

trowland32304 Posted at 2015-7-20 07:35
There has been some discussion of this at the rcforums site with lots of what I consider speculati ...

That is correct.   Most of the time stuttering is due to playback limitations working with the high resolution and highly compressed original footage.  It's not really meant to be played right out of the camera.  It's source material to be turned into something else.
2015-7-21
Use props
jimhare
Captain
Flight distance : 239035 ft
Australia
Offline

patou72 Posted at 2015-7-19 21:24
Hey Jim,

Thanks a lot for the time you take...next time you come to Switzerland you are very welc ...

Awesome, would love to get back to Switzerland, it's been years!  

Beautiful landscape by the way, simply stunning!

I downloaded the clip and had a look on a fast machine.  

The footage is perfect so no problem with skipped frames or anything else.  

I do believe your machine may not be fast enough to deal with the native footage, which is why I suggested downsizing and putting it into a more manageable CODEC, such as ProRes.

But there is a second thing going on.   Because you are shooting at 24FPS (23.98) you need to restrict your movement a bit, particularly fast rotations.   

There are rules for shooting movement due to the relatively slow frame rate.   In other words, there is too much movement between frames and this can cause a stuttered appearance.

So your choices are to either reduce your movement or raise your frame rate.    Many people enjoy faster frame rates, up to 60FPS.   For me personally I don't like the look, which is more like hyper-real video than eye pleasingly cinematic.   But to each there own!

Maybe experiment with higher frame rates and see if you like it.

Jim
2015-7-21
Use props
patou72
Second Officer
Flight distance : 3316614 ft
Switzerland
Offline

Hello Jim,

Happy to know that the cam/video and the Hardware are ok. I think always that the computer (normally used for mapping on big screens with "Illumine or madmapper") for the projection is really fast enough and yes, we tried also with the ProRes codec but the thing you said about "too much mouvement between frames" seems to be the answer for me...i will try to slow down next time :-)
By the way i think that the fact of a projection on big screens may bring all the little imperfections to a higher visible level.

So thanks again for all the help and time you share with all of us and don't forget to send a message when you come to Montreux...

Patou

PS: just came back from filming...this time in 29.97 fps





2015-7-21
Use props
427racing
lvl.1

United States
Offline

trowland32304 Posted at 2015-7-20 07:35
There has been some discussion of this at the rcforums site with lots of what I consider speculati ...

That's great info as I have been struggling with 4K video since I got my P3P. If I drop down to 1080 it is nice and smooth. Go back to 4K and it the vid is nice and clear but it skips terrible. I downloaded Transcoding and ran it in it's default mode and that doesn't work. Can you tell me what the 2 settings you use?
Thanks,
Bob
2015-8-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules