Please select Into the mobile phone version | Continue to access the computer ver.
PSDK Command async send error 0 with skyport V2
740 2 2021-6-4
Uploading and Loding Picture ...(0/1)
  • >>>

Hello everybody,

I am currently struggling with an issue regarding the skyport V2 and the PSDK, namely that I am unable to connect my payload (a NanoPi Neo Core2:

The situation and setup are as follows:
  • Drone: M300 RTK /w firmware version V02.02.0301
  • Skyport V2  /w firmware version V01.03.0200
  • PSDK version V2.2.1-beta.0-build.315
  • Payload: NanoPi Neo Core2 running Ubuntu 16.04.2 LTS

The NanoPi is powered by one of the power outputs of the skyport, as well as it's UART port. When starting the PSDK application on the NanoPi I get the following error output:

3615180.298][module_core]-[Info]-[PsdkCore_Init:76]Payload SDK Version : V2.2.1-beta.0-build.315

[3615180.805][module_command]-[Error]-[PsdkCommand_SendASyncHandle:866]Command async send error 0

[3615180.806][module_command]-[Error]-[PsdkCommand_SendSync:338]sendSync callback timeout

[3615180.806][module_core]-[Error]-[PsdkCore_WaitAdapterConnection:241]Can't connect to Skyport V2 or X-Port. Probably because PSDK Adapter not power on, PSDK Adapter not finish init or UART connect error. Please check PSDK Adapter connection, UART configuration and UART connection

(this continues indefinetly)

I have tried the following solutions:
  • Update drone firmware
  • Update skyport firmware
  • Used different NanoPi UART ports and Baud settings
  • Used different skyports (both bound and unbound)
  • Used different NanoPi hardware
  • Used different M300
  • Measured UART output on oscilloscope I can see both Rx and Tx are pulled up and I can see the periodic attempt to connect from the NanoPi.
  • Used a different development app key

A previous version of this exact setup has worked immediately without issue, so I'm quite clueless as to why I am having such trouble getting this to work, even my colleague who created the previous setup has no idea.

If anyone has any suggestions as to why it will not connect I would love to hear it! As I've completely run out of ideas.

Thanks in advance to all!


Use props

Hong Kong

Do you work it out now? I have got trouble into same peoblem and am clueless as well.
Use props


Same issue today.  

Device: Nano Pi Neo, M200 v2 with SkyPort v2.

Solution: change baud rate to 115200

- Drone side
open DJI Assistant 2(Enterprise Series), on "Payload SDK" tab, change it.

- Nano pi side
execute `stty -F /dev/ttyS1 115200 cs8 -parenb -cstopb` to set uart1 baud rate;
comment `cfsetispeed` and `cfsetospeed` lines in `hal/uart_hal.c` if you use psdk sample code.

PS: I've tried to set baud rate to `B115200` in `hal/uart_hal.c`, but unfortunely it doesn't work.
Use props
You need to log in before you can reply Login | Register now

Credit Rules