Please select Into the mobile phone version | Continue to access the computer ver.
OSDK 4.1 M300 MOP Example Issues
80 0 6-14 06:46
Uploading and Loding Picture ...(0/1)
o(^-^)o
hackerman
lvl.2

United States
Offline

Hi all,

I am emailing DJI support and will post any solutions they offer here as well, but I thought I'd ask anyway if anyone has solved this particiular issue. I am trying to run the mop example from the OSDK sample code on a M300. I am using a linux virual machine as a "dummy" onboard computer, I have it connected to the OSDK adapter board UART port via a USB -> Serial cable and the OSDK USB port with a male-to-male USB cable. I am not using any of the advanced sensing stuff and am compiling with CMake. Baud rate is 115200.

The problem is, the "accept" part of creating a mop channel doesn't work for me. I get an error code of 5, which corresponds to MOP_NOTREADY. I have tried waiting for 30 seconds after activation to try to create the mop channel but I still get MOP_NOTREADY. If anyone has ever successfully created a mop channel on the M300 I would be interested to hear how you did it!

I have attached a picture of the output and here are some specs:

OSDK 4.1 for Linux
  
M300 RTK 02.04.0102
  
Remote Controller 02.04.0103 / 3.4.8.74
  
Battery 1 01.02.05.31
  
Battery 2 01.02.05.31



mop_output.jpg
6-14 06:46
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules