Please select Into the mobile phone version | Continue to access the computer ver.
Firmware version inconsistent​ between Mini2 & Air2 S
1680 1 9-26 08:43
Uploading and Loding Picture ...(0/1)
o(^-^)o
Karlewski
lvl.1

United States
Offline

[size=14.000000953674316px]Every time I try to switch from my Mini2 to my Air2 S or visa versa using the same controler I get this Message:
Firmware version inconsistent[size=14.000000953674316px]and need to do a one minute update. . . if I have wifi... Often I am quite remote and do not have wifi so if I want to fly both ships I need to take 2 controllers. It SUCKS since I'm on some huge cliff digging out the 2nd controller, putting away the 1st and then reinstalling the phone not to mention just carrying 2 of the same RC's? WTF. Switching ships used to work fine between my now deceased Air 2 and the mini 2 and it was GREAT, just hold the pair button for 4 seconds and off goes the second ship. With the Air 2 S I've tried everything. . . Any help or advice would be greatly appreciated! I've updated all the batteries and everything. . . Saw another thread like this that went unresolved since it would work with the owner's Smart controler so he gave up on this fix. . .  [size=14.000000953674316px]Thanks,

[size=14.000000953674316px]Karlewski
9-26 08:43
Use props
videoeditman
Captain
Flight distance : 4877923 ft
United States
Offline

Are you using an Apple device or Android? I haven't tried switching controllers but 1.4.8 Beta (1185) fixed lock-up issues, may help here? Also post a copy of this on the original request if you can as that might flag DJI that multiple people are having the problem.
9-27 07:05
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules