Please select Into the mobile phone version | Continue to access the computer ver.
WARNING
2821 4 2021-10-20
Uploading and Loding Picture ...(0/1)
o(^-^)o
dji_MODDER
Captain
Flight distance : 11588 ft
Netherlands
Offline

I like to forward this because it's important for some people.
If you don't want to modify your drone forget this and keep updating you are used to do for the best of your DJI product.



Warning,
DJI seems to have released some firmware versions which have a higher antirollback value than others.
Air2:
01.01.0610 (firmware good for hacking) - Antirollback 2
01.01.665 (firmware cannot be hacked, neither downgraded or upgraded) - Antirollback 3
01.01.670 (firmware cannot be hacked, but it can be flashed to 610) - Antirollback 2
Air2s:
02.04.2040 (firmware good for hacking) - Antirollback 1
02.04.2075 (firmware cannot be hacked, neither downgraded or upgraded) - Antirollback 2
02.04.2080 (firmware cannot be hacked, but it can be flashed to 610) - Antirollback 1
FPV:
01.02.0000 (firmware good for hacking) - Antirollback 1
01.02.0015 (firmware cannot be hacked, neither downgraded or upgraded) - Antirollback 2
01.02.0020 (firmware cannot be hacked, but it can be flashed to 610) - Antirollback 1
As far as i saw this firmware versions are not public available but some people have them (not sure how, my current assumption is that they were flashed after service, but this is only a guess).
So please warn everyone now to install this firmware version, best would be not to update at all.
Also this again shows that we should change our way of speaking about firmware versions, the version numbering is completely unimportant, the only important fact is the antirollback value.
How does this value work?
The drone has the antirollback value of the current firmware, this value can NEVER be decreased, it can only stay the same or increase! So when you want to flash a firmware the drone cannot flash it if the antirolback value of the firmware you want to flash is lower than the current value on the drone. the firmware you want to flash must have the same or a higher value. If you flash a firmware with a higher value the drone will automatically set itself to the higher value, from now on only versions with the same higher value can be flashed. Due to this the air2 cannot flash firmware 670 on top of firmware 665, because 670 firmware has a LOWER value than 665.
i hope i was able to explain this now properly and i hope people will understand the importance of this value now.
All drones with the firmwares 665, 2075 and 0015 cannot be hacked anymore and can not be flashed to a hackable firmware. IF or WHEN they will be able to be hacked again is unsure.
Please spead this information in every channel and community you are part of! Warn everybody to NOT UPDATE!
thank you for your attention!

2021-10-20
Use props
DAFlys
Captain
Flight distance : 52404905 ft
United Kingdom
Offline

Thanks for sharing.
2021-10-20
Use props
DowntownRDB
Captain
Flight distance : 525 ft
  • >>>
United States
Offline

Interesting and thanks for sharing.  
2021-10-21
Use props
jozef88
lvl.1
Spain
Offline

does anyone know how to downgrade from 01.01.920 anit roll back 6
10-6 15:11
Use props
djiuser_uAyu2NFbT5oD
New

Ukraine
Offline

jozef88 Posted at 10-6 15:11
does anyone know how to downgrade from 01.01.920 anit roll back 6

Hi. Did you downgraded your firmware? I have the same problem
11-27 05:12
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules