Please select Into the mobile phone version | Continue to access the computer ver.
All new Android products are blocking DJI being installed
12Next >
4329 67 3-15 04:53
Uploading and Loding Picture ...(0/1)
o(^-^)o
palouta
lvl.2
United States
Offline

So you know DJI will no longer be supported by Android products! everything is now a brick unless you use older Android product and systems. DJI will only work with Apple!
3-15 04:53
Use props
LV_Forestry
First Officer
Flight distance : 4726654 ft
Latvia
Offline

Can you give us the source of this information?
3-15 07:48
Use props
DowntownRDB
Captain
Flight distance : 525 ft
  • >>>
United States
Offline

Would be interesting to see the source of this information.
3-15 12:16
Use props
palouta
lvl.2
United States
Offline

DowntownRDB Posted at 3-15 12:16
Would be interesting to see the source of this information.

I am the source. Go buy an Android product produced in the last 4 months and you will not be able to install the fly app. No fly app install means you can't fly the drone!

3-15 12:58
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft

Offline

Hi there. Thank you for reaching out and we're sorry for the trouble that this has caused. Can you please confirm what Android mobile device are you using when you experience the said issue? Please note that you can only download the DJI Fly app straight to our website. You may refer to the link below. Thank you for your valued support.

https://www.dji.com/downloads/djiapp/dji-fly
3-15 17:21
Use props
RGMGFitness
Captain
Flight distance : 233757 ft
  • >>>
United States
Offline

I'm NOT an Android user but perhaps this is what the person is referring to?

Subject:  Announcement on Updating Channels for DJI apps (for Android Users)

https://forum.dji.com/forum.php? ... D612%26typeid%3D612
3-15 18:29
Use props
DAFlys
Captain
Flight distance : 52729095 ft
United Kingdom
Offline

Just buy a device from the supported list and you'll be fine.
3-15 23:50
Use props
palouta
lvl.2
United States
Offline

DJI Paladin Posted at 3-15 17:21
Hi there. Thank you for reaching out and we're sorry for the trouble that this has caused. Can you please confirm what Android mobile device are you using when you experience the said issue? Please note that you can only download the DJI Fly app straight to our website. You may refer to the link below. Thank you for your valued support.

https://www.dji.com/downloads/djiapp/dji-fly

Galaxy A13. It has been on the market for 4 months. I had to buy a new phone as my old one broke. Stop telling everyone that you can download the app directly from the DJI website. That doesn't work either. The newer android phones will not let you install this app!

Hence why I keep saying this!
3-16 04:27
Use props
palouta
lvl.2
United States
Offline

DAFlys Posted at 3-15 23:50
Just buy a device from the supported list and you'll be fine.

thanks for the sage wisdom douche

how about you give me the money or better yet why dont you buy this brick off me so i can go to company that can keep up with it software compliance and updates.
3-16 04:37
Use props
palouta
lvl.2
United States
Offline

RGMGFitness Posted at 3-15 18:29
I'm NOT an Android user but perhaps this is what the person is referring to?

Subject:  Announcement on Updating Channels for DJI apps (for Android Users)

That is just a link to the latest app version update. there was a problem back in the fall that after an update the old DJJ fly version would not work so they did an update.

Now you can't even add the DJI Fly app to most of the new Android products. no matter the source of the download.

They have been kicked off Google Play and now it would seem they are black listed from Android systems even if you download directly and change you security setting you still can't load the DJI Fly app.

Why do you think they are going back to a dedicated control system!! Apple users are next in line for the A$$ job DJI is about to hand out.

you would think that they might reach out to me to make is right, but my guess is these posts will not be up for long.
3-16 04:53
Use props
DowntownRDB
Captain
Flight distance : 525 ft
  • >>>
United States
Offline

palouta Posted at 3-15 12:58
I am the source. Go buy an Android product produced in the last 4 months and you will not be able to install the fly app. No fly app install means you can't fly the drone!

I just recently purchased the new Samsung Galaxy S22 Ultra and the DJI Fly App works just fine on it and I have not experienced any issues.  
3-16 10:34
Use props
DAFlys
Captain
Flight distance : 52729095 ft
United Kingdom
Offline

palouta Posted at 3-16 04:37
thanks for the sage wisdom douche

how about you give me the money or better yet why dont you buy this brick off me so i can go to company that can keep up with it software compliance and updates.

I mostly stick with the iPhones,  get the top model each year and everything works great,  although I did just pick up the Smart controller before Christmas and thats been quite nice too.
3-17 00:19
Use props
ATKAS
Second Officer
Flight distance : 112303 ft
Australia
Offline

OP is right, has been an issue for a few months. Something to do with the Play Store not supporting DJI Fly currently due to tensions between US and China. Don't quote me, don't start flaming, may not be 'exactly' that, just Google it and you'll find info, that's just the general idea. I don't know the exact details, but that's the path a quick Google search lead me down when I too had the same problem. I too have a new Samsung S22 Ultra, but using the Smart Switch program to upgrade previous Android phone it automatically installed because it was previously installed. For another new Android tablet I have though I had to download the APK from DJI. Ironic considering our RC Pros are Android based...but preloaded I guess.
Easy to test, as I just did again. Open Play Store and search for the app. Not visible. May be regionally affected though, but Australia and US don't seem to be able to see it.
Also, click the "Download for Android" link on DJI's own Fly app page and rather than direct to the Play Store, it commences downloading the APK.
3-17 02:03
Use props
palouta
lvl.2
United States
Offline

ATKAS Posted at 3-17 02:03
OP is right, has been an issue for a few months. Something to do with the Play Store not supporting DJI Fly currently due to tensions between US and China. Don't quote me, don't start flaming, may not be 'exactly' that, just Google it and you'll find info, that's just the general idea. I don't know the exact details, but that's the path a quick Google search lead me down when I too had the same problem. I too have a new Samsung S22 Ultra, but using the Smart Switch program to upgrade previous Android phone it automatically installed because it was previously installed. For another new Android tablet I have though I had to download the APK from DJI. Ironic considering our RC Pros are Android based...but preloaded I guess.
Easy to test, as I just did again. Open Play Store and search for the app. Not visible. May be regionally affected though, but Australia and US don't seem to be able to see it.
Also, click the "Download for Android" link on DJI's own Fly app page and rather than direct to the Play Store, it commences downloading the APK.

I to originally did the smart switch when I got the new phone but the DJI Fly app was not brought over to the new phone. I think you were able to because the ultra is now the only newer phone that you can download the APK app directly  
3-17 05:18
Use props
palouta
lvl.2
United States
Offline

DAFlys Posted at 3-17 00:19
I mostly stick with the iPhones,  get the top model each year and everything works great,  although I did just pick up the Smart controller before Christmas and thats been quite nice too.

Still a douche I see.
3-17 05:20
Use props
palouta
lvl.2
United States
Offline

DowntownRDB Posted at 3-16 10:34
I just recently purchased the new Samsung Galaxy S22 Ultra and the DJI Fly App works just fine on it and I have not experienced any issues.

the ultra for some reason is the only newer one for some reason. But again you would have had to download it directly from the DJI website.

You might want to uninstall the FLY app do a software update and then see if you might be able to download and reinstall the app.

You might not be able to. I think this might be tied to the latest security update that came out at the end of FEB
3-17 05:37
Use props
DAFlys
Captain
Flight distance : 52729095 ft
United Kingdom
Offline

palouta Posted at 3-17 05:20
Still a douche I see.

thanks for the support.   
3-17 23:54
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft

Offline

palouta Posted at 3-16 04:27
Galaxy A13. It has been on the market for 4 months. I had to buy a new phone as my old one broke. Stop telling everyone that you can download the app directly from the DJI website. That doesn't work either. The newer android phones will not let you install this app!

Hence why I keep saying this!

Thank you for your response and we're deeply sorry if you are having trouble with this. However, it shows that the mobile device that you had mentioned is not compatible with the said unit and the DJI Fly app. Therefore, we cannot guarantee that it will work properly for the unit and the application itself. We strongly recommend using a compatible device to avoid any issues in the future. Thank you for your understanding and support.
3-18 04:05
Use props
palouta
lvl.2
United States
Offline

DJI Paladin Posted at 3-18 04:05
Thank you for your response and we're deeply sorry if you are having trouble with this. However, it shows that the mobile device that you had mentioned is not compatible with the said unit and the DJI Fly app. Therefore, we cannot guarantee that it will work properly for the unit and the application itself. We strongly recommend using a compatible device to avoid any issues in the future. Thank you for your understanding and support.

ummm, I am not understanding and I will not support...so don't thank me.

I am done with your brand. As anyone with a brain can now see, you don't care about post sale support. I have a drone that is just a brick now.

Why doesn't DJI provide the truth to new buyers...will only work with the Samsung Ultra...for now.
3-18 04:14
Use props
djiuser_L3AiqgixMKXT
lvl.1
Flight distance : 3065420 ft
United States
Offline

palouta Posted at 3-15 12:58
I am the source. Go buy an Android product produced in the last 4 months and you will not be able to install the fly app. No fly app install means you can't fly the drone!

That happens with a lot of android devices you just have to go to their website and download the APK file it doesn't show up in my Play Store either and I just downloaded it by  side loading it and now it's downloaded on my phone as easy as that
3-18 09:11
Use props
palouta
lvl.2
United States
Offline

djiuser_L3AiqgixMKXT Posted at 3-18 09:11
That happens with a lot of android devices you just have to go to their website and download the APK file it doesn't show up in my Play Store either and I just downloaded it by  side loading it and now it's downloaded on my phone as easy as that

cant side load it either. ready the posts. that's the issue
3-18 09:14
Use props
djiuser_L3AiqgixMKXT
lvl.1
Flight distance : 3065420 ft
United States
Offline

Quit Complaining and just get a damn phone that's compatible on the list your phone  is not on the list you obviously  didn't read there compatible phone list correctly so you don't have a brick you have a slow brain
3-18 09:17
Use props
palouta
lvl.2
United States
Offline

djiuser_L3AiqgixMKXT Posted at 3-18 09:17
Complaining and just give damn phone that's compatible on the list August 8th is not on the list is not going to work long as you didn't read that correctly so you don't have a brick you have a slow brain

eat a d1ck. I already own the drones, who would go out and do research to see if a particular phone will be be compatible with DJI software they already own?? the A13 is not some random one off phone and software.

DJI is abandoning their Android uses, apple will be next fuk face!
3-18 09:26
Use props
kleitongie
lvl.1

Brazil
Offline

O meu poço M3 pro deixou eu instalar o app mais abro o aplicativo conecto o drone aí ele pedi pra fazer atualização que trava a 40% e o calibrar o bússola
tbm trava
3-18 10:28
Use props
palouta
lvl.2
United States
Offline

kleitongie Posted at 3-18 10:28
O meu poço M3 pro deixou eu instalar o app mais abro o aplicativo conecto o drone aí ele pedi pra fazer atualização que trava a 40% e o calibrar o bússola
tbm trava

fuk me, no idea what you are going on about.
3-18 10:45
Use props
DowntownRDB
Captain
Flight distance : 525 ft
  • >>>
United States
Offline

palouta Posted at 3-17 05:37
the ultra for some reason is the only newer one for some reason. But again you would have had to download it directly from the DJI website.

You might want to uninstall the FLY app do a software update and then see if you might be able to download and reinstall the app.

You got me curious so I gave it a try.  I uninstalled the App and deleted all associate folders.  Restarted the Ultra and then downloaded App from DJI and installed.  Fortunately, it still works perfectly.  So at lease we know it doesn't affect all new phones.

I'm on the latest update to Android 12 and installed FJI Fly App V1.5.10.  
3-18 10:49
Use props
palouta
lvl.2
United States
Offline

DowntownRDB Posted at 3-18 10:49
You got me curious so I gave it a try.  I uninstalled the App and deleted all associate folders.  Restarted the Ultra and then downloaded App from DJI and installed.  Fortunately, it still works perfectly.  So at lease we know it doesn't affect all new phones.

I'm on the latest update to Android 12 and installed FJI Fly App V1.5.10.

and you have an s21 or s22?
3-18 10:56
Use props
palouta
lvl.2
United States
Offline

for those that don't believe here is the latest look at the google play store for the PRo4 app. Apple is next bruh...
3-18 11:07
Use props
DowntownRDB
Captain
Flight distance : 525 ft
  • >>>
United States
Offline

palouta Posted at 3-18 10:56
and you have an s21 or s22?

As stated in Post 11,  I have the Samsung Galaxy S22 Ultra.  It has the Snapdragon processor and not the Exynos processor if that should be the difference.  
3-19 04:37
Use props
palouta
lvl.2
United States
Offline

DowntownRDB Posted at 3-19 04:37
As stated in Post 11,  I have the Samsung Galaxy S22 Ultra.  It has the Snapdragon processor and not the Exynos processor if that should be the difference.

interesting as the s22 is not listed as compatible. the s21 is listed and that came out in jan of 2021 so looks like nothing in the past year is officially compatible   
3-21 11:46
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft

Offline

palouta Posted at 3-18 04:14
ummm, I am not understanding and I will not support...so don't thank me.

I am done with your brand. As anyone with a brain can now see, you don't care about post sale support. I have a drone that is just a brick now.

We totally understand your frustration with this one, palouta. Try to use a compatible device to see if the issue persists. Thank you and have a good one.
3-22 20:36
Use props
palouta
lvl.2
United States
Offline

DJI Paladin Posted at 3-22 20:36
We totally understand your frustration with this one, palouta. Try to use a compatible device to see if the issue persists. Thank you and have a good one.

the issue is that your are not make the newer Samsung phones compatible by keeping up with the software. there is no issue with the dones, the issue is i can't install you fly app on my new phone. of course it will install on compatible phones that are over a year old! what are you going to do to help the people who now own your drones but are unable to fly them because you can't or will not keep up with Android systems? Why do you still state that you are compatible with Android? you are only compatible with Apple now or at least for now.   
3-28 05:33
Use props
DubSound
First Officer
Flight distance : 95459 ft
  • >>>
United Kingdom
Offline

Bit of a dumb statement you got there
3-29 01:02
Use props
DubSound
First Officer
Flight distance : 95459 ft
  • >>>
United Kingdom
Offline

palouta Posted at 3-16 04:53
That is just a link to the latest app version update. there was a problem back in the fall that after an update the old DJJ fly version would not work so they did an update.

Now you can't even add the DJI Fly app to most of the new Android products. no matter the source of the download.

You are literally pulling some much BS out of your ass it's unreal. Take your tin-foil hat off and get your head out of the sand for 10 mins.

Android is NOT blacklisting DJI apps you utter moron
3-29 01:04
Use props
Andesclimb
lvl.1
Flight distance : 370007 ft
Chile
Offline

palouta Posted at 3-15 12:58
I am the source. Go buy an Android product produced in the last 4 months and you will not be able to install the fly app. No fly app install means you can't fly the drone!

Hi, I own a new Xiaomi Poco phone, buyed it a few weeks ago and it works well...
3-29 14:44
Use props
Airwolf076
lvl.3
Flight distance : 1354970 ft
United States
Offline

To the OP, download an app on the Play store called "CPU-Z", open that app and go into the "System" tab, in the "Kernel architecture" field, what does it say? If it does not say something like "aarch64" or something else that incorporates the number "64" then it indicates that your phone is using a 32-bit version of Android...... some modern budget phones still use 32-bit for whatever reason, and the Fly app will ONLY work on a 64-bit version of Android.

For the record, I am in complete agreement with you that DJI needs to do better here....... There's no reason the app should not work on ANY device that is powerful enough to run it in my opinion, and there definitely seems to be a strong bias towards IOS..... I think clearly DJI are some Apple fanboys, It's proudly displayed on my Mavic Air 2 box "Made for Iphone".
I'll also go on to ask WHY are some Android phone makers STILL putting a 32-bit Android on their budget devices? What kind of crap is that? I mean it's 2022 NOT 2002!

4-4 13:30
Use props
imazman
lvl.1

United States
Offline

My advice...keep your Samsung phone and buy a DJI smart controller....#ProblemSolved.  I freestyle with custom 210" FPVs with DJI air unit, DJI Google V2, and DJI FPV Controller.  I have not bought a DJI drone yet because of the need for a phone to fly...albeit I am now looking to buy since they have smart controllers.  I don't care how old and slow my phone gets...I know I will always be able to fly with a dedicated DJI controller.  Now if only they would have the upcoming Mini 3 work with their FPV V2 goggles and remote...sweeeeet.
4-6 18:52
Use props
palouta
lvl.2
United States
Offline

DubSound Posted at 3-29 01:04
You are literally pulling some much BS out of your ass it's unreal. Take your tin-foil hat off and get your head out of the sand for 10 mins.

Android is NOT blacklisting DJI apps you utter moron

F|_|CK FACE

Yeah you. You might want to use one of those 6 frig'in eyes

https://forum.dji.com/thread-238586-1-1.html


4-7 04:48
Use props
palouta
lvl.2
United States
Offline

Airwolf076 Posted at 4-4 13:30
To the OP, download an app on the Play store called "CPU-Z", open that app and go into the "System" tab, in the "Kernel architecture" field, what does it say? If it does not say something like "aarch64" or something else that incorporates the number "64" then it indicates that your phone is using a 32-bit version of Android...... some modern budget phones still use 32-bit for whatever reason, and the Fly app will ONLY work on a 64-bit version of Android.

For the record, I am in complete agreement with you that DJI needs to do better here....... There's no reason the app should not work on ANY device that is powerful enough to run it in my opinion, and there definitely seems to be a strong bias towards IOS..... I think clearly DJI are some Apple fanboys, It's proudly displayed on my Mavic Air 2 box "Made for Iphone".

Finally someone that can at least bring this to what is most likely going on. I thank you for your time and input.

So did that and the Kernel is 4.14.186. Regarding what you have said it would seem this is a 32-bit and not a 64-bit.

but if that is the case, I would think DJI would have and older version that I could self install. I have tried every FLY App version there has been (there is a site with about a dozen or more) none of them will install and my last phone was a budget Samsung that was almost 3 years old. The only thing then was I installed it through Play store as it was still available there then.
  
4-7 04:56
Use props
DubSound
First Officer
Flight distance : 95459 ft
  • >>>
United Kingdom
Offline

palouta Posted at 4-7 04:48
F|_|CK FACE

Yeah you. You might want to use one of those 6 frig'in eyes

Bit of a cretinous reply. Get gone.
4-7 05:02
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules