Please select Into the mobile phone version | Continue to access the computer ver.
Camera not working Vision 2 +
4360 16 2014-11-30
Uploading and Loding Picture ...(0/1)
o(^-^)o
koala27
lvl.1
Brazil
Offline

Dear all,

My camera stopped working, i still have commands, take picture, start recording, ajust camera trimble, but no video transmission, only a blue screen.
Any one had this problem? Just upgraded everything and still does not work.
When i open the sd card at my computer, no pics or video were recorded to the card.
2014-11-30
Use props
kenargo
First Officer
  • >>>
United States
Offline

There is a small button on the bottom of the camera mount; if you press that you can turn on video recording.  If recording works using the button then it may be your WIFI connection (though I would expect an issue with the connection itself would be reported when you try to open the Vision app.
2014-11-30
Use props
kenargo
First Officer
  • >>>
United States
Offline

I should have mentioned; press and it take a still image; hold for +2 seconds and it begins recording, press again to stop recording.
2014-11-30
Use props
koala27
lvl.1
Brazil
Offline

kenargo Posted at 2014-12-1 13:11
I should have mentioned; press and it take a still image; hold for +2 seconds and it begins recordin ...

Already did it still not working. Will try to upgrade the camera firmware.
2014-11-30
Use props
DJI-Sophie
lvl.3

China
Offline

Make sure all the firmware are the latest version; hold the reset button on the range extender for three seconds to reset it, connect to the wifi again, rebinding the camera, and test the video preview again.
2014-11-30
Use props
kenargo
First Officer
  • >>>
United States
Offline

koala27 Posted at 2014-12-1 14:12
Already did it still not working. Will try to upgrade the camera firmware.

If the button on the camera mount did not work then that rules out the Wi-Fi module and points to a problem with the camera.  
2014-11-30
Use props
roodee127
New

United States
Offline

I install a new camera on my phantom 2 vision plus.iEverything  works fine except the camera is always freezing as i see it on my monitor.
2014-12-1
Use props
umpa
Second Officer

United Kingdom
Offline

This happened to me on my second flight.  I switched everything off, quit all the apps on my phone (using iPhone at the time) turned off wifi in phone. Turn controller on, extender, then Phantom, then wifi on phone, then connect phone to extender, start app - all good. Many systems i'm surprised it works half the time - lol
2014-12-1
Use props
tomvon
lvl.2
Flight distance : 201673 ft
United States
Offline

Ladies and Gentlemen,

After emails from DJI, suppliers here in the U.S. and from reading other boards, the conclusion is that these failures are due to a faulty WiFi module. Evidently, the modules have been overheating which results in a complete loss of video feed although telemetry and other functions still work fine. Despite DJI not taking on this issue professionally by taking responsibility for the design issue leading to this problem, there is a solution. A new module can be purchased from U.S. Hobby or UAV Direct for $189. There are several sites....http://www.phantompilots.com/viewtopic.php?f=27&t=20006.... where you can find a step-by-step procedure for replacement.

I have had great success with the DJI Phantom 2 Vision+, but this issue and the lack of professional responsibility on the part of DJI, has really made me start second guessing any future business with the organization.

Good luck with your repairs.
2015-1-4
Use props
tkocaman
lvl.1

United States
Offline

I have a similar problem. I have a vision 2 plus.

The LED light on the camera comes on most of the time. And I can connect to iPhone and take photos with it. But as soon as I hit record on the iphone, connection is lost and the LED light goes away. I cannot even take pictures now. So as if something shorts the system as soon as I try to start video.

Same thing happens when I select to view the photos on the SD Card.

However, when I press and hold the button on the camera to start video, it will start taking the video. But the 2nd or 3rd time I try that, I get the same issue. LED Light goes away, camera does not work. Although it will still operate the gimball.

I replaced the ribbon cable, and the 3 cables from the camera. But no luck.

Any suggestions?
2015-4-27
Use props
jfehn
lvl.1

United States
Offline

I installed a new board on the camera, binded it to the system and entered the new Mac address, I am able to move the cam up and down, but no picture. Is the board bad,or I did not complete the installation of the camera to the Phantom. I also have a green light on the cam until i attempt to take a picture then it flashes green. The error I get is that I am not connected to the Phantom. This is viewing from my IPhone.
Any thoughts?
2015-6-29
Use props
jfehn
lvl.1

United States
Offline

How do you find and install the camera firmware, is it different from the Phantom firmware v.38, or is it inside the v.38?  
2015-7-1
Use props
quanthonytrang
First Officer
Flight distance : 419980 ft
  • >>>
Australia
Offline

Drop you FPV res to 360*240@15fps. This is the lowest bandwidth.
Other considerations:
Overheated WIFI module,
Check the antenna on the wifi module and make sure its MMCX end is plugged in. You will hear a click.
Maybe Try android device.

2015-7-1
Use props
Henry_666
lvl.1

China
Offline

But where do you get the new firmware? And when I opened the card, there's nothing in it.
4-4 05:05
Use props
Henry_666
lvl.1

China
Offline

But where do you get the new firmware? And when I opened the card, there's nothing in it.
4-4 05:05
Use props
Henry_666
lvl.1

China
Offline

Henry_666 Posted at 4-4 05:05
But where do you get the new firmware? And when I opened the card, there's nothing in it.

Sorry, I accidentally clicked the button twice.
4-4 05:07
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

Henry_666 Posted at 4-4 05:05
But where do you get the new firmware? And when I opened the card, there's nothing in it.

The chance that you need a FW upgrade is almost zero because there hasn't been an update in about six years.  
4-6 04:42
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules