Please select Into the mobile phone version | Continue to access the computer ver.
DJI GO App Not Working
1206 1 2022-7-16
Uploading and Loding Picture ...(0/1)
o(^-^)o
SiteWork Media
lvl.1

United States
Offline

Hello, I just tried to use the DJI GO App after months of not flying. It kept crashing like other people on these threads are describing. I am running the Inspire 1 pro black edition. I am using a Samsung Galaxy S10 with software versions: One UI Version 4.1 and Android 12. I tried both the GO app before P4 and the dji go app 4 for after p4. Both kept crashing the same. I uninstalled both and with both apps I went onto dji's website and downloaded the apk file. After both attempts, I convinced that dji does not play well with Samsung. I run a business and use my drone for it. I cannot use my drone now. Can someone help me out? Or should I just sell it and upgrade to a newer model?
2022-7-16
Use props
DJI Paladin
Administrator
Flight distance : 318 ft

Offline

Hi there. Thank you for reaching out and we're sorry for the trouble. It seems that the mobile device that you are using is not listed on our recommended mobile device for the DJI GO App and this might be the main cause of the issue. We strongly suggest using a compatible device to avoid issues. Kindly please refer to the link below for you to have the list of compatible devices for the said app. Thank you for your understanding and support.

https://www.dji.com/downloads/djiapp/dji-go-3
2022-7-16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules