Please select Into the mobile phone version | Continue to access the computer ver.
(Hyperlapse) - Color Shifting between raw photos - NOT FIXED
1258 38 2022-8-20
Uploading and Loding Picture ...(0/1)
o(^-^)o
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
Offline


Update Dec 6th 2022
Sadly the hyperlapse issue is NOT fixed and photo from photo each one has a major tint shift still present, honestly 10x worse than before. This is such a disappointment, especially returning from new Zealand where I shot a lot of hyperlapse and most of the raw dng photos are absolutely useless and trash now because of the color inconsistency from one to the next. I'm honestly SO ANGRY at this being claimed as fixed and its far from fixed.




Extremely disappointed to see the lack of quality control over this camera. This problem should NOT happen in a professionally marketed "cine" camera. It would be great to hear from DJI if there's a fix inbound or the issue here and if there's a workaround.
Mavic 3 Cine
ALL MANUAL SETTINGS
Aperture: F10.0Shutter: 1/20
ISO 100
WB: Manual 5,600
Files are written to the SSD.

In this first example, viewing the raw dng file you can see the histogram change dramatically, this is an internal issue



In this next example after an edited batch of photos you can really see the horrible effect that's happening.


Even in another hyperlapse from earlier in the day the camera is having the same issue.



I find this completely unacceptable especially seeing numerous other consumers and professionals like me using the mavic 3 and having the same issue with no formal response from DJI. You reach out to support and they ask oh was it in auto settings? No... IT WAS NOT. We need a fix whether its sending in the drone to get a new updated hardware for the camera, or a firmware update that fixes this issue that plagues both photo and video and hyperlapse.



1.jpg

example 1

example 1
2022-8-20
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Just checked the other Timelapse I took hours before this one... sadly suffering the same issue...
Is ANYONE else having issues with their hyperlapse photo? If you don't edit the raws its very hard to see it happening.

I did a test at home to see and watch the hyper-lapse even stationary everytime it takes a photo I can see on the RC Pro some weird flicker / purple pop on after each. Hoping this is only hardware and once I send it off tomorrow its a quick fix.
2022-8-21
Use props
DarthSLR
Captain
Flight distance : 1679665 ft
  • >>>
United States
Offline

Did you shoot in auto, or full manual?
2022-8-22
Use props
CloudVisual
First Officer
Flight distance : 25957795 ft
  • >>>
United Kingdom
Offline

To me that looks like your white balance bouncing around. It's a very orange/blue dark/light scene so if you're shooting on AWB then it'll be hunting round for a 'good' white balance.

Also, the flickering.... Are you shooting in manual?
2022-8-23
Use props
HarleyFlyer
lvl.4
Flight distance : 1356178 ft
United Kingdom
Offline

I have just experienced the same thing on a Mini 3 Pro Hyperlapse - I am 90% sure it's caused by leaving the white balance on Auto. I saw on a YT video earlier this week, that the best thing is to use the auto white balance to check the colour temperature - then immediately turn it to manual and use that temperature for the entire video / hyperlapse. I will be doing this from now on.
2022-8-23
Use props
CloudVisual
First Officer
Flight distance : 25957795 ft
  • >>>
United Kingdom
Offline

HarleyFlyer Posted at 8-23 05:14
I have just experienced the same thing on a Mini 3 Pro Hyperlapse - I am 90% sure it's caused by leaving the white balance on Auto. I saw on a YT video earlier this week, that the best thing is to use the auto white balance to check the colour temperature - then immediately turn it to manual and use that temperature for the entire video / hyperlapse. I will be doing this from now on.

As someone who professed to me in another thread that "i am a professional photographer - master level" I'm very surprised you apparently can't work out what white balance to use or how to correct it in post...

I'm not trying to be rude here, I just felt in the other thread that I was supposed to take heed on your words based on this title, when I've just read you're unable to set your own WB.
2022-8-23
Use props
Mzp
First Officer
  • >>>
United States
Offline

I have a suggestion for flickering issue. The flickering seems to happen when aperture is allowed to wander. If you lock your aperture , shutter speed and just let ISO to wander or if you also lock ISO that imho would help with flickering a lot.
2022-8-23
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

DarthSLR Posted at 8-22 05:54
Did you shoot in auto, or full manual?

I shoot everything always in full manual. As this was also shot full manual.
2022-8-23
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Mzp Posted at 8-23 05:56
I have a suggestion for flickering issue. The flickering seems to happen when aperture is allowed to wander. If you lock your aperture , shutter speed and just let ISO to wander or if you also lock ISO that imho would help with flickering a lot.

If every exposure is locked + WB is locked, why would there be any flickering outdoors without artificial light? It seems more like a hardware issue right?
2022-8-23
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

HarleyFlyer Posted at 8-23 05:14
I have just experienced the same thing on a Mini 3 Pro Hyperlapse - I am 90% sure it's caused by leaving the white balance on Auto. I saw on a YT video earlier this week, that the best thing is to use the auto white balance to check the colour temperature - then immediately turn it to manual and use that temperature for the entire video / hyperlapse. I will be doing this from now on.

Interesting suggestion. I always shoot manual everything (was set to daylight 5,600) but if this is a little "hack" for an internal issue I'll give it a go.

I've noticed in the past video used to have very strange tints of green or purple throughout but completely random from shot to shot.
2022-8-23
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

JJungPhoto Posted at 8-23 07:57
Interesting suggestion. I always shoot manual everything (was set to daylight 5,600) but if this is a little "hack" for an internal issue I'll give it a go.

I've noticed in the past video used to have very strange tints of green or purple throughout but completely random from shot to shot.



Another Hyperlapse was taken the same day. Look at the clouds again for that "flicker" happening.

Again, everything is set to manual here; (Aperture, shutter (was at 1" drag) ISO 100, WB 5,600)

This doesn't seem normal.

Any response DJI?
2022-8-23
Use props
CloudVisual
First Officer
Flight distance : 25957795 ft
  • >>>
United Kingdom
Offline

JJungPhoto Posted at 8-23 08:20
https://youtu.be/A-vkvmZIGuU

Another Hyperlapse was taken the same day. Look at the clouds again for that "flicker" happening.
Edit: Thought I had a suggestion, but it wasn't right.
2022-8-23
Use props
Mzp
First Officer
  • >>>
United States
Offline

JJungPhoto Posted at 8-23 07:55
If every exposure is locked + WB is locked, why would there be any flickering outdoors without artificial light? It seems more like a hardware issue right?

Hi Jjung, it's a bug unfortunately  , reported it to DJI earlier as well. As a workaround, until DJI fixes it, you can use NeatVideo plugin for your app, i.e. if you use Davinci Resolve , NeatVideo plugin can be used to clear up flicking.
2022-8-23
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Mzp Posted at 8-23 12:29
Hi Jjung, it's a bug unfortunately  , reported it to DJI earlier as well. As a workaround, until DJI fixes it, you can use NeatVideo plugin for your app, i.e. if you use Davinci Resolve , NeatVideo plugin can be used to clear up flicking.

Yea I use Digital Anarchy Flicker Free. Which helped the 2nd example of the fluffy clouds to work.

Sadly the other one is too contrasty to fix in post. I own neatvideo also, so I'll give it a try.

Did DJI respond to you when you reported it? It's just extremely disappointing owning a $5.5k drone that cant even do what the Mavic 2 did flawlessly... (Not to mention the worble even with 0 wind, which Mavic 2 didn't have much issues with either)
2022-8-23
Use props
Mzp
First Officer
  • >>>
United States
Offline

JJungPhoto Posted at 8-23 14:41
Yea I use Digital Anarchy Flicker Free. Which helped the 2nd example of the fluffy clouds to work.

Sadly the other one is too contrasty to fix in post. I own neatvideo also, so I'll give it a try.

I hear you, those usually work for me. I believe DJI responded they would pass it to the engineering team.

Thanks, Mike.
2022-8-23
Use props
HarleyFlyer
lvl.4
Flight distance : 1356178 ft
United Kingdom
Offline

CloudVisual Posted at 8-23 05:50
As someone who professed to me in another thread that "i am a professional photographer - master level" I'm very surprised you apparently can't work out what white balance to use or how to correct it in post...

I'm not trying to be rude here, I just felt in the other thread that I was supposed to take heed on your words based on this title, when I've just read you're unable to set your own WB.

Fair point well made - but I am a photographer not a videographer - I have had no cause to need to adjust white balance in any single drone photo I have ever taken - I'm not shooting indoors with artificial light and i certainly don't carry a balance card around with me any more. I spotted this happening only in my last Hyperlapse - and tonight I have indeed cured the issue by taking a white balance reading - setting it to manual and letting the Hyperlapse run that way.

Every day is a school day...
2022-8-24
Use props
CloudVisual
First Officer
Flight distance : 25957795 ft
  • >>>
United Kingdom
Offline

HarleyFlyer Posted at 8-24 13:29
Fair point well made - but I am a photographer not a videographer - I have had no cause to need to adjust white balance in any single drone photo I have ever taken - I'm not shooting indoors with artificial light and i certainly don't carry a balance card around with me any more. I spotted this happening only in my last Hyperlapse - and tonight I have indeed cured the issue by taking a white balance reading - setting it to manual and letting the Hyperlapse run that way.

Every day is a school day...

If it helps, there's absolutely nothing different you need to do between video and photos when it comes to WB. Personally, I stick it to around 5000k and that'll do for any daytime shots. If you put it in AWB and then flick over to manual, you'd need to note what it suggested so that you can use that as a base in post to correct, given that the video won't output the temp in the metadata like it does with photos.
2022-8-24
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Mzp Posted at 8-23 21:12
I hear you, those usually work for me. I believe DJI responded they would pass it to the engineering team.

Thanks, Mike.

It'd be great to hear from anyone at DJI regarding the issue and if it's still being looked into.

@DJIStephen ?
2022-8-25
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Updated the initial post to be more straight to the point, as well as add in another video example. Hoping DJI can respond to this post please and let the users know what's happening with a launch issue that still plagues the camera.
2022-8-30
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

I have been experiencing these issues as well.  I thought I resolved them but they are still there.  It's driving me nuts to the point I decided to just ground the drone for most of the summer and do something else while waiting for a fix from DJI.  

I have posted several examples:












2022-9-4
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

Color-shifting Images

Look at the very top middle cloud.  You can see the color-shifting.  Going from cool to warm colors.  I always have WB on manual mode, not auto.    Hope this helps get the bottom of it.  This has been going far too long.   

It can be obvious to see if you compare the JPG versions.  The issue persists with the DNG.

52340401408_ee34d51ecc_5k.jpg   Cool 52340162211_a7db481451_5k.jpg   Warm


Uploaded them.

2022-9-6
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

Look at the very top middle cloud.  You can see the color-shifting.  Going from cool to warm colors.  I always have WB on manual mode, not auto.    Hope this helps get the bottom of it.  This has been going far too long.

Edit:  Having trouble uploading the second photo.  It can be obvious to see if you compare the JPG versions.  The issue persists with the DNG.
2022-9-6
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Thanks for sharing all these examples! I even sent a DM to the moderators and was ignored on the issue... Sad they can't give an official response on this issue andyet they're bringing another mavic 3 to market soon it seems?
2022-9-6
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

JJungPhoto Posted at 9-6 23:00
Thanks for sharing all these examples! I even sent a DM to the moderators and was ignored on the issue... Sad they can't give an official response on this issue andyet they're bringing another mavic 3 to market soon it seems?

I know, right?  It is crazy and irresponsible of them to be non-responsive especially with paying this much for the Mavic 3 Cine version.   They won't be regaining my trust ever again.  Not so easily anymore at least, assuming if they somehow fix these issues.
2022-9-11
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

SFC Posted at 9-11 21:37
I know, right?  It is crazy and irresponsible of them to be non-responsive especially with paying this much for the Mavic 3 Cine version.   They won't be regaining my trust ever again.  Not so easily anymore at least, assuming if they somehow fix these issues.

I had a DJI rep reach out over DM. I'll be uploading the original files to dropbox, if you have some you'd want to share as well, I can compile it into the same dropbox link (like your examples above) this could benefit the cause, so they can hopefully deliver a lot of these faulty clips to the engineers.
2022-9-11
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

JJungPhoto Posted at 9-11 22:50
I had a DJI rep reach out over DM. I'll be uploading the original files to dropbox, if you have some you'd want to share as well, I can compile it into the same dropbox link (like your examples above) this could benefit the cause, so they can hopefully deliver a lot of these faulty clips to the engineers.

Sure, I can do that!  How do I send them to you?
2022-9-15
Use props
sky_makai
Second Officer
Flight distance : 3097861 ft
  • >>>
United States
Offline

This is very disappointing.  Time lapses are one of my favorite uses for my cameras.  

My guess is that there's some tone mapping happening on the fly.  But in RAW that shouldn't be happening.  It seems like there's some processing happening even to the RAW files.  DJI 'should' fix this.

At this point you've got an entire YouTube channel made up of DJI Mavic 3 problems with Time Lapses.  Don't stop now...
2022-9-16
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

sky_makai Posted at 9-16 10:50
This is very disappointing.  Time lapses are one of my favorite uses for my cameras.  

My guess is that there's some tone mapping happening on the fly.  But in RAW that shouldn't be happening.  It seems like there's some processing happening even to the RAW files.  DJI 'should' fix this.

its a major disappointment. And still no official response from DJI other than brushing it under the rug.
2022-10-13
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

JJungPhoto Posted at 10-13 09:26
its a major disappointment. And still no official response from DJI other than brushing it under the rug.

Update #1. Back and forth with DJI Thor he replied and said he sent it onto the team and said to address the issue ASAP. So hopefully we'll see a firmware update before the new year? Fingers crossed...
2022-10-14
Use props
DRAGenDROP
First Officer
Flight distance : 24942208 ft
  • >>>
Netherlands
Offline

DarthSLR Posted at 8-22 05:54
Did you shoot in auto, or full manual?

Did you read?!
2022-10-27
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

Any idea if the "Fixed abnormal colors in DNG photos" addresses the hyperlapse issue?  I have not had a chance to update the drone yet, I may not be able to for a bit due to the college-related workload.
2022-11-3
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

SFC Posted at 11-3 08:19
Any idea if the "Fixed abnormal colors in DNG photos" addresses the hyperlapse issue?  I have not had a chance to update the drone yet, I may not be able to for a bit due to the college-related workload.

new firmware!? Oh man this sounds amazing because this wasn't just a hyperlapse issue either it did happen on photos. Fingers crossed ill check now.
2022-11-3
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

JJungPhoto Posted at 11-3 10:02
new firmware!? Oh man this sounds amazing because this wasn't just a hyperlapse issue either it did happen on photos. Fingers crossed ill check now.
ITS FIXED! As well as the Video WB issue! WOOHOO
Update: NOT fixed
2022-11-3
Use props
SFC
lvl.4
Flight distance : 8062845 ft
  • >>>
United States
Offline

JJungPhoto Posted at 11-3 13:28
ITS FIXED! As well as the Video WB issue! WOOHOO!

That's great news!!  Can't wait to fly as soon as I can!
2022-11-3
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

SFC Posted at 11-3 20:21
That's great news!!  Can't wait to fly as soon as I can!

well, we were lied to.

It is still prevalent, and if anything, it's gotten WORSE! Anger can't even put it lightly with my mood right now. I took so many hyperlapses in New Zealand that are absolute trash now because of DJI's false claims. This is ridiculous.
2022-12-6
Use props
Geo_Drone
Captain
Flight distance : 1532264 ft
  • >>>
Romania
Offline

JJungPhoto Posted at 12-6 15:38
well, we were lied to.

It is still prevalent, and if anything, it's gotten WORSE! Anger can't even put it lightly with my mood right now. I took so many hyperlapses in New Zealand that are absolute trash now because of DJI's false claims. This is ridiculous.

Have you tried also with AE locked? click on area on screen then keep it to appear AE locked...
2022-12-7
Use props
JJungPhoto
lvl.3
Flight distance : 532838 ft
  • >>>
United States
Offline

Geo_Drone Posted at 12-7 23:07
Have you tried also with AE locked? click on area on screen then keep it to appear AE locked...

Everything is set to manual. AE lock is for auto exposure.

As my post states the exposure is fine. It's literally bugging out in the corners with a tint WB issue in the clouds when the aperture is above 5.6. I'm a professional cinematographer with over 12 years experience and this is the worst camera issue I've ever been faced with. And spending 5k for the cine version and this happens is an absolute joke.
2022-12-7
Use props
Geo_Drone
Captain
Flight distance : 1532264 ft
  • >>>
Romania
Offline

JJungPhoto Posted at 12-7 23:16
Everything is set to manual. AE lock is for auto exposure.

As my post states the exposure is fine. It's literally bugging out in the corners with a tint WB issue in the clouds when the aperture is above 5.6. I'm a professional cinematographer with over 12 years experience and this is the worst camera issue I've ever been faced with. And spending 5k for the cine version and this happens is an absolute joke.

I know...I have seen this variations sometimes from sensor, as is heating, is giving wrong voltage and parameters are changed...In this particular situation if JPG are fine, then there is something wrong with a post-processing of DNG.
Only variable on DNG if is all manual is just the algorithm or the sensor itself...
Better be algorithm....
2022-12-8
Use props
fansd23a86d1
lvl.4

Thailand
Offline

JJungPhoto Posted at 12-7 23:16
Everything is set to manual. AE lock is for auto exposure.

As my post states the exposure is fine. It's literally bugging out in the corners with a tint WB issue in the clouds when the aperture is above 5.6. I'm a professional cinematographer with over 12 years experience and this is the worst camera issue I've ever been faced with. And spending 5k for the cine version and this happens is an absolute joke.

I think they quietly fixed it on the latest firmware (v01.00.1000). I have also been monitoring on this issue for long long time. Please try with the new firmware and see whether yours are fixed.
Updated 19/12/22: I have tried shooting in different scenes and confirm it is still NOT FIXED.
2022-12-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules