Please select Into the mobile phone version | Continue to access the computer ver.
Drone will not take-off
762 2 2022-9-15
Uploading and Loding Picture ...(0/1)

United States

My husband and I recently purchased our DJI FPV Drone (recently being a week ago), we have updated all the firmware (as needed), we made sure everything was at its full charge, we were in a recomended flying zone (checked on the app), we were able to do the flying practice and virtual tutorials in the app as well. Everything seemed like it was working well both in app and regularly. However, upon taking the FPV outside and trying to fly it in real time, it would not take-off. When turning on the FPV a warning comes on (in the goggles) asking if our propellers are correctly installed, it also says check to see if motor is working properly when trying to take-off, and then altogether it just will not take-off, start, or fly.

This has happened about 3 or 4 times now. We have tried taking the propellers off and puttting them back on, re-installing the firmware update, turning everything off and back on, and still have had zero success diagnosing what the issue is or how to fix said issue. It should probably be noted that the question of if our propellers are installed correctly has appeared (in the goggles) everytime we've turned the FPV on.

I have attached pictures of the drone in question to see if by chance we -do- actually have the propellers installed incorrectly. If anyone else is having this problem and has fixed it some insight is deeply appreciated, seeing as how this product is brand new and we have not been able to fly it once. Thanks to anyone in advance that can help us get our FPV in the air!
Use props
DJI Stephen
Super Moderator

Hello there Ash.Walker. I am sorry for the trouble this has caused and thank you for reaching out. Since we are having this issue with your new DJI FPV and you have done several troubleshooting steps and still the issue persist. I would recommend for you to contact our DJI Support Team at for further assistance. We will do our best to help you and give out the best resolution for the said issue. Again, I am sorry and thank you.
Use props
Flight distance : 4861152 ft

Hi, I think the default is to display that message every time until you say "Don't show again". You do have the props installed correctly by the looks of it, are you in normal mode when trying to takeoff? Is it giving you a message when you do the CSC motor start command?
Use props
You need to log in before you can reply Login | Register now

Credit Rules