Please select Into the mobile phone version | Continue to access the computer ver.
Activation Failed/Firmware error : DJI FPVGoggles v2
438 26 11-19 00:15
Uploading and Loding Picture ...(0/1)
o(^-^)o
JoeJoeJoe
lvl.1

France
Offline

This is a repost as i guess i made this thread in the wrong forum (Firmware & Software).


Hello,

I just received my DJI FPV Goggles v2 this week with a Caddx Air Unit.
Had no problem to bind the Goggles to the Air Unit.
But i can't activate it through the DJI Assistant v2 (any version, tried them all including FPV) downloaded on DJI website.

The assistant recognize the Goggles v2 as i plug it and ask for activation. I then click next and next... and get this message: "Activation Failed" "Firmware error"
As i bind successfully to my Air Unit i can have a video feedback in the goggles but no way to access any other function nor the menu inside the goggles.

I already tried with all DJI Assistant V2 Version (FPV, Drone Consumer and others...), restarting my computer after every installation.
Tried within different configurations (Disabling Firewall and anti-malwares during the whole process and before installation, running as admin, Tried to activate with and without Air Unit connexion, Starting the Software first and then the goggles, checking different parameters in DA2 settings, etc...)

Looking through the forums i can see some people had that problem in 2021 and solved it thanks to DJI_Aftersales IDs that could allow them to pass that activation process and let them downgrade/upgrade to another firmware. Those IDs no longer work now.

My last idea is to ask a Goggle FPV v2 owner his IDs so i can try this trick. but i don't know any

PS : I had no problem activating the Air Unit.

Help

Sans titre.jpg
11-19 00:15
Use props
DJI Wanda
Administrator
Offline

Hello, there. Sorry for your inconvenience. Would you please tell us your purchase channel and time?
11-19 00:32
Use props
JoeJoeJoe
lvl.1

France
Offline

Hello, Thank you for replying
I'm not sure of what you're asking

The Goggles are apparently in public channel and i purchased it the 13/11/2022
I'm in France.
Some bug just allowed me to ignore the activation tab in DA2 and i can see i'm on current firmware v01.00.0606 .
It is the only option as no other firmware version show up.
Tried to "refresh" it but that didn't work, i get through the same activation process as i restart DA2.

Message update: Today I tried :
with DJI Fly but i don't have the FPV drone nor the OTG cable to connect correctly to my phone.
with another DJI account which had already DJI FPV Goggles v2 activated in the past
with a virgin SD card in



Sans titre.jpg
11-19 01:29
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

JoeJoeJoe Posted at 11-19 01:29
Hello, Thank you for replying
I'm not sure of what you're asking

Thanks for the detailed information. May I ask if the Goggles V2 has been switched to DJI Digital FPV system mode? Please try to switch to DJI FPV mode and try to upgrade and activate it again.
11-20 00:53
Use props
JoeJoeJoe
lvl.1

France
Offline

As i don't have any access to the Goggles V2 menu, i can't switch to any different mode.
5D button and any other button will not respond

11-20 00:59
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

JoeJoeJoe Posted at 11-20 00:59
As i don't have any access to the Goggles V2 menu, i can't switch to any different mode.
5D button and any other button will not respond

We apologize for any inconvenience caused by this issue. Our engineers have located the problem, and will update DJI Assistant 2 (Consumer Series) on Nov 22, 2022. By then, connect your goggles to a computer, and update the firmware to complete the activation. Once again, we would like to express our sincere apologies for your negative experience. Thank you for your understanding.
11-20 02:48
Use props
JoeJoeJoe
lvl.1

France
Offline

Ok, i will let you know how it goes by then.
Thank you !
11-20 04:34
Use props
Clair De Lune
lvl.1

Offline

DJI Mindy Posted at 11-20 02:48
We apologize for any inconvenience caused by this issue. Our engineers have located the problem, and will update DJI Assistant 2 (Consumer Series) on Nov 22, 2022. By then, connect your goggles to a computer, and update the firmware to complete the activation. Once again, we would like to express our sincere apologies for your negative experience. Thank you for your understanding.

Hi, i have the exact same problem of JoeJoeJoe, hope your update will work.

Thanks
11-21 10:32
Use props
aero1199
lvl.2
Flight distance : 372192 ft
  • >>>
New Zealand
Offline

DJI Mindy Posted at 11-20 02:48
We apologize for any inconvenience caused by this issue. Our engineers have located the problem, and will update DJI Assistant 2 (Consumer Series) on Nov 22, 2022. By then, connect your goggles to a computer, and update the firmware to complete the activation. Once again, we would like to express our sincere apologies for your negative experience. Thank you for your understanding.

We are also having this issue 2x sets of brand new goggles.

PC, Mac (same failed message as original post) and DJi Fly app (wont connect)

Shouldn't it be "dji assistant FPV series" be updated?

Please help us!
11-21 17:36
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

JoeJoeJoe Posted at 11-20 04:34
Ok, i will let you know how it goes by then.
Thank you !

Thanks for your understanding. If the issue still exists, please let us know.
11-21 19:54
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Clair De Lune Posted at 11-21 10:32
Hi, i have the exact same problem of JoeJoeJoe, hope your update will work.

Thanks

We are sorry for the inconvenience. You are recommended to keep close attention to the update on our official web: http://dji.com. If the issue still exists then, please feel free to contact us.
11-21 19:55
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

aero1199 Posted at 11-21 17:36
We are also having this issue 2x sets of brand new goggles.

PC, Mac (same failed message as original post) and DJi Fly app (wont connect)

We are sorry for the inconvenience. We will update DJI Assistant 2 (Consumer Series), you can try to activate the drone on that version to see if it works.
11-21 22:15
Use props
djiuser_5N04CfeiV1Fk
lvl.1

France
Offline

Hi everyone, getting the same error (activation failed, firmware error) while trying to activate the googles V2 with either DJI assistant consumer series or DJI assistant FPV series.
Hope we will have the dji assistant update today but I don’t really hope on a move from DJI, I’ve talked with peoples who have that same issue since 4 month and no changes. That’s not correct from you DJI
11-22 00:54
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

djiuser_5N04CfeiV1Fk Posted at 11-22 00:54
Hi everyone, getting the same error (activation failed, firmware error) while trying to activate the googles V2 with either DJI assistant consumer series or DJI assistant FPV series.
Hope we will have the dji assistant update today but I don’t really hope on a move from DJI, I’ve talked with peoples who have that same issue since 4 month and no changes. That’s not correct from you DJI

Hi there, we are sorry for this issue. Hope you can patiently wait for the update of DJI Assistant 2 (Consumer Series) on Nov 22, 2022. If the issue still cannot be solved, please let us know.
11-22 03:51
Use props
Clair De Lune
lvl.1

France
Offline

DJI Mindy Posted at 11-22 03:51
Hi there, we are sorry for this issue. Hope you can patiently wait for the update of DJI Assistant 2 (Consumer Series) on Nov 22, 2022. If the issue still cannot be solved, please let us know.

I installed the new assistant 2 (consumer series) V2.1.14 and still won't activate.
11-22 05:12
Use props
Clair De Lune
lvl.1

France
Offline

Ok it worked, after i installed the latest version of Assistant 2 (Consumer series) i clicked on "Activate later" under the activation icon, i updated the goggles to the latest firmware from today and then i activated the goggles V2.
Thank you very much for the update that finaly work!

11-22 06:43
Use props
JoeJoeJoe
lvl.1

France
Offline

Hello,
It worked fine for me too.
As Clair De Lune said,
had to press "activate later" and then update (to the last and only firmware available v01.00.0607) before going back to the activation tab.
Tried first to refresh my v01.00.0606 but that didn't work

Thank you for your reactivty!
11-22 11:26
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Clair De Lune Posted at 11-22 06:43
Ok it worked, after i installed the latest version of Assistant 2 (Consumer series) i clicked on "Activate later" under the activation icon, i updated the goggles to the latest firmware from today and then i activated the goggles V2.
Thank you very much for the update that finaly work!

Thanks for the update. We are glad to know it works. If there is anything else we can help you with, please feel free to contact us.
11-22 19:52
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

JoeJoeJoe Posted at 11-22 11:26
Hello,
It worked fine for me too.
As Clair De Lune said,

Hi Joe, thanks for the update. Yes, please upgrade it to the latest firmware version and then activate it. Should you have any further inquiries, please feel free to contact us. Thanks for your support of DJI.
11-22 19:54
Use props
djiuser_Pvf21p95V2Ue
lvl.1
Flight distance : 3612 ft

Indonesia
Offline

DJI Mindy Posted at 11-22 19:54
Hi Joe, thanks for the update. Yes, please upgrade it to the latest firmware version and then activate it. Should you have any further inquiries, please feel free to contact us. Thanks for your support of DJI.

Hi Mindy,
Is it possible for the new firmware (V01.00.0607) to fully support canvas mode on vista? as i already have unrooted goggles and vista unit
11-24 01:23
Use props
DJI Natalia
Administrator

Offline

djiuser_Pvf21p95V2Ue Posted at 11-24 01:23
Hi Mindy,
Is it possible for the new firmware (V01.00.0607) to fully support canvas mode on vista? as i already have unrooted goggles and vista unit

Hi, there.
We are sorry it can not support canvas mode on vista.
Thank you for your understanding.
11-25 02:56
Use props
Guznoer
lvl.1
Flight distance : 3612 ft

Indonesia
Offline

DJI Natalia Posted at 11-25 02:56
Hi, there.
We are sorry it can not support canvas mode on vista.
Thank you for your understanding.
too bad , cause i just bought Goggles v2 a few days ago on a discounted price, thinking could use it with my fpv drone with vista in it, but due to activation problem in DA2 I had to update the fw to the newest version
11-25 04:37
Use props
DJI Natalia
Administrator

Offline

Guznoer Posted at 11-25 04:37
too bad , cause i just bought Goggles v2 a few days ago on a discounted price, thinking could use it with my fpv drone with vista in it, but due to activation problem in DA2 I had to update the fw to the newest version

We are sorry for the inconvenience caused.
We will also forward your feedback to the relevant team for evaluation.
And may we know if your activation problem is resolved now?
If there is anything that we can help with, please just let us know.
Thank you.
11-29 00:03
Use props
Guznoer
lvl.1
Flight distance : 3612 ft

Indonesia
Offline

DJI Natalia Posted at 11-29 00:03
We are sorry for the inconvenience caused.
We will also forward your feedback to the relevant team for evaluation.
And may we know if your activation problem is resolved now?

is it possible to downgrade the firmware ? as i just upgrade the fw for activation purpose
11-30 04:39
Use props
DJI Wanda
Administrator
Offline

Guznoer Posted at 11-30 04:39
is it possible to downgrade the firmware ? as i just upgrade the fw for activation purpose

Hello, there. May we know which firmware version did you update your devices to?
12-1 04:09
Use props
Guznoer
lvl.1
Flight distance : 3612 ft

Indonesia
Offline

DJI Wanda Posted at 12-1 04:09
Hello, there. May we know which firmware version did you update your devices to?

01.00.06.07 , seems like everybody says we can’t downgrade it… but just want to make sure, is there any possible way to downgrade it, let say, to 01.00.06.06 ?
12-1 19:03
Use props
DJI Wanda
Administrator
Offline

Guznoer Posted at 12-1 19:03
01.00.06.07 , seems like everybody says we can’t downgrade it… but just want to make sure, is there any possible way to downgrade it, let say, to 01.00.06.06 ?

Sorry for the late response. Would you please screenshot the firmware version for us?
yesterday 00:03
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules