Please select Into the mobile phone version | Continue to access the computer ver.
SLOWLY LOSES ALTITUDE WHILE HOVERING
1794 15 2015-8-14
Uploading and Loding Picture ...(0/1)
o(^-^)o
Fred1969
lvl.2

United States
Offline

My P3A stays steady but slowly loses altitude while hovering.  Is there something I can do to fix that?
2015-8-14
Use props
bradneal24
lvl.3
United States
Offline

Have you recalibrated everything? (IMU & compass)
2015-8-14
Use props
sdharris
lvl.3
Flight distance : 384967 ft
United Kingdom
Offline

What firmware are you on, do you have VPS enabled, what altitude are you hovering at?
2015-8-14
Use props
Fred1969
lvl.2

United States
Offline

bradneal24 Posted at 2015-8-15 03:46
Have you recalibrated everything? (IMU & compass)

Yes everything was recalibrated after I noticed it doing it and it did not stop it.  It's slow but enough to make it a problem if you are filming something or taking multiple pictures of something.  You have to throttle it back up.
2015-8-14
Use props
bradneal24
lvl.3
United States
Offline

Like sdharris asked, is VPS enabled?
2015-8-14
Use props
bradneal24
lvl.3
United States
Offline

Oh, and one other thing. Try taking the dog off of it.
2015-8-14
Use props
skine75
lvl.2

United States
Offline

you can adjust the throttle gain so that this doesn't occur.  In a previous post "THE guide to the Phantom" someone mentioned that ideal settings for the throttle gain were .30 compared to the standard .40.  I tried this to see what would happen at that is exactly what mine did, just a slow decent.  I changed it back to .40 and it was perfect.  If yours is already at .40, try .50 and see if that works.
2015-8-14
Use props
Fred1969
lvl.2

United States
Offline

bradneal24 Posted at 2015-8-15 04:06
Like sdharris asked, is VPS enabled?

VPS is on.
2015-8-14
Use props
Fred1969
lvl.2

United States
Offline

skine75 Posted at 2015-8-15 04:13
you can adjust the throttle gain so that this doesn't occur.  In a previous post "THE guide to the P ...

Throttle gain is set at .40.  If this continues I will try tweaking that setting.
2015-8-14
Use props
Fred1969
lvl.2

United States
Offline

bradneal24 Posted at 2015-8-15 04:08
Oh, and one other thing. Try taking the dog off of it.

Do you think he is too much weight?  I'll try putting him on a diet.
2015-8-14
Use props
Fred1969
lvl.2

United States
Offline

sdharris Posted at 2015-8-15 03:55
What firmware are you on, do you have VPS enabled, what altitude are you hovering at?

It has the latest firmware also.  It has about ten flights with no noticeable loss of altitude.  It just started doing this today.  I recalibrated everything and checked everything I could think of.  Going to try a couple more flights and see if it continues.
2015-8-14
Use props
dlongcamp
lvl.4
Flight distance : 755988 ft
  • >>>
United States
Offline

did you calibrate your sticks?  Maybe that would help.
2015-8-14
Use props
sermole
lvl.2

United States
Offline

the propellers are in a good shape?
2015-8-14
Use props
myTehi
lvl.1

United States
Offline

i am curious about this mine has started doing the same thing.

P3A
latest FW
VPS on
Calibrations completed ... good readings
props in good shape

No dog on mine  
2015-8-14
Use props
Fred1969
lvl.2

United States
Offline

myTehi Posted at 2015-8-15 06:05
i am curious about this mine has started doing the same thing.

P3A

That eliminates having to put him on a diet then.
2015-8-14
Use props
HunterBrooks
lvl.4

United States
Offline

I had the same problem.  But once I recalibrated the IMU, it stopped drifting.
2015-8-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules