Please select Into the mobile phone version | Continue to access the computer ver.
DJI Fly for laptop or PC?
9750 4 2023-2-3
Uploading and Loding Picture ...(0/1)
o(^-^)o
777Brad
lvl.3

United States
Offline

I have an Android (moto g(7) play) that it would appear, is not able to download the DJI Fly app.

Can I get DJI Fly for laptop or PC?

Thank you



2023-2-3
Use props
DJI Gamora
Administrator

Online

Hi, 777Brad. Thank you for reaching out and we're sorry for the inconvenience. Regretfully, the DJI Fly app can only be installed on Android and iOs mobile phones. May we please ask how are you trying to download the DJI Fly App? Please try downloading it from our direct website using your Moto G7: (https://www.dji.com/downloads/products/dji-fpv). We also have DJI Assistant 2 that can be installed on a PC however, the only same function that they have is by updating the devices.
2023-2-3
Use props
777Brad
lvl.3

United States
Offline

Thank you for your fast reply.

It is not working, perhaps because it is a moto g(7) play, which is not listed among the supported Android devices.
Of course,  I would prefer to find a way to make my moto g(7) play work, however if I have to buy a new phone, then I have 2 questions

1.) On any of these pages for DJI Fly App;
https://www.dji.com/downloads/products/dji-fpv
https://www.dji.com/downloads/djiapp/dji-fly
https://www.dji.com/dji-fpv/downloads
Below the iOs area is says "For older versions: click to download"
However it does not say what older versions are compatible.   What older versions are compatible?

2.) On this page for DJI Virtual Flight;
https://www.dji.com/downloads/djiapp/dji-virtual-flight
it says "Requires iOs 12.0 or above."   
But then it goes to say   "Compatible with Recommended Devices: " many of which are below iOs 12.0
Please clarify.

Thank you again
2023-2-4
Use props
DJI Paladin
Administrator
Flight distance : 318 ft

Offline

777Brad Posted at 2-4 08:35
Thank you for your fast reply.

It is not working, perhaps because it is a moto g(7) play, which is not listed among the supported Android devices.

Hi there. Sorry for the late response. Kindly please refer to the information below.

1.) Below the iOs area it says "For older versions: click to download" However it does not say what older versions are compatible. What older versions are compatible?

If you are using an iOS device with iOS version 11.0 or above and it is not listed on our website, you may click the link and scan the QR code or open the link using the safari browser to download the DJI Fly app.

2.) it says "Requires iOs 12.0 or above." But then it goes to say   "Compatible with Recommended Devices: " many of which are below iOs 12.0 Please clarify.

If you are using for example iPhone 8, you may update the iOS version of the mobile device to iOS version 12 or above to use the DJI Fly app. Should you have other inquiries, please don't hesitate to reach us. Thank you.
2023-3-20
Use props
sebadia
lvl.1
Flight distance : 723064 ft
Spain
Offline

how old is this thread?
2023-9-28
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules