Please select Into the mobile phone version | Continue to access the computer ver.
Phantom 3 Video issues - Zebra lines and Purple distortion
16517 35 2015-8-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
ujanbasu18
lvl.1

United States
Offline

I was having problems with my Gimbal facing the wrong direction. To fix the issue I realigned the gimbal and tightened the little hex screw on the shaft which made the gimbal face straight ahead again.

I figured everything was normal now but I took it up to fly and I noticed my DJI GO app (on Android) was lagging more than usual and showing me some odd artifacts along with randomly losing and regaining the live feed. I thought this was only in the transmission of the video but when I watched the video off the sd card I was seeing the same problems that I was seeing while shooting. I'm getting these weird zebra lines in overexposed areas and random purple distortion as you can see in the video below. When I switch into photo mode I the zebras instantly disappear and I can take photos with no issue.



Anyone have any ideas what could possibly be wrong or any troubleshooting things I can do to possibly fix it.

*keep in mind that when my gimbal was messed up and facing left I was not having any of these video issues except for the fact that there was a landing gear in my shot. All these issues started happening after the fix.

*DID IMU AND GIMBAL CALIBRATION. FIRMWARE IS UP TO DATE ON EVERYTHING INCLUDING APP AND CONTROLLER

2015-8-19
Use props
rayrokni
Captain
Flight distance : 8139875 ft
United States
Offline

zebra lines are over exposure warning which you can turn off in the camera setting just above the shutter button on right side of your app screen
2015-8-19
Use props
rayrokni
Captain
Flight distance : 8139875 ft
United States
Offline

as far as the purple issue, make sure ribbon cables are firmly inserted, it could be a transmission issue also, try putting device in airplane mode and choose a manual channel, 20 works great for me, and drop the video transmission rate to 4 instead of default 6
2015-8-19
Use props
ujanbasu18
lvl.1

United States
Offline

rayrokni Posted at 2015-8-20 02:52
zebra lines are over exposure warning which you can turn off in the camera setting just above the sh ...

It is definitely not the typical zebra lines on a camera so that you can monitor the overexposure. Because (in the android app at least) there is no way to do zebra monitoring only histogram. and either way when have you ever heard of a camera baking in the zebra lines in an image
2015-8-19
Use props
stevedunk
lvl.2

United States
Offline

Need assistance with video mode. What is the best video setting to eliminate a jerky motion feedback. I tried the 4k high Def resolution with 24 frame rate but the video seems to be staggered. It only gives a smooth video when I shoot at a 720p setting. Thanks for your help.
2015-8-22
Use props
maciej.drelicho
lvl.1

Poland
Offline

I have exactly the same effect, the stripes on bright sky. This is not overexposure thing, this is recorded in the video on the sd card. I have it in my P3A since the beginning. I bought it 2 days ago. I use iPhone6 and iPad Mini 3, firmware is not updated to the newest one. It must be linked to seetings of the camera. I hope. Solution please.
2015-9-11
Use props
llll
lvl.2

United States
Offline

I just discovered that I've got the same issue -- stills are perfectly fine, but 4K video (mp4 on the SD card directly) is a periodically purple mess w/ zebra stripes in the overblown highlights. My P3P just came back from repairs, so I haven't had a chance to take it fully through the ropes and test things out. Next step is to see if this crap shows up on all video modes or only 4K. I use an Android tablet and phone (maciej.drelicho was all Mac w/ the same problem), so it's not a DJI Go app platform issue. The video I was shooting today was in exceptionally sunny conditions, but if that's the issue, then surely DJI's sensor and software can find a better way to deal w/ input overload?!?
2015-9-20
Use props
DJI-Tim
DJI team

Hong Kong
Offline

rayrokni Posted at 2015-8-20 02:52
zebra lines are over exposure warning which you can turn off in the camera setting just above the sh ...

this one doesn't looks like a overexposure warning... it is a camera problem
2015-9-20
Use props
DJI-Tim
DJI team

Hong Kong
Offline

for me it looks like it needs to be send in
2015-9-20
Use props
llll
lvl.2

United States
Offline

@DJI-Tim: as long as the turnaround for repairs are in excess of 6-7 weeks, the "sending it in" option gets really old really fast. I literally just got my P3P back after 8 weeks of repairs at DJI, and now I discover that it's come back with this banding issue when I try to shoot video. It'd be exceptionally lame if the only remedy were to send it back and wait another x weeks.
2015-9-21
Use props
markurski
lvl.3
Flight distance : 2816900 ft
  • >>>
United States
Offline

llll Posted at 2015-9-22 04:10
@DJI-Tim: as long as the turnaround for repairs are in excess of 6-7 weeks, the "sending it in" opti ...

Any updates to this thread?  I just got my P3 Pro back from the repair depot in CA and am now having these Zebra lines and purple/magenta flashes across the screen in both the recorded SD video and on the iPad mini screen.  I didn't have these issues before I sent it in!  Any other ideas?
2015-10-16
Use props
jjejfjf
Banned

United States
Offline

Tip: the author has been banned or deleted automatically shield
2015-10-16
Use props
matthew
New

Canada
Offline

ujanbasu18@gmai Posted at 2015-8-19 14:22
It is definitely not the typical zebra lines on a camera so that you can monitor the overexposure. ...

I have the exact same problem, but I get those lines not only in hotspots, but also in the shadows. Do you know if there is a recall of this issue or is it covered by warranty?
2015-10-24
Use props
matthew
New

Canada
Offline

maciej.drelicho Posted at 2015-9-11 11:51
I have exactly the same effect, the stripes on bright sky. This is not overexposure thing, this is r ...

Same problem for me too.... damn it.
2015-10-24
Use props
didit28
lvl.1

Indonesia
Offline

same problem...It still can took a picture and video and previewed them in the gallery but the image on the display is distorted...so it is like flying blind
2016-4-28
Use props
andynewson01
lvl.2
Flight distance : 62100 ft
United Kingdom
Offline

Hi mate you will find this is your frame rate on your tablet or phone is not fast enough after filming you need to edit on pc or laptop had same problems hope that helps you
2016-4-28
Use props
didit28
lvl.1

Indonesia
Offline

Dear experts,

Does anyone know what cause this error?, Mine is DJI Phantom 3 Advanced. I still could take a picture and previewed it in the gallery, but when I press the video recording button...the display is became freeze and only black and white. I also get the "no signal" message...please help
IMG_20160428_184740.jpg
2016-5-1
Use props
jeffreytaylor24
New

United States
Offline

Bump. I'm on my wedding trip in Alaska and i am getting the zebra and purple distortion. I removed the gimbal and reinserted the cables. Did anyone ever find a fix?
2016-5-5
Use props
ryan209
lvl.4

United States
Offline

jeffreytaylor24 Posted at 2016-5-5 12:42
Bump. I'm on my wedding trip in Alaska and i am getting the zebra and purple distortion. I removed t ...

Yes,  I would say if the purple lines and such are included in the SD card videos, then its a strong possibility the ribbon cable is damaged.   I had the same issue, swapped out for a new OEM DJI ribbon cable,  and was back to operating normally.   The old cable had no visible defects either but apparently was damaged internally.
2016-5-5
Use props
lee65
lvl.1

Australia
Offline

ryan209 Posted at 2016-5-6 05:00
Yes,  I would say if the purple lines and such are included in the SD card videos, then its a stro ...

Thank you for your post , i have had the same issue, with purple lines in video, ive swapped out the ribbon cable and the purple lines are gone, but am now having different issues each time the ribbon is seated, and mainly on the camera (still) image side of things, does any one know what the numbering on the ribbon cable is, is it thickness of cable, I purchased a non genuine cable ( mistake now im thinking) and the numbers are off by 0.1 but could  explain the issues if the ribbon isnt seating correctly each time due to being a thinner cable.

cheers lee.
2016-5-20
Use props
joshuab86
New

Switzerland
Offline

Hi guys, is getting the ribbon replaced the only solution here? Looks like @lee65 had limited success with that. Having the zebra bars corruption in the highlights too.
2016-8-25
Use props
anthony4
lvl.1

United Kingdom
Offline

Getting these issues to, can DJI please help? This is clearly a common issue
2016-10-31
Use props
fans19dc1529
New

Offline

I have the zebra lines issue as well on my P3P, and now it also shows on stills.
2016-11-1
Use props
fans19dc1529
New

Offline

Here's my zebra lines on my P3P.
IMG_0802.JPG
2016-11-1
Use props
Geebax
Captain
Australia
Offline

fans19dc1529 Posted at 2016-11-2 18:17
Here's my zebra lines on my P3P.

I'm not surprised, that image is totally over-exposed. Try adjusting the exposure or put it in auto-exposure mode.
2016-11-1
Use props
fans5eb35c0b
New

United States
Offline

Geebax Posted at 2016-11-1 23:50
I'm not surprised, that image is totally over-exposed. Try adjusting the exposure or put it in auto-exposure mode.

I have the same problem purple lines and green lines tried everything someone help!!!
2017-1-2
Use props
Forest
lvl.1

Australia
Offline

Hi guys, I use my drone for aerial mapping and I'm getting purple images on the SD card....I've tried different cards and reformatting to no avail...... I shoot in auto, did any of you guys in this thread fix your problems?
Does anyone have any ideas?

Oh and its a P4
edit .........how do I upload a photo?
2017-1-28
Use props
Forest
lvl.1

Australia
Offline

Dropbox link
2017-1-28
Use props
Forest
lvl.1

Australia
Offline

double post sorry
DJI_0048 (Large).JPG
DJI_0048 (Large).JPG
2017-1-28
Use props
Delta Z
lvl.1

United States
Offline

I am having this problem to a lesser extent with a P3P right out of the box. Would an ND Filter solve the problem?
2017-2-18
Use props
Geebax
Captain
Australia
Offline

Delta Z Posted at 2017-2-18 11:34
I am having this problem to a lesser extent with a P3P right out of the box. Would an ND Filter solve the problem?

Try setting a fixed colour temperature in settings, disable the auto colour temperature mode. An ND filter is only really useful for shooting video, not still photos, and then only if it is a very bright day.

2017-2-18
Use props
Delta Z
lvl.1

United States
Offline

These issues are with video. Not stills.
2017-2-19
Use props
Delta Z
lvl.1

United States
Offline

http://www.phantompilots.com/threads/purple-lines-in-videos-pictures-when-using-my-p3p.68783/
2017-2-21
Use props
djiuser_Z0cxTUz
lvl.1

United States
Offline

Jeeez after reading all of these forums... finally i spent a good hour lowering my setting down on my video recording until i have the highest resulution possible without the picture being distorded with My video had Green zebra strips.... so my setting on the video were MP4 at 1920x1080 at 30fps.... so after a trip of aerial videos and come back to view them of all green zebra strips... i got this one figured out
2018-1-13
Use props
Geebax
Captain
Australia
Offline

djiuser_Z0cxTUz Posted at 2018-1-13 19:09
Jeeez after reading all of these forums... finally i spent a good hour lowering my setting down on my video recording until i have the highest resulution possible without the picture being distorded with My video had Green zebra strips.... so my setting on the video were MP4 at 1920x1080 at 30fps.... so after a trip of aerial videos and come back to view them of all green zebra strips... i got this one figured out

Post a photo of what you are talking about if you want some help.
2018-1-13
Use props
djiuser_2piCLKIViWgi
lvl.1
United States
Offline

My P3 4K has the stripes but no purple haze and the stripes do not show in videos or photos, only on the live feed. I can adjust the lines out but then the image or video is too dark.
2019-3-13
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules